Asynchronous I2S FIFO project, an ultimate weapon to fight the jitter

I would start with Volumio and known driver first.

Do you get a “lock” led light on you dual 9038 DAC?

I assume you are using the linearPi to power the Rpi and dirty side of FiFoPi Q7. Have you set the jumpers correctly on the stationPi pro so that single power supply can be used?
Yes I get correct lock led on dac board, power jumpers are correct. All fiopiq7 led appear correct. Led change to dsd when I send dsd as well.

This is test build setup, but wire is all red because it's 99.99% sold core 14 gauge copper in Teflon. Will replace with my occ kimber latter. I have checked voltage and wiring very close and everything has power and correct voltage to the i/v board when measured.

Dirty side has a ucconditoner but not in pic as not needed for testing atm.

Rpi4 with gentooplayer and same exact setup works no problem with usb output to another ammenero based dac...although here it's just Rpi4 usb to standalone dac using the ammenero board.
Can someone please help me? I've been trying to fix this four eight hours straight now and I'm about at my end.

I'm clueless on anything Ian-DAC-related, but I troubleshooted Q3 a few years ago. Did you mention you have AudioLinux?

I think I need to take this week off because my Long COVID makes me collapse to the floor so I'm thinking of taking it easy.

I can try to look up my config.txt since you are a fellow solid core user. My memory is wiped so I need to reverse engineer a bit as I can't remember the driver. RPI-DAC?
Yes any help would be appreciated.

Audiolinux on server (can't say enough good about this) with roon/hqplayer embedded/dirreta host - >>> raspberry pi based streamer running gentoplayer (also best software imo for rpi but audiolinux might be better)

This works without hicup to same rpi4 used in Ian build, but usb out to a different ammenero usb input dac.
Rpi4 with gentooplayer and same exact setup works no problem with usb output to another ammenero based dac...although here it's just Rpi4 usb to standalone dac using the ammenero board.

I wasn't aware of Diretta for PC <-> RPi communication. I don't need but nice to know it is there. I use AudioLinux PC + Microsoft Fonts + Nvidia DKMS + Steam for Gaming Only. It's nice for the whole OS to load in RAM and for my Games to load in RAM. My USB Optical powered by UcPure makes Gaming sound like I'm playing over Toslink. Maybe one day I will use it for actual Music. My future project is to install AudioLinux PC on Steam Deck OLED since SteamOS is Arch-based and can possibly dual-boot. I love using AudioLinux PC just for general purpose use as it's so snappy and since I run in RAM, nothing gets saved so I don't have to constantly clear caches. Reboot and I have a fresh desktop.

Anyways. My RPi Audio System has been down until I receive my StationPis, so my fresh install of AudioLinux on the RPi has non-existent Ian Drivers. I booted RPi and was wondering where the heck is the driver. I need to look into the archives. Check back in 30 minutes.

I recommend installing Squeezelite so you can squeezelite -l from the command line to list all your available audio devices. Make sure to start the squeezelite service before running squeezelite -l.
Last edited:
My guess is something to do with a damn mute channel or something... I can't figure it out for the life of me.

A mute issues... Mute cable? Trying now without receiver pi II, using monitor pi pro with ddc off... Can't get this mute on the display to go away no matter what I do, 44.1, higher, dsd, dop natta. Dsd and dop don't show mute, but they just have no sound but lights change correctly...

Does it matter station pi pro shows controller led?


  • 20231113_202719.jpg
    419.1 KB · Views: 81
  • 20231113_202713.jpg
    480.1 KB · Views: 74
  • 20231113_202708.jpg
    439.5 KB · Views: 82
  • 20231113_202708.jpg
    439.5 KB · Views: 82
  • 20231113_202700.jpg
    466.4 KB · Views: 80
  • 20231113_202558.jpg
    423.8 KB · Views: 77
  • 20231113_202538.jpg
    311.8 KB · Views: 81
  • 20231113_202700.jpg
    466.4 KB · Views: 78
  • 20231113_202527.jpg
    377.4 KB · Views: 78
Here's my config.txt snapshop January 2022 or 2023:

# See /boot/overlays/README for all available options #dtoverlay=vc4-kms-v3d initramfs initramfs-linux.img followkernel dtoverlay=disable-bt dtparam=i2c_arm,i2s dtparam=audio=off dtoverlay=rpi-dac dtoverlay=gpio-ir,gpio_pin=25 dtparam=i2c_arm=on enable_uart=1 arm_freq=1500 force_turbo=1 boot_delay=1

As you know, AudioLinux constantly updates so config is dynamic so it may vary present day.

The key here is dtoverlay=rpi-dac and maybe dtparam-i2c_arm,i2s and dtparam=audio=off

I can't remember but if you sqeezelite -l, you should see hw:CARD=sndrpirpidac or something similar

squeezelite is nice to troubleshoot. if your squeezelite.conf is correct with the sndrpipridac driver, your FiFoPi should light up if clocks are installed correctly once you start squeezelite service. If you shutdown squeezelite service, the FiFoPi light should turn off.

I'm still waiting on the StationPi, so can't comment if this works the same on StationPi.
My guess is something to do with a damn mute channel or something... I can't figure it out for the life of me.

Keep an eye out on the results of squeezelite -l for Audio devices. Without the proper driver, I don't think it goes further.

Also, I'm asumming there is a FiFoPi in the chain. If it's just a DAC, I'm hoping it behaves similar to FiFoPi. I'm just hoping a light activates when you start squeezelite with the proper driver.
Looks like the DAC is similar to the FiFo:



  1. Find driver by locating using squeezelite -l
  2. Insert that driver into squeezelite.conf
  3. Start squeezelite service. That should activate D2 and/or D3.
From there, you know at least the base level is working before proceeding to the Application level.

Sometime, aplay displays your Audio devices too:

aplay -l
Last edited:
Another possible is power the same or another RPi with the official Raspberry Pi Power Supply, then add just the HAT DAC via GPIO.

If just the base RPi and HAT DAC play nice with one another, you should be able to replicate that on the StationPi.

But be careful as you are in the "Pull Out Your Hair" mode, so patiently disassemble and start fresh.

The StationPi has so much variance because your dealing with 40 pin + 40 pin, if even one pin is off, nada, zilch.
Wish you luck fellow audiolinux, solid core user.

Best approach is just to start from scratch with a traditional stack, but don't add any HATs that are configured for direct 3.3V use. Extremely important as if you shorted any HATs to run only via 3.3V direct, you possibly cannot put those HATs on a traditonal stack.

If the traditional stack works, it's the StationPi GPIO pins.

That's the main reason why I'm going with StationPi SMT. I can visually see the soldering points on the Surface Mount. With the other StationPis, I need a magnifying glass to visually see the soldering points. One GPIO pin not soldered correctly and it's hell to troubleshoot.

Anyways, I'll try to check back but might take a good break. You have at least two suggestions to consider with squeezelite and a tradtional stack. Although, I noticed in the photo the D3 LED activating.

I experienced Soundstage Depth for the first time Gaming, so I'm going to try to replicate the experience via AudioLinux LTO 1666Mhz kernel and UcPure powering USB optical cable. The UcPure lowers noise floor to the extreme, so that opens up SQ attributes to shine like Soundstage Depth.
Last edited:
  • Like
Reactions: 1 user
I had a problem were every thing was connected to the station PI and all the lights were glowing correctly on the FIFOQ7 , butno sound but there was no sound
Can someone please help me? I've been trying to fix this four eight hours straight now and I'm about at my end.

I can't get anything to play thru the opa861 i/v board. Using station pi pro everything is powered correctly.

I've used with and workout a reciever pi 2 using different combos of jumpers at j14 and different ess and monitor pi pro settings. No matter what pcm or dsd with or without dop nothing.

Using only usb input from rpi, fiopiq7 and no dac chip is in the 9038qm mk2 board. Sync cables hooked up correctly. Used with and without j4 control port on station pi pro to fiopiq7.

I've tried a ton of gentoplayer drivers... Including all the rec ones i2s general ect ect.

Please help. Thank you.
Have you checked the gpio pins on the station PI are correctly soldered ?
Just to add a data point: I also have distortion (static noise) with 176 and 192 PCM files although my setup is different:
RPi4, StationPi Pro, FifoPi Q7 and HDMIPi Pro, powered by PurePi II with UcConditioner II 3.3V.

An Amanero board is on the way, and I am hoping that this will enable up to PCM384 and DSD512.

All my components have there own power supply. I use a RPI 3b+, not that different.
The noise shouldn't be there as it wasn't there before.

Don't know if more users have the same issues.

Hi everyone 🙂
Small video about my DiY Dac & Streamer...which runs like a power tank completely on LifePO4 batteries...
And everything packed in two cases 🙂
Still under construction; and I still have to finalise a few things .

I also wanted to thank Ian again for the good support...Ian doesn't let anyone down...sometimes it can take a while; because he can't clone himself :) so thank you Ian for your help :)

  • Like
Reactions: 6 users
Hello all,

I am new to this tread and to Ian's magical audio equipment.
At this point I am now using ALLO USBridge Sig as my streamer (with Shanti linear power supply) but looking to upgrade using Ian's stuff.
I looked through the history of the thread and I noticed that some of you used USBridge as a "base" RPI for the build using Ian's hats.
Could I ask those who did use US Bridge as a base to tell me if they are using linear power supply in the build (like Shanti LPS) - taking into account that there is no way to supply power from bottom GPIO pins of Allo using Ian's UC PI or pure PI?

Any recommendation or ideas/youtube videos how to proceed with capacitor/battery power with US Bridge Sig as a base? Is that needed, I guess it is when you need to supply 3.3 Volts into some hats.

Anyway, any help regarding supplying power to the build using USBridge will be much appreciated.

Hello Pawel, I am powering an Usbridge Sig via the FifoPi Q3 dirty side with a +5,25VDC super regged linear diy supply (capable of - probably more - than 1,5A continuous). Between the UsbSig and FifoPi I am using a ReceiverPi with its own 5VDC linear supply.
No experience with batteries/supercaps here, I am on (a lot of) linear supplies only, having a LifePo 3,3VDC mini to play with in an non distant future hopefully..
Today I received the ShieldPi Pro.
Question: In my build, mounting it on the RPi is not straightforward because the RPi is mounted upside down on the StationPi Pro. Is it possible to put the ShieldPi between the StationPi and the RPi?

P S Actually, this only seems it possible if I remove one of the StationPi's shields. Is this a good idea?
Last edited: