Open-source USB interface: Audio Widget

gioz

Member
2008-07-26 2:55 pm
Hi, I've two problems with usb>I2S module (red version, clock on board):

1) If I connect the module to my Mac (running 10.7.4) the device appear in audio setting with limit up to 48Khz (Probably UAC1 mode) and work ok.
If I push for 5 seconds prog button and than reset button for a moment (To switch from uac1 to uac2) I think the module reboot (led flashing) the module desappear from audio device on my Mac and no sound. I tried to disconnect usb and reconnect to my mac but not work....

2) when I play music I've strange problem:
The music play pretty well, but after 8/9 minutes I hear music with metallic sound for 2 or 3 seconds, after this the music is again ok, but the problem is repeated after a further 8/9 minutes...
 
Last edited:
Hi Gioz,

I'm no Mac expert, so someone else will have to respond to 1). When it comes to 2) please see how often this appears and what the module LEDs are doing. I had a similar experience on Windows a long time ago when the feedback was disfunctional. You'll have to make a detailed error log with when the sound is strange and what the module LEDs are doing.

Børge
 

oneoclock

Member
2010-10-04 11:03 pm
The window is Blackman-Harris. With Tektronix (without MOTU jitter) I've done zoom just on the skirt and I have tried other windows.

Measure are very well. This is with 1Audio power suply.
Now I not have original AB power suply to measure .

Jtest-44.1Khz.
[IMGDEAD]http://img189.imageshack.us/img189/9089/jitterzoom44.jpg[/IMGDEAD]

Jtest-48 Khz
[IMGDEAD]http://img163.imageshack.us/img163/1443/jitterzoom48.jpg[/IMGDEAD]


The peak jitter is -130 dB. The value peak of 11,025 and 12,000 on the tektronic are 0 dB but the Jtest teoric value of these signals is -3 db . The signal must go down 3 dB relative the scale.

The signal of 1 kHz I have made with CoolEdit to 44 Khz at -1 dB 24 bit. And best measured channel L green (R pink).
[IMGDEAD]http://img824.imageshack.us/img824/820/es90231khz.jpg[/IMGDEAD]
 

1audio

Member
Paid Member
2004-03-24 5:16 am
SF Bay Area
The 1 KHz distortion spectrum is similar to what I measured. It just meets spec and has a lot of upper harmonics.

The jitter may be lower. Finding the jitter floor of the capture system is difficult. You need to get a really clean source (I use a 10MHz oscillator divided down to 10 KHz and a 4M point FFT with 10 averages (1/2 hour of data collection and crunching) to get the noise out so I can see the residual jitter of the ADC. Needless to say the jitter is not an issue with this hardware. The DAC is limited by other aspects.

I was going to repeat my measurements but I sent my sample off to a programmer who is working on fixing issues in the Linux USB audio stack. I should have it back in a few weeks.
 
Gioz:
Which firmware is in the module? Lets make sure its correct for this application and not some other variant.

For all practical purposes the red modules have shipped with what has been in the audio-widget branch for quite some time.

I made the binaries using the 2.7 toolchain on Cygwin.

Again, I had a similar issue before. When It happened I spent half a day playing music and looking at the module LEDs. Whenever the LEDs broke out in a different pattern, or whenever the sound changed, I recorded the time and the behaviour.

We had a lengthly discussion on this some time ago. Please see if any of those experiences match what you are observing on your Mac. Look at the Audio-Widget email archive for threads named:
* Async UAC1 on Win7, weird noise...
* Audio buffers
* Metallic sound captured Win7-64 / UAC1


Børge
 
Prefer PCM5102 (with IIR filter mode) for redbook material with better presence.
With Hi-res material, both are good, ES seems a bit better dealing with big pieces.

Borge, I think full scale (0db?) signal is kind of extreme condition. I've heard it can be resolved on ES9023 by using 3.6V AVCC. PCM5102 should have similar issue as well. Since these are rare condition, I guess we can ignore it.

Audio-widget driving ES9023 and PCM5102, with dual stage Salas Shunt regulators and I2S isolator.
 

1audio

Member
Paid Member
2004-03-24 5:16 am
SF Bay Area
I wish FS in a track was a rare condition. I have on very popular track I use to test for overload that does go to FS on extended bass hits. Its possible for a producer to get real close and "win" the loudness war with some of the current DAWs and VST compressors.

When my AB1.1 returns I'll check the AVCC. There is also a resistor ratio tweak for the reference voltage that plays into this I think.
 

oneoclock

Member
2010-10-04 11:03 pm
Many commercial expensive DAC would like to have this QNKT jitter measure and 1 KHz. and 19-20 Khz. distortion. Stereophile do not dare to publish most of DAC the 1 Khz distorsion.

If Borges sell me AB 1.12 1.13 (PCM5102 and AK4430) all the components soldiers I buy to test and measure. I dare not soldered SMD.

Try to measure the ADC Jitter MUTU with the measuring equipment Tektronix to 10 Khz. But MOTU measured quite well for the price it costs and adds little jitter. I think now it is very difficult and expensive overcome the measures this card.
 
maybe try with a Windows or Linux host and run WidgetControl to see whether uou can run the module in uac2 mode with metallic sound issue
That will exclude any hardware provlems.
unfortunately, his other problem is that he's not able to get it working in UAC2 mode:

www.audiofaidate.org - Async USB2 - SDR/Audio-Widget collaborative project

Judging from the status LED (which he have added) the widget seems to switch (using the buttons), but when in UAC2 mode it is no longer recognized by his Mac (which is running the latest MacOS/X, thus it should work without problems).

Other problem is that the card does not work at all when powered from USB, apparently due to over-current. He got it to work only providing +5V externally.
 
It looks likr Gioz is connecting the module to a buffalo II. So it also depends on how the master clock is wired. There are just too many variables here so we need many more details to help with debugginng.

If the module can be set to uac2 mode according to the leds but it is mot recognized by OSX, it will ne useful to find out whether uac2 mode is recognozed by Win or Linux. If it is recognozed by ein or Linuz, then it is a Mac specific issue if not, then it is a hardware/ firmware issue.

Changing the host will.also check whether the win/linux PC USB port has enough joluice to.power the module without external +5V. If another UsB port is also not suppluing enough currwnt, them there might be a hardware problem somewhere.

Alex
 
I just saw the video. Two comments:

- It was hard to see the two LEDs on the module with all the green background light. Could you reshoot without the background light?

- This is a module with XOs on it. The XO power comes from the same 3.3V LDO as the MCU. It is LC filtered individually for each XO. Each LC branch has 22+1µF. It may be that even though the caps are behind the 3.3V LDO too much capacitance is exposed to VBUS in the USB cable. AB-1.x uses active inrush current limiting which is not present on the stand-alone module.

On page 3 of http://www.qnktc.com/usbmod_20120227_C_SCH.pdf you see C1006 and C1007 specified as 33µF. I could only get 22µF. Try removing those and see if it enumerates on the MAC without external power.


Børge
 
It looks likr Gioz is connecting the module to a buffalo II. So it also depends on how the master clock is wired.
he is using the Buffalo as-is, that is in async (ASRC) mode with its own local MCLK.

Børge: that of USB self-power is a very minor problem. He would have independently powered the widget anyway. I mentioned it just FYI.
 
Last edited: