Babelfish XA252 / Babelfish XA252 SIT / Babelfish XA252 SET

Official Court Jester
Joined 2003
Paid Member
ZM special.jpg
 
  • Like
Reactions: 1 user
Running into a problem on first start. Using dim bulb tester, and on startup, offset quickly climbing toward negative rail voltage. I shut it off around 20v. No smoke or anything. No visual damage. Any specific areas to test? I went over board with magnifying glass, and didn't find anything unusual. Thx
 

Attachments

  • IMG_0500.JPG
    IMG_0500.JPG
    543.6 KB · Views: 48
  • Like
Reactions: 1 user
Official Court Jester
Joined 2003
Paid Member
Using dim bulb tester, and on startup, offset quickly climbing toward negative rail voltage

instead of bulb tester it would be clever to resort to temporary fuses in amp rails, say that 2A5 will do

frankly - I forgot what is level of minimum Iq when trimpot is set for minimum, but - I'm sure that even if bulb tester in circuit practically messing up things, DC Offset can't be a problem

starting with Iq trimpot pre-set to minimum, DC Offset trimpot arbitrary in mid position

both inputs shorted to GND, no load at output

observing both DC offset and Iq, as described in short initial procedure in post #1
 
Update: Output mosfets are in correct position and orientation.
Went through whole board for proper parts and values.
Installed 2A5 fuse for each rail and powered up.
Offset again went up to 24v ish, then R24 smoked and I shut it down
Fuses both ok


Figuring I should pull Q1 and 2 and check. Not sure what to do thereafter. Might be useful to swap mosfets from other side to test? Run BD pair without heatsink for a few seconds to see operation? (I did have mica installed on both). Only replacement resistor I have right now for R24 is 47r.

Thanks
 

Attachments

  • IMG_0512.JPG
    IMG_0512.JPG
    489.9 KB · Views: 44
Official Court Jester
Joined 2003
Paid Member

well, it must be something fishy in assembly process, R24 doesn't go in smoke without a cause

anyhow, besides checking each and every component for placement, value and orientation (where applicable), if R24 gone Dodo ........ you need to check and replace what's gone:

R18, R19, T6, LED1, R21, R22, Q1, Q2, R24

all ref to schematic for full mos, post #1462, linked here:



babelfish-xa252-straight-mos-sch-png.1257028