3 Phase Class D amp for DIY BLDC motor Drive

hirscwi

Member
Paid Member
2014-03-06 2:18 am
Indianapolis, IN, USA
Warm is a relative term. I've built both the BLWS and BLWS versions. Both versions will become warmer than the ambient temperature after a while, but never too hot to touch. The round version (BLWR) gets a bit warmer than the square version. And mine are located in a solid plinth so they don't have much ventilation at all.
 
  • Like
Reactions: 1 user
"The LM317 should be OK at 1.5A. The SG4 draws minimum power and the MA3D is class D so it is 90-95% efficient."

That - 1.5A - was close to the limit.
If you are at about 60%, and heat sink is adequate, and properly mounted, should not be an issue. Drops to 30% at run...
I’m facing quite a few challenges. Factory power supply uses double regulation: first there’s is a 317 on the power supply board, it sends 39v to the table, where there is another 317 providing 23v to the motor (it replaces on board regulator that is normally present on Paost board); power transformer is also rated low, 1 amp. Even the umbilical cord is skinny, with DIN connectors. So the whole thing is borderline. To upgrade everything for higher current is possible, but may be too much work. It’s easier to run new system separately, albeit will not be as pretty with extra boxes, cables, switches etc. But safer.
I’m ready to test everything in situ, to see if the dreaded wow disappears, waiting for a round belt.
 
Just a suggestion, but why not replace the existing, much too high voltage, PSU with a laptop brick?
They're generally around 19V, so only 7V to drop across the LM317 which should help with heat dissipation and are generally of decent quality.
I don't know your layout, but most people can lose a 5 x 3 x 1 brick down behind the rack,
and you also have the advantage of not having a mains transformer in the vicinity of the pickup
 
  • Like
Reactions: 1 user
Just a suggestion, but why not replace the existing, much too high voltage, PSU with a laptop brick?
They're generally around 19V, so only 7V to drop across the LM317 which should help with heat dissipation and are generally of decent quality.
I don't know your layout, but most people can lose a 5 x 3 x 1 brick down behind the rack,
and you also have the advantage of not having a mains transformer in the vicinity of the pickup
I have “the brick”))). Interesting idea. I wanted to keep the original factory set-up, so all switches and functions remain as is…
 
Just a suggestion, but why not replace the existing, much too high voltage, PSU with a laptop brick?
They're generally around 19V, so only 7V to drop across the LM317 which should help with heat dissipation and are generally of decent quality.
I don't know your layout, but most people can lose a 5 x 3 x 1 brick down behind the rack,
and you also have the advantage of not having a mains transformer in the vicinity of the
 
Hi all. So I hooked it all up today, and… I’m very disappointed. As I had suspected before, the wow/flutter problem is probably mechanical. Bad bushings, thrust plate etc. I’m getting the same crappy readings as the table warms-up as before, with the old Papst motor. 0.17% is very far from 0.04% that other members have reported with their tables. Well, this was the last chance I gave this old Cosmos. Not sure what to do next.
 
How difficult is it to remove the platter and clean the spindle and bearing well of old oil,
while you're there see what the clearance is like and the condition of the thrust bearing?
I can't see how worn spindle bearings would produce such poor figures, especially as , I see,
the figures are worse as the TT warms up.
 

hirscwi

Member
Paid Member
2014-03-06 2:18 am
Indianapolis, IN, USA
In addition to Ralph's good suggestions, I'd try different belts. I've had dramatic improvements between belts by different makers, even if both new. Are you measuring W&F with something like Kenwood FL140? or the Feickert app? Either is dependent upon the accuracy of test record and I find tradition W&F meter better than Feickert. Furthermore I'd be suspect of 0.04% DIN weighted W&F. That's down in direct drive range and I'd be skeptical of the measurement. Possibly using a phone app? In my experience those are less accurate.
 
  • Like
Reactions: 1 user
How difficult is it to remove the platter and clean the spindle and bearing well of old oil,
while you're there see what the clearance is like and the condition of the thrust bearing?
I can't see how worn spindle bearings would produce such poor figures, especially as , I see,
the figures are worse as the TT warms up.
I’ve been through this many times. Cleaned, lubricated etc. Even tried different platters. Nothing helps this piece of crap.
 
In addition to Ralph's good suggestions, I'd try different belts. I've had dramatic improvements between belts by different makers, even if both new. Are you measuring W&F with something like Kenwood FL140? or the Feickert app? Either is dependent upon the accuracy of test record and I find tradition W&F meter better than Feickert. Furthermore I'd be suspect of 0.04% DIN weighted W&F. That's down in direct drive range and I'd be skeptical of the measurement. Possibly using a phone app? In my experience those are less accurate.
I only have apps on my i phone, and my ears that tell me that wow is high on piano notes… If I put a coat of fresh light oil on shaft, the figures go right down. But as soon as it dries up - back into the crap-zone. I’ve had a Sota Star series 3 here recently - same problem.
 
In addition to Ralph's good suggestions, I'd try different belts. I've had dramatic improvements between belts by different makers, even if both new. Are you measuring W&F with something like Kenwood FL140? or the Feickert app? Either is dependent upon the accuracy of test record and I find tradition W&F meter better than Feickert. Furthermore I'd be suspect of 0.04% DIN weighted W&F. That's down in direct drive range and I'd be skeptical of the measurement. Possibly using a phone app? In my experience those are less accurate.
Thank you. I’ve tried different belts. I’ve recorded a 3000 hz test time of of my test record. It’s about 3 min long, 1.4 Mb. If anyone can use this recording to measure w/f I’d really appreciate it.
 
In addition to Ralph's good suggestions, I'd try different belts. I've had dramatic improvements between belts by different makers, even if both new. Are you measuring W&F with something like Kenwood FL140? or the Feickert app? Either is dependent upon the accuracy of test record and I find tradition W&F meter better than Feickert. Furthermore I'd be suspect of 0.04% DIN weighted W&F. That's down in direct drive range and I'd be skeptical of the measurement. Possibly using a phone app? In my experience those are less accurate.
Here's the result of my test; not as good as my Technics SP10 mk II (0.02%), but pretty good for a belt drive
 

Attachments

  • Screenshot_20220516_181106_com.AM.AM.RPMSpeed.jpg
    Screenshot_20220516_181106_com.AM.AM.RPMSpeed.jpg
    88.7 KB · Views: 8
  • Turntable_s.jpg
    Turntable_s.jpg
    34.8 KB · Views: 8
  • Like
Reactions: 1 user