Go Back   Home > Forums > >

PC Based Computer music servers, crossovers, and equalization

Pulseaudio Crossover Rack - multi-way crossover design & implementation with linux
Pulseaudio Crossover Rack - multi-way crossover design & implementation with linux
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools
Old 11th April 2021, 10:00 PM   #931
katariat is offline katariat  United States
diyAudio Member
 
Join Date: Nov 2014
Hi Jürgen

do agree on going step by step while debugging. Wanted to start with first principle thinking and get the basics right. Some good news - i was able to get the xover rack to work with my creative 5.1 sound card. It works when i play the music file from the sbc, i just used some media player that was natively available.

not so good news, after i installed the shairpoint-sync...and do air play into the sbc, i can get sound from the headphone socket like before but not from the mutichannel ports of the sound card. So i know the issue is just with the sharipoint-sync and or its settings.

the distro i am using is Ubuntu 18.04 Bionic LXDE Desktop. Link below
ROCK64 Software Release - PINE64

i started doing some research on the shairpoint-sync; by default it is compiled with alsa as it engine. I thought, may be if i can compile it with pulse-audio then may be it may work. So i removed all the old files per the instruction, and re-compiled shairpoint-sync with pulse-audio. Unfortunately the same results. The xover rack works just fine when i play natively from the SBC but when i air-play into the SBC through shair-point thing break

there is some documentation on the shair-point....it has multiple configuration options. Unfortunately this is where my already very limited knowledge/ understanding goes for a toss. As always any help would be greatly appreciated. Happy to share/ provide any diagnostics or output if needed.

GitHub - mikebrady/shairport-sync: AirPlay audio player. Shairport Sync adds multi-room capability with Audio Synchronisation

my original compilation of shairpoint-sync
Code:
./configure --with-alsa --with-avahi --with-ssl=openssl --with-systemd --with-metadata
my revised compilation of shairpoint-sync
Code:
./configure --with-pa --with-avahi --with-ssl=openssl --with-systemd --with-metadata
  Reply With Quote
Old 11th April 2021, 10:09 PM   #932
Tfive is offline Tfive  Germany
diyAudio Member
 
Tfive's Avatar
 
Join Date: Jun 2018
Location: Straubing
The --with-systemd option makes me suspicious. Does shairpoint-sync run as a service?

If so I'd suggest to stop that service and to try to run it as the same user that you login to your desktop with.
__________________
Want more of the good stuff? -> https://t-5.eu/
  Reply With Quote
Old 15th April 2021, 04:30 PM   #933
katariat is offline katariat  United States
diyAudio Member
 
Join Date: Nov 2014
Hi Jürgen

your hunch was correct. With some additional help i was able to figure out that shairport-sync was running as a super user vs the the account that i was using for the pulseaudio crossover rack.

When i started shairport-sync with the user credentials ...things started to work as intended.

I did hit another roadblock .. the distro wouldn't recognize the WIFI adaptor when all the other distros that i have used have had no issues with it. The issues with the other distros was that i could never get the entire thing to work as designed...so it was almost going back to the drawing board once again

This time i started with dietpi as the distro and i was able to replicate the overall design....load shairport-sync, configure Pulseaudio crossover rack etc.

The story wont end if there were no issues though....in the current setup ie dietpi distro, i hear cracking sound when i use pulseaudio crossover rack. This happens irrespective of whether i play a file natively on the SBC or airplay through wifi into the SBC. There is no such crackling sound when i take off the Pulseaudio crossover rack.

What could be the issue and any suggestions to take care off it. Thanks

Last edited by katariat; 15th April 2021 at 04:51 PM.
  Reply With Quote
Old 16th April 2021, 08:10 AM   #934
Tfive is offline Tfive  Germany
diyAudio Member
 
Tfive's Avatar
 
Join Date: Jun 2018
Location: Straubing
I recommend to RTFM

Pulseaudio Crossover Rack - Online Help


EDIT: what's the soundcard you use?
__________________
Want more of the good stuff? -> https://t-5.eu/
  Reply With Quote
Old 16th April 2021, 01:23 PM   #935
katariat is offline katariat  United States
diyAudio Member
 
Join Date: Nov 2014
my sound card is creative sound blaster x-fi surround 5.1
  Reply With Quote
Old 16th April 2021, 01:26 PM   #936
phofman is online now phofman  Czech Republic
diyAudio Member
 
Join Date: Apr 2005
Location: Pilsen
katariat: FYI CamillaDSP - Cross-platform IIR and FIR engine for crossovers, room correction etc.
  Reply With Quote
Old 16th April 2021, 01:30 PM   #937
katariat is offline katariat  United States
diyAudio Member
 
Join Date: Nov 2014
@phofman....i am happy to experiment and share USB packets dump if that's what you are referring to.
  Reply With Quote
Old 16th April 2021, 01:33 PM   #938
Tfive is offline Tfive  Germany
diyAudio Member
 
Tfive's Avatar
 
Join Date: Jun 2018
Location: Straubing
Quote:
Originally Posted by katariat View Post
my sound card is creative sound blaster x-fi surround 5.1
This is a USB card AFICT. Might try this also:
Pulseaudio Crossover Rack - multi-way crossover design & implementation with linux
__________________
Want more of the good stuff? -> https://t-5.eu/
  Reply With Quote
Old 7th May 2021, 09:03 AM   #939
phofman is online now phofman  Czech Republic
diyAudio Member
 
Join Date: Apr 2005
Location: Pilsen
Quote:
Originally Posted by katariat View Post
@phofman....i am happy to experiment and share USB packets dump if that's what you are referring to.
Please can you take a look if the same URB_FUNCTION_ABORT_PIPE request is sent in windows dump like in X-Fi USB HD - switching from USB1.1 to USB2? ? You may have a different EP IN ID (5.1 maybe different from the stereo HD). Thanks.
  Reply to this post

Reply


Pulseaudio Crossover Rack - multi-way crossover design & implementation with linuxHide this!Advertise here!
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can you use a digital active crossover to design a passive analog crossover ? RickDangerous Digital Line Level 28 22nd November 2020 05:32 PM
analyzing my Linux/ecasound dsp crossover speaker system gibbyj Multi-Way 5 6th August 2017 07:42 PM
Linux + MPD player + dsp crossover via ecasound jplesset PC Based 11 15th September 2013 10:24 PM
Active Crossover using PC and multi ch. Soundcard? vision Digital Source 22 7th July 2012 11:59 PM
Implementation of 3 ways speaker with digital crossover ackcheng Multi-Way 4 6th December 2010 03:50 PM


New To Site? Need Help?

All times are GMT. The time now is 03:59 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright ©1999-2021 diyAudio
Wiki