Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Digital Line Level DACs, Digital Crossovers, Equalizers, etc.

XMOS-based Asynchronous USB to I2S interface
XMOS-based Asynchronous USB to I2S interface
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th November 2014, 05:55 PM   #2231
wlowes is offline wlowes  Canada
diyAudio Member
 
wlowes's Avatar
 
Join Date: Mar 2007
Location: Toronto
I use mine with a 1541a and it is a wonderful combo. So nice I am rebuilding the 1541a to be up to the full capacity including DSD thanks to Lorien and to Ian with his I2S to PCM board.
  Reply With Quote
Old 30th November 2014, 07:03 PM   #2232
Eldam is offline Eldam  France
Banned
 
Join Date: Sep 2012
Location: France
Freax,

I'm already on the waiting list also , I was advised also by the ancients !

If you don't need the spidf, ask for a board without the U11 chip as said above!
  Reply With Quote
Old 9th December 2014, 04:00 PM   #2233
NickD is offline NickD  Canada
diyAudio Member
 
Join Date: Sep 2012
Hello,

Can anyone confirm that the WaveIO with firmware updated to 6.60 and using drivers 2.23 or 2.24 with Win 8.1/Foobar actually works with Native DSD? I have no trouble playing uncompressed WAV rips, just native DSD is not working (silence). I've contacted Lucian off board and he is aware of the issue I am having, just wanted to see if I am alone in this. The WaveIO is connected to a Buffalo IIISE using the J2 (non-isolated) connections. The WaveIO has it's own linear supply (5.25V/3A). As I mentioned, it's working great with CD quality material (WAV) but nothing from DSD (DFF/DSF).

Thanks for any input

Nick

Last edited by NickD; 9th December 2014 at 04:22 PM. Reason: dropped sentence section
  Reply With Quote
Old 10th December 2014, 12:30 PM   #2234
Lorien is offline Lorien
diyAudio Member
 
Join Date: Nov 2007
Hello Nick,
I saw your messages, both of them, but here things could end up in a huge mess if are not solved in appropriate manner!
Regarding to your 'quest', I just test a randomly chosen board and saw the DSD streams as should be (with my scope).
Sadly I'm not home to plug it into my test DAC and hear music but you can try it on your side!
What I did:
1. I downloaded latest Foobar version from here (v1.3.6).
2. Install over what I had before (v1.3.3 or so)
3. Uploaded 6.6.0 into this test WaveIO board I have near me (see first post of this thread).
4. open Foobar and do the following:
a) File => Preferences => Output and choose ASIO: foo_dsd_asio (you must install it first - google it)
b) File => Preferences => Output => ASIO and double click on 'foo_dsd_asio'
c) In the new opened window @ ASIO driver choose "WaveIO ASIO driver" and under it @ DSD Playback Method: "ASIO Native".
To "DSD to DSD" and "PCM to DSD" options leave: None.
Close it.
d) Tick "Use 64-bit ASIO drivers" - I don't know if there are any changes by using this option so you can disable it later.
e) click OK.
f) File => Preferences => Tools => SACD pick "DSD" at ASIO Driver Mode (and PCM samplerate to 176400). Click OK.
I use the test files for DSD64 and DSD128 from here (2l.no).

I hope I didn't forget anything!
L
__________________
Contact link for WaveIO USB-to-I2S/SPDIF board.

Last edited by Lorien; 10th December 2014 at 12:32 PM. Reason: spelling
  Reply With Quote
Old 10th December 2014, 02:32 PM   #2235
NickD is offline NickD  Canada
diyAudio Member
 
Join Date: Sep 2012
Hi Lucian,

thanks so much for testing this. I have the exact configuration you have described but I get nothing. What I will do next is to uninstall everything and start fresh. Maybe it is something as simple as a bad driver install. I will report back when that is done.

thanks again,

Nick
  Reply With Quote
Old 10th December 2014, 02:43 PM   #2236
Lorien is offline Lorien
diyAudio Member
 
Join Date: Nov 2007
Hmm... I forgot to mention that my PC is running Windows 7 SP1 x64 and I do use driver version 2.23.
I'll try to install Windows 8.1 when I get some free time and pray not to smash my laptop in the process as I really hate the user interface of this new OS.
Cheers,
L

Edit: I remember it was hard for me to make it work too! It took me one day to adapt that firmware for WaveIO and make it work in Foobar! A lot of my patience has gone ! I don't know if there are any other settings on Foobar besides those listed above... This happened in summer and wasn't a very pleased day to remember!
__________________
Contact link for WaveIO USB-to-I2S/SPDIF board.

Last edited by Lorien; 10th December 2014 at 02:48 PM.
  Reply With Quote
Old 10th December 2014, 02:49 PM   #2237
NickD is offline NickD  Canada
diyAudio Member
 
Join Date: Sep 2012
I don't like it either but I had to go this route for reasons other than audio.

Anyway I will go through the motions of re-install just to be sure but if you can test in 8.1 sometime soon that would be great.

thanks,

Nick
  Reply With Quote
Old 11th December 2014, 02:43 PM   #2238
NickD is offline NickD  Canada
diyAudio Member
 
Join Date: Sep 2012
Hi Lucian,

I removed everything from the system (Foobar, all Foobar drivers/components, all drivers for WaveIO). Started from the beginning again except for the firmware update to 6.60 as it reports correctly (should be ok yes?). I can report that there was no change at all for DSD output. Also, I tried drivers 2.24 and they behave the same as 2.23. For now I have left 2.24 in.

Nick
  Reply With Quote
Old 11th December 2014, 03:21 PM   #2239
Lorien is offline Lorien
diyAudio Member
 
Join Date: Nov 2007
Well, I tried to install Win 8.1 last night and it ended up badly! I had two other OSes on my PC but at some time I couldn't boot up any of them... I don't know but for some reason (I guess my hate for win 8 is carrying the guilt!) at the end of installation, I get an error saying that Windows cannot modify the boot configuration (if I remember right) and that was all! From that point I'm trying to recover my system as it was before this "beautiful" experience!
Anyway, even if I have to format all my HDDs, I'll move on and see if "my" Win 8.1 does act like yours! From this moment forward, the Win 8.1 'deal' become a personal thing!
__________________
Contact link for WaveIO USB-to-I2S/SPDIF board.
  Reply With Quote
Old 11th December 2014, 03:24 PM   #2240
Lorien is offline Lorien
diyAudio Member
 
Join Date: Nov 2007
crossing posts! Wait to revert my PC to "defaults" and then move on with Win 8.1 installation!
__________________
Contact link for WaveIO USB-to-I2S/SPDIF board.
  Reply With Quote

Reply


XMOS-based Asynchronous USB to I2S interfaceHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
exaU2I - Multi-Channel Asynchronous USB to I2S Interface exa065 exaDevices 1422 22nd March 2020 02:15 PM
Introducing miniStreamer: Native 24/96 USB to I2S / SPDIF interface minidsp miniDSP 40 22nd October 2015 07:46 PM
Ultimate USB to I2S interface sampler Digital Source 206 30th January 2012 03:45 PM
Is it possible to develop a ASIO driver for PCM2900 based USB Audio interface? cxhawk Digital Source 7 3rd December 2010 02:30 PM
interface I2S with USB mermoz Digital Source 0 21st February 2003 10:34 AM


New To Site? Need Help?

All times are GMT. The time now is 08:26 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio
Wiki