Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Class D Switching Power Amplifiers and Power D/A conversion

TDA7498E don't produce any sound (red Amplifier module)
TDA7498E don't produce any sound (red Amplifier module)
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th May 2020, 05:35 PM   #1
Jorgesilva is offline Jorgesilva  Portugal
diyAudio Member
 
Join Date: May 2020
Location: Porto
Smile TDA7498E don't produce any sound (red Amplifier module)

Hi my dears "DiyAudio" lovers. I purchase one amplifier module "TDA7498E 2 * 160 BTL (red pcb module)" from ebay.
First i wiring all connections from my power supply module 36V 5A (the cheap module from ebay) to TDA7498E and connect my 4Ohm speakers on TDA7498E.
All connections it's ok. Then I connected my laptop with RCA cable to the TDA7498E, and finally turned on the amplifier.
The red LED from the TDA7498E it's turn on, and i play music using my laptop but the TDA7498E amplifier module only work for about 15min with the volume knob in mine o'clock, it is not giving music but energy arrives at the TDA7498E because I measured the voltage and the TDA7498E receives 36V, and the red LED is on.
Than i turn off the TDA7498E and tried to see what was wrong. When removing the heatsink from the TDA7498E i see my amplifier do not have an Schottky diode on D8 and D9.
The other Schottky diodes for output channels is an "SS1060" but i cannot encouter this type of Schottky diode available to buy.
Anyone can help me to find any solution for can i put my amplifier module TDA7498E working?
I need your help, please.

Last edited by Jorgesilva; 11th May 2020 at 11:19 AM.
  Reply With Quote
Old 11th May 2020, 01:17 PM   #2
manojtm is offline manojtm  India
diyAudio Member
 
manojtm's Avatar
 
Join Date: Aug 2008
Location: KERALA
Quote:
When removing the heatsink from the TDA7498E i see my amplifier do not have an Schottky diode on D8 and D9.
Hi,
Any picture of your amp

Regards
MANOJ
  Reply With Quote
Old 11th May 2020, 01:47 PM   #3
Jorgesilva is offline Jorgesilva  Portugal
diyAudio Member
 
Join Date: May 2020
Location: Porto
Quote:
Originally Posted by manojtm View Post
Hi,
Any picture of your amp

Regards
MANOJ
Hi my dear "NANOJ", i hope you have an nice day.
Many many thanks for your time helping me.
Meanwhile, this is the picture of my amplifier.
Can you help me find some compatible schottky diodes for i can use in my amplifier?

Best regards.
Attached Images
File Type: jpg IMG_20200509_224442-2.jpg (646.5 KB, 112 views)
  Reply With Quote
Old 11th May 2020, 01:52 PM   #4
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
TDA7498E don't produce any sound (red Amplifier module)


No need to keep reposting As a newbie all your posts have to be approved before going live.
  Reply With Quote
Old 11th May 2020, 02:00 PM   #5
Jorgesilva is offline Jorgesilva  Portugal
diyAudio Member
 
Join Date: May 2020
Location: Porto
Quote:
Originally Posted by Mooly View Post


No need to keep reposting As a newbie all your posts have to be approved before going live.
Thanks for this information my dear "Mooly".
  Reply With Quote
Old 11th May 2020, 05:31 PM   #6
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
TDA7498E don't produce any sound (red Amplifier module)
No problem.
  Reply With Quote
Old 14th May 2020, 01:44 PM   #7
Jorgesilva is offline Jorgesilva  Portugal
diyAudio Member
 
Join Date: May 2020
Location: Porto
Anyone can help me find some compatible schottky diode for my amplifier board "TDA7498"?
My board is detective and don't have the schottky diode on position D8 and D9.
The other schottky diodes i have on the output channels is an schottky diode SS1060.
Can anyone help find some schottky diode compatible with this?

Best regards.
  Reply With Quote
Old 14th May 2020, 06:42 PM   #8
Jorgesilva is offline Jorgesilva  Portugal
diyAudio Member
 
Join Date: May 2020
Location: Porto
Sorry for this mistake but the other schottky diodes i have on the output channels is an schottky diode "S1060" and it's not an "SS1060".
I need help to find some schottky diode compatible with this.
Can anyone help me on this?
  Reply With Quote
Old 14th May 2020, 07:28 PM   #9
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
TDA7498E don't produce any sound (red Amplifier module)
Do they look anything like these.

If so then it might give a clue on the specs and help you choose something similar. As long as what you fit is fast enough and rated sufficiently in current and voltage then it should be fine. Speed is very important in switching applications.

https://uk.farnell.com/on-semiconduc...tky/dp/1611585
Attached Images
File Type: jpg Annotation 2020-05-14 202505.jpg (161.9 KB, 78 views)
  Reply With Quote
Old 14th May 2020, 11:26 PM   #10
Jorgesilva is offline Jorgesilva  Portugal
diyAudio Member
 
Join Date: May 2020
Location: Porto
Quote:
Originally Posted by Mooly View Post
Do they look anything like these.

If so then it might give a clue on the specs and help you choose something similar. As long as what you fit is fast enough and rated sufficiently in current and voltage then it should be fine. Speed is very important in switching applications.

https://uk.farnell.com/on-semiconduc...tky/dp/1611585

Thanks Mooly but i need schottky diode SMD and i don't know if this schottky diode you say fit on the amplifier board "TDA7498E".
I need something like this picture but i can encouter something like that.
And other question, is possible, with this defective, without this schottky diode my IC 'TDA7498E" it's been damage?
Attached Images
File Type: jpg IMG_20200515_002952_786.jpg (45.1 KB, 69 views)

Last edited by Jorgesilva; 14th May 2020 at 11:38 PM.
  Reply With Quote

Reply


TDA7498E don't produce any sound (red Amplifier module)Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SMSL SA-98E TDA7498E , What's your opinion of its design\sound ? WhiteRhino Chip Amps 3 21st October 2015 09:51 AM
Which company produce high end pure digital amp module? mbl Class D 0 3rd March 2010 06:44 PM
You PC amplifier can be modified to produce better sound destroyer X Solid State 11 12th October 2008 01:00 PM
Why can't sound produce light? tomasro Everything Else 62 1st February 2004 02:00 AM


New To Site? Need Help?

All times are GMT. The time now is 01:37 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio
Wiki