wtfplay project - Linux based PC playback system

Hello all. I just downloaded the wtfplayer software and am enjoying the transparency of it very much. The sound is incredible through my stereo, however I am having some difficulty in accessing all of my 2 terabytes of music off my drive. It appears that some files aren’t found by the software. When I click on certain albums it shows a blank with no songs. So I unplugged the drive from my music server with the wtfplayer software, plugged it into my windows desktop and sure enough, all the missing files were there. I believe most are in flac or wav format but there could also be other formats as well. Any help in remedying this situation would be greatly appreciated.
Hi Otto,

I think that adding a command line option to force a particular format (or formats) can be easily done. I will look into this.


Hi Frd, Hi all,

up to the acutal version of wtfplay i still can either play 16bit songs or 24/32bit songs. Setting my RME Digi96/8 to Buffer 1024/8 works for 24/32bit files, but still not for 16 bit files (and the other way round for Buffer 2048/8).

When starting via Command-Line a 16bit file i get the information:
"failed setup pcm: -1"
and no sound.

Anything I can do?

Have a nice day,
Still greatly enjoying this very fine player.

I recently got an ASUS motherboard and WTF says it has four unneeded hdmi sound devices.

My previous board had an HDMI output but I never got this message before.

Of course, WTF allows them to be disabled in the OS but you also say it is better to do it in the BIOS.

I thought I was competent with BIOS but I see nowhere in the BIOS that allows doing anything with the hdmi output.

Am I looking in the wrong places or is it unusual for this to be included in BIOS?

Any suggestions of where to look? I see plenty of advice on how to enable them, not necessaruily for this mother board. I got nothing I could use from those articles.

I love keeping the OS as simple as possible so my obsessive nature would like this to be handled in the BIOS

Thanks in advance.

PS do you continue to work on the ARM version?

Take care,
Hi Rick,

Most HDMI outputs have support for audio. I am not familiar with many BIOSes, but I do not think that you can enable/disable the HDMI audio support on its own. I would guess that it would rather be enabling/disabling HDMI completely (audio and video), but I am not even sure if even that is available.

  • Like
Reactions: 1 user
Hi all, maybe a pretty specific question. I am running wtfplay on my Steam Deck - works really well! However, the screen is sideways (this is by steam deck design, its a 10:16 ratio screen)

Is there any way to change the orientation of the screen? I tried the usual /sys/class/graphics/fbcon/rotate attempts without joy. Grub config doesn't look accessible?

Anyone aware of how else to do it? And whilst I'm being greedy - would there be any chance to re-map the keys so the buttons on the steam deck could be used?

Lastly: Is there any way to enable a screensaver? Cannot switch off the screen on a console.

Thank you!
Steam Deck - wow! I would not suspect that it the system would run on it. It would not have came to my mind to try it :) Good stuff!

To answer your questions:

1. The support for console rotation is not in the kernel. I never thought on would need it.
2. The same goes for the screen backlight. The generic UEFI framebuffer is used (the simplest approach I could think of).

Steam Deck - wow! I would not suspect that it the system would run on it. It would not have came to my mind to try it :) Good stuff!

To answer your questions:

1. The support for console rotation is not in the kernel. I never thought on would need it.
2. The same goes for the screen backlight. The generic UEFI framebuffer is used (the simplest approach I could think of).

Hey thanks for following up! Well, here's to hoping that ever shows up - my neck is starting to hurt from looking sideways lol

Ciao frd_. Wtfplay è fantastico, amo tutto ciò che è minimo, congratulazioni per il progetto e grazie per aver condiviso il tuo lavoro con noi appassionati!
Vorrei chiederti se potresti implementare delle scorciatoie nelle prossime versioni per spegnere completamente il monitor! (sarebbe molto utile nel taccuino)
una buona cosa sarebbe impedire lo sleep del display dal quale a volte il risveglio è complicato (meglio se la riproduzione rimane sempre in primo piano)
Segnalo anche un bug: durante il boot, Wtfplay, alcune volte, il mio dac (DENAFRIPS ARES - Amanero) viene innescato da un falso impulso, in cui leggo sul display del dsd x 8, e il suono che esce degli altoparlanti, è quella di una radio fm che non trova la stazione, per fermarla devo mandare un file in play, e poi premere Q per fermarla e tornare al silenzio.
Grazie per l'attenzione
Ciao frd ho lo stesso problema con un denafrips Ares con scheda usb xmos.
Last versione installed .... best audio.
Last edited:

I would also like to point out a bug: during boot, Wtfplay, a few times, my dac (DENAFRIPS ARES - Amanero) is triggered by a fake impulse, in which I read on the dsd x 8 display, and the sound coming out of the loudspeakers, is that of a fm radio that does not find the station, to stop it, I have to send a file in play, and then press Q to stop it and go back to silence.
Thanks for your attention
hello _frd I wanted to report that I have the same problem on denafrips ares with xmos card. the disturbance is generated during the wtfplay boot ... then when I launch the file to be played it starts to always go well until the player is closed.
I apologize but with my cell phone the message was translated automatically.
Hi ucciopino,

That is an interesting case. I have tried many XMOS based DACs and I never came
across the behaviour that you describe. Just to be sure that I have a full
picture of what is goin on:

1. Does the issue happen every time that you boot the PC? Or does it occur
at random boots?

2. Does this issue happen only on that particular PC? Have you tried a
different PC (a laptop) with your Ares DAC and wtfplay-live?

3. Does the issue happen with wtfplay-live and any other DAC that you have
tried? Or is it just Ares?

4. Does the issue happen only when you boot your PC with DAC connected? Or
maybe, it also happen when you connect DAC after your PC has booted?

6. Would you be able to check if the issue occurs with any other Linux
distribution? Ubuntu or Mint for example?

7. I also guessing that you do not have this issue when you use your DAC
in exactly the same under Windows/OSX? Is that correct?

I also checked my old correspondence regarding Ares (Amanero based)
and at that time the issue was not limited to wtfplay-live and could be
reproduced with Ubuntu as well. It seems that Ares does not like how Linux
generic USB audio driver initialises the device and thinks it
should start playback, yet PC is not sending any data, so the DAC plays
whatever it has currently in its buffers - a random data which produces the

Since the issue seems to occur with both: XMOS and Amanero Ares units, this
may suggest a bug in the DACs firmware. On the other hand, maybe those devices
require some sort of special treatment (a quirk) in the driver (as many others
do). It's hard to tell without without having an access to the unit and
running few tests.

@phofman. Interesting. IMHO I see no reason why snd_usb_audio would talk to any USB data endpoint during the device enumeration. I am trying to find that in the kernel sources. I know that you've been working on UAC2 gadget driver. Did you observe such a behavior?

What I have found so far is that during the card initialization snd_usb_audio sets the clock in the device (over the control pipe). Maybe that's what triggers the DAC? I also have XMOS refernce sources of their USB audio app. Will try to see what's going on there, however there is absolutely no guarantee that this is exactly what is running in Ares.
@frd__ : I checked with wireshark. The usb driver does not output any data, but switches to all non-zero alternate settings with SET INTERFACE during the enumeration, repeatedly. No data are passed. In case of the USB audio gadget the the switch to non-zero altsetting signals start of possible data transmission and is observed by the driver. Actually my gaudio controller debounces this event to avoid false starting the playback/capture processes .

Pulseaudio sends a stream of zero samples to the device upon its emergence but that is not relevant for wtf play, IIUC.

IMHO setting the clock and/or configuring the "runable" altsetting could cause the glitch in the device, as reported above, should the firmware not handle it properly.