MTX 81001, Want to know the value of two parts

Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.
Replace any semiconductors in the circles if you're not 100% sure that they're OK.
 

Attachments

  • IMG_6823x.jpg
    IMG_6823x.jpg
    82 KB · Views: 95
  • IMG_6814x.png
    IMG_6814x.png
    899.7 KB · Views: 101
I replaced Location Fet401
I also replaced Location D404, r410, Q401, U402, U403.

Then i turned the amplifier onn with a 12V 2A adapter.

Then i about 15 sec i heard something sizzle.

I turned the amplifier off immediately.

After i turned off the aplifier i saw the Elco at Location C408 was hot and distended.
 
The 'regulator' is a voltage regulator. The opto-couplers cannot operate from rail voltage. The voltage limit is about 20v. The voltage regulator supplies a safe voltage to the opto-coupler.

There is no one part that makes up the regulator. It's made of a number of parts. I don't have a diagram for the regulator with the circuit board designations in your amp but the diagram from another MTX amp can be seen below.
 

Attachments

  • mtxreg01.png
    mtxreg01.png
    21.6 KB · Views: 103
I`m still busy with this amplifier. The problem is still the same the Elco keeps burning.

I readed this topic again and i saw this text.
"Until you get the regulators working properly, I'd suggest pulling the two 3120s and soldering a jumper connecting pins 5, 6 and 7 on each 3120. This will prevent damage to the opto-couplers and the jumpers will keep the outputs from switching on."

I want to know what you ment by:
soldering a jumper connecting pins 5, 6 and 7 on each 3120.
(i know what a jumper is. but i dont know what you ment by pins 5,6,7 on each 3120?
 
At this moment i replaced all of the following locations beneath 3210 :
D404, r410, q401, d401,c408, c406, d405, d406.
I also replaced fet401 and resistor 407 and 403 seems to be good i think the q403 and d400 is not likely defective.

I also relaced a 100ohm resistor and a zener diode j5 under the 2 coils.

And replaced the optocouplers and when i turn op the amp on low voltage the capacitor c406 is distending.
 
Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.