CD Player laser fault/misdiagnosed (SHANLING S100)

Hi, thanks for reading.

I have a Shanling CD S100 using, I believe, a Philips 12.1 transport and a Sanyo SF-HD850 optical pickup.

The noise of the laser reading the disk is fairly loud. It's not too bad at normal listening levels but it's still there. The noise is constant when in PLAY but when in PAUSE it's less frequent but still fairly regular.
I've attached a sound clip (NOTE the mic is pretty close to the cd player here).

http://sites.google.com/site/nathanjh13/home/jolidajd9/ShanlingCD_SpinningBeep.WAV

I'd read that changing the laser fixes the problem. I did this but I've exactly the same problem :(

If I change the transport etc will this cure it or am I stuck to a Philips 12.1 (or VAM1210) and Sanyo as above, hoping I finally find a comination that works?

I wonder if it's when the laser "pops up" to read and it catches the surface of the disk?

Any help is appreciated. Thanks
Nathan
 
Last edited:

Mooly

Administrator
Paid Member
2007-09-15 8:14 am
Hmmm... the sound clip would be better with just the player and less background/music :)

The noise is that of the servo system and is audibe because of the coils (tracking/focus) on the lens assembly. You need to be sure the discs are 100% perfect and clean. Any scratches can give a burst of noise from the servo as the system tries to correct for tracking/focus errors. Does the disc run perfectly true with no wobble or run out when viewed edge on ?

I am puzzled with the references to the CDM12.1 and Sanyo pickup. The CDM12 is a Philips unit and has no connection with anything Sanyo.

CDM12.1 here,
cdm12.1 - Google Search

Sanyo here,
Sanyo SFHD 850 - Google Search
 
Thanks Mooly.

The unit makes the same noise regardless of the condition of the disk (even brand new). I diagnosed the transport type from all the reviews I've seen, such as this:

Product Review

but if it's different then fair enough (pics below).

The laser I replaced was the Sanyo one but I'm not sure what to make of it all now.

Is it as simple as buying a cdm12.1 as shown in your link, with the laser assembly and sled attached (or a VAM1210 if easier to find) and that's it?
 

Attachments

  • IMGP8475.jpg
    IMGP8475.jpg
    614.4 KB · Views: 224
  • IMGP8479.jpg
    IMGP8479.jpg
    663 KB · Views: 216
Last edited:

Mooly

Administrator
Paid Member
2007-09-15 8:14 am
It's not a Philips CDM12 for sure.

Not familiar with the unit, but, looking at the large ribbon connector to the pickup I wonder whether this is in fact a DVD drive (which many manufacturers use for both good performance and cost), in which case they can be a little noisy in my experience,
 
Thanks. To tell the truth I only looked up the transport type recently and long after replacing the laser (so convinced was I that it was the laser).

Do you reckon, I'd be better off using another transport and pickup in there instead? They're cheap enough and I've so far had bad luck with both attempts with this one. Is a straight switch like this possible or not so good an idea looking at the circuitboard fixed to it etc.

If the other Shanling units as per the reviews are anything to go by, a 12.1 should "fit"?

I'm now, and was a little before, out of my depth.

Apparently it's a HDCD so the wider ribbon may explain it but yes, I think it's a DVD pickup.

Thanks
 
Last edited:
I read in another thread that too high focus gain and tracking gain causes such noise. The advice was to turn down the corresponding pots until the noise just disappears. Another suggestion was to monitor the eye pattern, turn down the pots until the eye pattern envelope starts to be uneven, then turn up until just becomes quiet.
 

Mooly

Administrator
Paid Member
2007-09-15 8:14 am
I read in another thread that too high focus gain and tracking gain causes such noise. The advice was to turn down the corresponding pots until the noise just disappears. Another suggestion was to monitor the eye pattern, turn down the pots until the eye pattern envelope starts to be uneven, then turn up until just becomes quiet.

Correct... but... you really need to understand what you are doing. Tracking gain and focus gain have no direct effect on the visible quality of the eye pattern (RF) and will work within a wide range of adjustment, but that doesn't mean they are correct.
If the focus gain is to high then the pickup can become noisey (usually white noise... hiss). An experienced tech can get it pretty near spot on just by listening to the pickup. Tracking gain is more difficult and examination of the tracking error waveform will reveal the presence of a low frequency fundamental wave appear as the gain is turned up. Again an experienced tech can set the gain using this as a guide and adjusting the gain up to the point that the LF wave form appears. That can even be done by listening to the TE signal via an amp and speaker as unbelievable as it sounds in the absence of having a scope. There may be other adjustments... EF balance and offsets and really without the equipment and experience the only way is to have a manual. Focus bias is critical and has a direct effect on the signal... a scope is the only way to adjust this.

I suspect the noise is going to be something that can not be eliminated fully rather than a fault.

Fitting another type of pickup is a non starter... the whole of the servo and electronics is built for that one device only. They are as different as can be in every possible respect.
 
The saga continues, I've even uploaded videos of the problem here. I'm hopefull that one of you guys will know exactly what's going on.

ShanlingCD - swapfile

The file "OldMechOldLaserFault" is what's wrong, the constant high pitched beeping/scraping sound. This only occurs in PLAY mode and less so in PAUSE. As soon as I press STOP the fault goes away even though the disk is spinning just as fast.
Does anyone know what the specific fault is?


Remedies tried:

I installed a new laser to that mech but it had the same problem. Although the laser definitely reads, "Laserworking" video.

I bought a new mech and laser combo and installed it but the laser doesn't work. "NewMechNoLaser" video.

I put a cd in and it barely spins though I suspect if would if the laser read that there was a disk present "NewMechNoLaserNoSpin" video.

In the meantime I guess I need to wait for a replacement part.

Nathan Hudson - 14 Dec 2010 10:47
The shop tells me:

Hello!
"I am sorry.
Products in send out before,We must undertake strict test.
Laser head is more accurate instrument, In order to ensure the safe transport of laser head, So some laser head need added protection solder joints.We must use before use iron solder open this protection, Otherwise, laser head didn't light.
Thank you!"

Does this mean I have to de-solder something on the pickup?
 
Last edited:
Thanks.

Yes I guess it is more of a chirp sound now you mention it. It's a little hard to hear on the video but a chirp for sure, very frequent. Less so in PAUSE, but still regular.

Are the trim pots easy to locate (No, because I'm asking but you know what I mean). Where are they and what do I do?

thanks a million
nathan
 

Attachments

  • IMGP8474.jpg
    IMGP8474.jpg
    685.7 KB · Views: 100
  • IMGP8475.jpg
    IMGP8475.jpg
    614.4 KB · Views: 90
  • IMGP8478.jpg
    IMGP8478.jpg
    578.7 KB · Views: 101

Mooly

Administrator
Paid Member
2007-09-15 8:14 am
Any adjustments may need to be done via software or a modified "service" remote control etc however I still think the noise is going to be "normal" and not something that can be adjusted out. As mentioned DVD drives are often noisy... just try playing a CD in a DVD recorder.
 

nac134

Member
2008-09-04 1:47 pm
I couldnt see any on the board, but they can be pretty small. There are 4 adjustments that might be considered 'typical', but not all players have them. They have to do with how the player tracks the 'grooves' on the disc.
Basically, the transport is looking for the groove in a certain place. The pots adjust where its looking. Its never perfect, so the mechanism has error correction to find the groove. If the adjustments are off its giong to be looking in the wrong place. The chirping is the error correction working harder than expected - moving the laser around and such.
There are other symptoms that go with this problem. The player will be picky with discs, especially those that are not mint. It may also not play discs all the way through, or take an unusually long time to load.
In almost every case, there is a very little pot, often looking like a little disc, on the laser itself. You may want to try fiddling with that.
Calibrating optical disc players can be rather involved. If you are looking for a challenge and a learning experience, you might want to take it on. There is a great guide here Notes on the Troubleshooting and Repair of Compact Disc Players and CDROM Drives . If you just want it to work, take it to a shop.
 
Great, thanks!

I desoldered the new laser unit and that worked fine but the chirp was still there, even worse sometimes.

So I put the older unit back in and the chirp is much less!?. Either way the pots are surely worth a look at (given that I can always put them back to where they were I imagine).

Or if not a shop like you say.

It's much easier to live with now but even so, it may as well be right.

Thanks again, what a runaround.
Nathan