Cambridge Audio CD3 Player

do you have a scope? if so, you can try tracing the signal path back from the output. It could be several things: output relays (if any), the mute transistor (wrong mute signal or just a shot transistor), bad solder joint or cracked PCB trace (not unknown), blown opamp .... etc. best is to get a scope and poke around.
 
My Cambridge Audio CD 3 does not respond to any commands at all and the display is not working. When the power is switched on, the motor spins a bit and the LED at the front panel lights up, indicating that there is power. It also does not respond to remote commans.

What wrong with this player? I"ve been told that the user processor/interface chip is spoilt. What's the user processor of this player? It's in the same generation as the Philips 880/Marantz CD 85 with a CDM 2 mechanism and 1541 DAC.

Would appreciate any comments/suggestions. If anyone has the service manual, I would be really grateful.

Thanks in advance for your help.
 

jean-paul

diyAudio Moderator Emeritus
2002-09-20 7:20 am
Germany
Since this evening I am the proud owner of a CD 3 too and I am very interested in the manual of course. Did anyone find the manual or the schematics ?

Mine has tray problems and a broken DAC in one channel but it looks good ;)

It is my very first CDM 1 machine and it will end up as a non os cdplayer I think. The quest for the holy CD80 is over, long live the CD 3 !
 
jean-paul said:
Since this evening I am the proud owner of a CD 3 too and I am very interested in the manual of course. Did anyone find the manual or the schematics ?

Mine has tray problems and a broken DAC in one channel but it looks good ;)

It is my very first CDM 1 machine and it will end up as a non os cdplayer I think. The quest for the holy CD80 is over, long live the CD 3 !

Congratulations!

As far as i can can see you cannot remove the dig filter and connect the tda1540's direct to the decoder(s). It's 16bit to 14bit 4x with that filter. But since one dac is broken anyway, i guess you want to use other dacs.

I think it is possible to connect the tda1541 in parallel mode (one pin for left channel, one pin for right channel) and connect this before the filter. It's no i2s inside!

Greetings,
 

TV Man

Member
2002-12-12 4:34 am
US
CD3

I also have a CD3 and have been looking for the service manual.

The sales and tech representative for the present owners of Cambridge Audio (in North America) told me on the telephone they have been "looking for copies of those old service manuals for years now."

They get requests for them from time to time, but don't have copies. They also mentioned that the original Cambridge Audio is a company that hasn't been in existence for quite some time now, making it even more complicated searching for the manual.

Perhaps a hifi shop somewhere in England might have a dusty copy laying around somewhere??

I have been struggling with my CD3 for a few days after messing something up while changing the 1N4004 diodes to 11DQ10 Shottkys :(

The manual would be VERY handy right now....

Basically my 5v supply to the D/A converter card is dead. The LM 317 regulator gets VERY hot. I'm getting 13.4v on the rail feeding the 317 and .1v out of the reg.

Changing the diodes back to the original 1N4004 hasn't helped and neither has changing LM317 regs.

Still 13.4v in and .1v out of an instantly very hot regulator.

I've got the diodes in correctly according to the print on the power supply PCB... and all looks correct to my limited knowledge of electronics. Very frustrating as this was a very simple mod :(

Anyone have an idea what this might be??

This is a very fine sounding player when it's working.

Smooth and refined. Lots of potential!! I put OPA627 in the I/V stage and 1541A S1 grade chips for a nice improvement in sound.

I figured the power supply caps needed to be updated along with the diodes to get more smoothness, but now I'm stuck in the forest and can't see the trees with a dead player.

Can anyone help??

Thanks :)
 

jean-paul

diyAudio Moderator Emeritus
2002-09-20 7:20 am
Germany
guido said:


Congratulations!

As far as i can can see you cannot remove the dig filter and connect the tda1540's direct to the decoder(s). It's 16bit to 14bit 4x with that filter. But since one dac is broken anyway, i guess you want to use other dacs.

I think it is possible to connect the tda1541 in parallel mode (one pin for left channel, one pin for right channel) and connect this before the filter. It's no i2s inside!

Greetings,


Hi Guido,

it has SAA7310, SAA7220 and 4 x TDA1541A AFAIK, but I will check again this evening. So if I am correct it has ( or can have ) I2S.
 

TV Man

Member
2002-12-12 4:34 am
US
CD3

The CD3 has the standard SAA7210/SAA7220 chipset & 4xTDa1541A chips. Non oversampling and I2S should be no problem.

The logic circuit for the sample delay is using six chips with two markings: S=BB742 & DM74LS166N

Not sure if they are shifting by one sample, one bit, or one 16 bit word to get the "16x oversampling" effect.

Hope this helps.
 
TV Man said:
The CD3 has the standard SAA7210/SAA7220 chipset & 4xTDa1541A chips. Non oversampling and I2S should be no problem.

The logic circuit for the sample delay is using six chips with two markings: S=BB742 & DM74LS166N

Not sure if they are shifting by one sample, one bit, or one 16 bit word to get the "16x oversampling" effect.

Hope this helps.

Oops, i saw cdm1 and thought it was an old 14bit machine. Guess it should be cdm1 mk2 ???

Anyway, the '166 is 8 bit shift register. Put two together and you have a 16 bit register. So three 16 bit registers. Used to delay the data coming out of the 7220 to feed the dac's with i2s. Don't know exactly how, maybe split left right and/or make it differential. Or 8fs somehow.

The datasheet will tell. But going to non oversampling WILL BE A PROBLEM if you just remove the 7220:

Wordlength of the 7220 is 16 bit. Wordlength of the 7210 is 32 bit (with 16 bits unused). The construction with the shift registers will probably fail. You need to double the ammount of registers probably.

Again, you need the datasheet or can somebody do some 'reverse engineering'. Should be no big issue: connection of 7220, the '166's and the tda's.

Greetings,
 

TV Man

Member
2002-12-12 4:34 am
US
CD3

Hi,

A quick trace of the D/A card shows no differential output. The left output of each DAC are summed as are the right.

Could it be that the first 16 bit word is fed to the first DAC undelayed while the next three 16 bit words are delayed and fed sequentially to DACs 2, 3, and 4...??
 

jean-paul

diyAudio Moderator Emeritus
2002-09-20 7:20 am
Germany
Mmm, to make confusion even bigger I just read that the SAA7310 is a *fully* compatible replacement for the for me less well known SAA7210 with better CIRC and lower power consumption ( 175 mW due to NMOS die ). It is also suitable for CDROM applications.

So I don't see a reason for *not* making this cdplayer non os. Chipset is identical to other normal Philips cdplayers. The 16 x Fs process is done after the SAA7220 on a separate board with shift registers. I hope I'll be able to repair it. Till now it is flaky with intermittent tray problems probably due to a defect MAB8441P-T164 controller. When the tray opens its motor won't stop sometimes but if I tap on the MAB chip it 'll stop.

As I said on previous occasions CDM 1 plus the second generation decoders are not very known to me because I made the decision before that they're too old and finding a spare ones is a hassle. Now that I have such an oldie I regret my decision a little ;)

TV man, I checked the diodes on my board and I wondered if the print on the PCB is correct. The stripe on the symbols indicates the cathode of course. The print corresponds with the direction of the diodes so you made another error somewhere. Did you measure the 5V with the DAC board decoupled ?? That way you'll know if the error is on that PCB. Just disconnect the green power cable, when you have your 5V back you have to check the DAC board for errors.

BTW can you tell me what R25's value is ( it's on the pcb behind the front cover just below the infrared sensor ). R25 is burnt black in my CD3 probably because of excessive current of the tray motor. You can see R25 with the top cover off.