Go Back   Home > Forums > >

Software Tools SPICE, PCB CAD, speaker design and measurement software, calculators

First experience with KiCad
First experience with KiCad
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools
Old 25th November 2020, 04:42 PM   #1
tvrgeek is offline tvrgeek  United States
diyAudio Member
 
Join Date: Dec 2009
Location: North Carolinia/Piedmont
Default First experience with KiCad

I have never used a layout tool. A little searching led me to KiCad.
OK, it works. Figuring it out. But it seems very frustrating that once you get a preliminary layout, it is not capable of rubber banding the tracks. Seems you have to delete the traces, move the part and then reconnect.

Wondering if there is another free tool, not WEB based, that has this feature? Or is that the kind of thing you have to pay for?
  Reply With Quote
Old 26th November 2020, 01:28 AM   #2
Indiglo is offline Indiglo  Australia
diyAudio Member
 
Join Date: Sep 2018
It's easy - Left click mouse to highlight the track, then hold left click to move track around or right click track then select "move" or left click track then hit "G" on keyboard then move track.
  Reply With Quote
Old 26th November 2020, 10:45 AM   #3
tvrgeek is offline tvrgeek  United States
diyAudio Member
 
Join Date: Dec 2009
Location: North Carolinia/Piedmont
That moves a tract, but is not the "rubber band" feature. I want to move a component and have it bring the tract with it unless it crosses, in which case it would stop or highlight maybe. It does this in the view without traces, but not after you replace a point to point with a trace.
  Reply With Quote
Old 28th November 2020, 01:40 PM   #4
Indiglo is offline Indiglo  Australia
diyAudio Member
 
Join Date: Sep 2018
Update: Component rubber band feature coming early next year in Version 6.
Source: Kicad Forum
  Reply With Quote
Old 28th November 2020, 02:13 PM   #5
tvrgeek is offline tvrgeek  United States
diyAudio Member
 
Join Date: Dec 2009
Location: North Carolinia/Piedmont
Sweet.

BTW, I clicked on
Rubber band when moving parts? - Layout - KiCad.info Forums
and Malware Bytes blocked it due to "suspected trojan"
  Reply With Quote
Old 29th November 2020, 11:25 AM   #6
davidsrsb is offline davidsrsb  Malaysia
diyAudio Member
 
Join Date: Dec 2005
Location: Kuala Lumpur
Probably because the OP in the thread uses the word "ransomware"
  Reply With Quote
Old 31st December 2020, 12:30 AM   #7
dotneck335 is offline dotneck335  United States
diyAudio Member
 
Join Date: Dec 2012
Beware! I just tried KiCad version 5.1.8---bummer! It wouldn't load my 5.1.6-created files.
  Reply With Quote
Old 31st December 2020, 02:41 PM   #8
rsavas is offline rsavas  Canada
diyAudio Member
 
Join Date: Aug 2012
Location: Georgina, Ontario
Unbelivable, that a minor version change makes previous databases unreadable or convertible. Might want to contact the support to ask what’s up with that
  Reply With Quote
Old 1st January 2021, 02:02 AM   #9
JeffYoung is offline JeffYoung  Ireland
diyAudio Member
 
JeffYoung's Avatar
 
Join Date: Jul 2017
Location: Ireland
First experience with KiCad
All versions of Kicad read files written by all previous versions.

What error are you getting?
  Reply With Quote
Old 1st January 2021, 03:04 PM   #10
dotneck335 is offline dotneck335  United States
diyAudio Member
 
Join Date: Dec 2012
Hmmm....no error reported....when I try to load a previous 5.1.6-created pcbnew file, it just never loads--I waited an hour....it just doesn't load......the eeschema file does load, however....?? I went back to version 5.1.6 and all was good.
  Reply With Quote

Reply


First experience with KiCadHide this!Advertise here!
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kicad acenovelty Parts 8 18th May 2013 01:33 PM
Kicad: can't connect pins/wires Dan Moos Software Tools 4 16th May 2013 06:33 PM
How to have multiple copy of the pcb in the same sheet? (KICAD) washburn_it Software Tools 0 29th April 2013 11:04 PM
Switching from Eagle to KiCad panson_hk Software Tools 8 5th May 2010 03:21 AM
kicad problem zilog Parts 1 23rd November 2008 02:20 PM


New To Site? Need Help?

All times are GMT. The time now is 05:40 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright ©1999-2021 diyAudio
Wiki