diyAudio

diyAudio (https://www.diyaudio.com/forums/index.php)
-   PC Based (https://www.diyaudio.com/forums/pc-based/)
-   -   piCorePlayer = piCore Linux + Raspberry Pi + Squeezelite (https://www.diyaudio.com/forums/pc-based/275586-picoreplayer-picore-linux-raspberry-pi-squeezelite.html)

soundcheck 29th September 2019 10:08 AM

It's not about 64bit audio data playback.

It's about 64bit processing. That's a different subject.
Things can and many get more efficient. From what I read 20-30% performance gain in certain areas can be expected.

Considering the extremely poor RPI performance on e.g. HQ resampling. I'd very well appreciate such a boost.

I'll run the benchmarks if I'm done with it.

And it's not that there are no full (kernel and userspace) 64bit RPI OSes around. Actually they are around for quite a while.
The issue was the mainlinekernel and Uboot on these 64bit systems.
The PI without the PI kernel IMO looses it's key selling point. Since Pi4 the RPI folks concentrate much more on the 64-bit PI kernel.
That changes the game.

Greg Stewart 30th September 2019 02:44 AM

I want to say thanks to the PcP team for their support in getting my USBBridge Signatures up on PcP the last several days. I'm big into small op systems and player footprints and PcP fits that perfectly. AND they have made getting this running on their new Beta a pleasure!

THANKS ALL!

Greg in Mississippi

P.S. See my posts #588 & #594 in Allo's Shanti / USBBridge Sig thread:

Shanti Dual LPS 5V/3A , 5V/1.5A

Basically, the USBBridge Signature used as an RPi-substitute I2S source is STUNNING. Definitely as large of a step above my linear-regulated-modified RPi 2B as they were above a stock RPi. HIGHLY RECOMMENDED!

soundcheck 30th September 2019 07:21 AM

Dear Greg.

If you'd like to promote/introduce that product I'd really appreciate if you'd open a new thread.
I'd love to comment. I'd give my 2cts why people better think twice to go for such a product!

Quote:

I'm big into small op systems and player footprints and PcP fits that perfectly.
Wow. Didn't realize you switched sides. Now you're also BIG on the software side. That's good. We all know that only SW AND HW makes a solution.

Perhaps you could share your experiences on that SW side in another thread! Looking forward to it.

Great to have you around.

soundcheck 10th October 2019 01:40 PM

Just FYI - since we've been discussing it recently.

I finally manged to build a complete 64bit ArchLinux installation - kernel & userland.

Code:

root@boss64:~# uname -a
Linux boss64 4.19.76-rt25-sc1 #1 SMP PREEMPT RT Sun Oct 6 14:11:00 CEST 2019 aarch64 GNU/Linux

root@boss64:~# file /usr/bin/ls
/usr/bin/ls: ELF 64-bit LSB pie executable, ARM aarch64, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-aarch64.so.1, BuildID[sha1]=d3d0049a9af71d4be7a4dafff7d668b248b75319, for GNU/Linux 3.7.0, stripped

Not that many 64bit RPI OSes (with RPI kernel!) around. :D

Note:
The RPI kernel is prerequisite to get our beloved audio HATs going.
Since most 64bit systems come with the mainline kernel most audio devices
and a lot of other things wouldn't be working anymore. The RPI kernel
is a must and it's gonna be that way for quite a while.


Let see if Paul (and TinyCore) can catch up with a 64bit userland sooner or later. ;)

Enjoy.

paul123 10th October 2019 11:14 PM

Have you had the chance to do any 32/64 bit benchmarking? Then of course does it make any real audible changes? Curious if the effort is really worth it.

soundcheck 11th October 2019 06:59 AM

Quote:

Originally Posted by paul123 (https://www.diyaudio.com/forums/pc-based/275586-picoreplayer-picore-linux-raspberry-pi-squeezelite-post5940546.html#post5940546)
Have you had the chance to do any 32/64 bit benchmarking? Then of course does it make any real audible changes? Curious if the effort is really worth it.

Not yet. I'm still in the process to analyze and understand the situation. You know that the devil lies in the details. ;)
For sure it's more then just a simple swap. And there's not much info around. Lot's off digging.

E.g.
* rewriting/updating all my scripts
* gcc CFLAGS are different
* I tried to compile flac/libflac and I'm not sure yet if and how NASM works on 64bit ARM.
* and then ArchLinux doesn't offer a 64-bit userland for PI-4.
* ....

I think you'd do good to not waste too much time on it for know.
You'd obviously would have to provide a separate 64bit image, just for PI3/4. Not sure if you really want to go down that road.
Your 64bit kernel und 32bit userland is a stable and extremely well working solution. IMO no need to step up in the near future.

Onvinyl 19th October 2019 12:37 PM

Quote:

Originally Posted by paul123 (https://www.diyaudio.com/forums/pc-based/275586-picoreplayer-picore-linux-raspberry-pi-squeezelite-post5927503.html#post5927503)
Sorry, I lost track of the conversations over here......did you get your NFS problem sorted.

More than likely you are missing a mount option "vers=x" (Where x = 3 or possibly 2) it depends on what you are trying to connect to.

No, I’ve given up. Using a usb drive instead of network now.

ElEsido 2nd March 2020 09:56 AM

Quote:

Originally Posted by Onvinyl (https://www.diyaudio.com/forums/pc-based/275586-picoreplayer-picore-linux-raspberry-pi-squeezelite-post5906194.html#post5906194)
I have an issue with picore 5 on rpi3

Setting up an NFS share isn't working.
I have 'additional file systems' installed.

When trying to mount it 'by hand' in a shell I get
Code:

sudo mount -t nfs 192.168.178.66:/export/data test
mount: wrong fs type, bad option, bad superblock on 192.168.178.66:/export/data,
      missing codepage or helper program, or other error
      (for several filesystems (e.g. nfs, cifs) you might
      need a /sbin/mount.<type> helper program)

      In some cases useful info is found in syslog - try
      dmesg | tail or so.

which indicates that something is still missing
(the mount works fine on a raspian-install)
Rüdiger

Try adding the following at the end of your mount command:
Code:

-o username=yourusername,password=yourpassword,sec=ntlm,vers=3,uid=1001,gid=50
If you didnt' set a username or password, just put in "username=1,password=1".

djedje7676 8th April 2020 08:52 PM

Hello all, hope you're good in these bad days!

I have a question/remark: I used Picore with Hifiberry DAC+Pro for a long time with LMS installed on the same Rpi, I changed my speakers recently and the sound quality was not good at all.
Then I tried Max2Play and Dietpi with only Squeezelite and LMS running (should be equivalent to Picore then): the sound quality is much better than Picore (I had no voices, like no medium frequencies).

Does someone have an idea of why I find so bid sound quality difference between Picore and the two other (quite equivalent in sond quality)?

Thanks.

paul123 9th April 2020 12:17 AM

Did you change your amplifier too? Nothing in the OS should have done that, unless you were running AlsaEQ and somehow the mixer settings got changed.


All times are GMT. The time now is 10:31 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 17.65%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio

Wiki