YBA CD2 alpha : laser diod don't light up.

I have a problem on a YBA CD2 alpha player. The laser diod and the YBA blue LED don't light up. Trying to initialize a new CD, the pick up moves correctly to the center of the disc to the position switch. Then the lens moves up and down to search the CD but the laser does not light up.

This happened after I disconnected and reconnected the mechanism (pick-up + spindle motor + sled motor + switches) from the main board.

The pick-up is only two years old and had been replaced and adjusted by YBA. I swapped the whole mechanism with a spare one got from a TEAC PD-365 but it didn't change anything.

As far as I know, YBA never published any service manual, so I've got the one of the CEC 780-880CD which is built on the same base : a SF90 (with 2 6 pin connectors) Sanyo pick-up and a Sanyo mainboard.

According to the service manual, the laser diod is controlled by the Sanyo LC6554H microprocessor. When the pin 43 is low, the laser emits the beam. In addition of the player state, two conditions must be met : the tray must be closed and the pick-up position switch must be closed. As there is no tray on this player, YBA shorted the tray switch so as it seems always closed.

I checked that both signals came properly from the mechanism to the LC6554H on pins 18 and 19. I checked also all the components on the laser control circuit from pin 43 to the pick-up connector and the laser power supply circuit. The only problem I found is that the pin 43 is always high (+5V) even in initialization time.

Did anyone experience such kind of problem ? Might be something wrong with the LC6554H ?

Thank you for your help.
 

Attachments

  • YBACD2.mainboard.JPG
    YBACD2.mainboard.JPG
    149.3 KB · Views: 171
  • YBACD2.mechanism.JPG
    YBACD2.mechanism.JPG
    88.7 KB · Views: 154

Mooly

Administrator
Paid Member
2007-09-15 8:14 am
The fact it does a focus search routine but doesn't pull the LD on pin low is a bit disturbing.

Could the micro have got zapped when you were working on it ? I hope it was all unpugged from the mains while you were connecting/disconnecting ribbons. I wonder if a rail was charged and the ribbon made contact somehow.
 
The player was unplugged when I was disconnecting/connecting the ribbon. But, at a certain point, I plugged the main on without the ribbon connected. May be this brought some confusion to the µproc and for some safety reasons, it has locked the laser beam. Yet, this is not documented in the service manual.
Another thing could be that some components from pin 43 to the ribbon didn't like that the circuit was open. They are not so many of them : capacitor C051, 2 transistors used as switches Q12 and Q13 and 4 resistors. I wonder if some damage on one or several of these could maintain the pin 43 in +5V, which is the same voltage as the one on the transistors's emitters and bases. This could explain why the focus works properly.
 

Mooly

Administrator
Paid Member
2007-09-15 8:14 am
I doubt the uP has locked anything. That would imply a backup 5 volts and /or non-volatile RAM somewhere. (Sometimes where that is the case then discharging all caps and then pressing tinfoil hard on to the PCB covering all uP pins can remove residual charge and provide a "reset") I don't think anything like that is happening here though.
 
I tried with the tinfoil but it didn't change anything as expected.
I decided to check again all components on the laser control circuit, especially transistors and capacitors which may be tricky to check. I found out that a capacitor was zapped (the capacitance measure was right, so to be clear in one's mind about it, I made a little circuit to check the tension and the time of charge/discharge under the condition of the original circuit). I will tell you when I will get through all of this.
In the meantime, a new picture of the famous blue diod soldered on the SF-90 head. In the background, the zapped capacitor (1) added by YBA ,another capacitor on the laser power circuit (2) , and the two transistors for light up control by the µproc (3 - 4).
 

Attachments

  • YBACD2.mainborad and mech.jpg
    YBACD2.mainborad and mech.jpg
    192.6 KB · Views: 128
Hello Michael,

Thank you for your support.
I'm still having the problem on my player.
I changed a few components on the laser control circuit, the transitors Q012 and Q013, the capacitors C051and the 470µF one in parallel added by YBA. You can find these references on the attached schematic that I made from a CEC 880 player and modified according to the tweaks made by YBA (as far as I know) After that, I got back the voltage values given by the schematic, except the one of the µproc pin 43 which was always at 5V even at playing or initialization time. The Sanyo.LC6554H µproc datasheet tells that pin 43 is an "open drain" type output with the Mos fet source connected to ground an the drain pulled up by an internal resistance to 5V. I suspected that this MosFet was zapped with the source-drain channel always "closed".
To solve the problem, I added a little switch near the disc tray, connected to pin 43 and the ground, in order to pull down the voltage, making manually the job of the µproc. For instance, when I want to initialize the CD, I push up the play button and at the same time the little switch to light up the laser. Once the player displays the tracks information, I switch off the laser. Yes I kown it's a little bit rough but I can live with it.

Do you think too that the µproc is involved, and in this case, is there a way to fix it or replace it ?
 

Attachments

  • YBA.CD2.Schéma.v4.jpg
    YBA.CD2.Schéma.v4.jpg
    504.3 KB · Views: 96
hi mate am Steve from the uk,
i have a yba cd 2 i was wondering if you can help me fix it? it seems to have a strange fault. seem that that motor to the laser only worked when you hold the cog, it wont find a cd unless you put the lazer in the right place and it only works for 30 secs unless you move the cog that conected to the motor, be mega greatfull if you can help thanks

steve
 

Mooly

Administrator
Paid Member
2007-09-15 8:14 am
Hi there yes it moves back

OK. That's good.

Now when you can get it to play for 30 seconds or so, is there any sign of the motor (the gears) moving or trying to move. The amount of movement would normally be very small, more a case of seeing the motor twitch back and forth but it should be visible.

Also, another test to help confirm what is happening would be to solder a couple of wires to the above sled motor and connect those to your meter. Get it to play and monitor the voltage across the motor. If the voltage builds and builds without the sled moving then that points to either a faulty motor or the sled that is mechanically sticking. Both are common problems on any player.