Xonar Essence STX ii recording - no info above 22KHz

Asus' web specs say this card will record at multiple sample rates including 96KHz and 192KHz. When used with Adobe Audition under Win10 or Audacity under Xubuntu 16.04, the files are at a higher sample rate, but there is ZERO information above a sharp 22KHz cutoff. It's as if the card itself is operating the analog-digital conversion at a lower rate and/or stripping info. See screenshot or spectral analysis.

Can anyone say they've seen the same (or something different?)

I did not see this behavior with my older M-audio Delta 24/96.
 

Attachments

  • SharpCutoff.jpg
    SharpCutoff.jpg
    294.4 KB · Views: 88
four years later: I solved the problem, then forgot how to solve it, then solved it again. phofman was correct - the card was recording at 44.1KHz sampling. The challenge was how to change this in my environment. Running Xubuntu 18.04, and 19.10, I was using Audacity to record and setting the sample rate in the program never changed the result. Ultimately, it came down to PulseAudio. Tricks to disable pulse and run Audacity did not work in my system - I simply got no input. This made it apparent, Pulseaudio was controlling the source. More digging indicated that I could override pulseaudio defaults by editing the file /etc/pulse/daemon.conf. By uncommenting the default sample rate (and sample size!) and changing to what I wanted, Audacity was finally fed the audio I wanted. Posting this here, in case someone else has the same issue some day... or if I forget what I did before :D
 
The easiest way to avoid PA blocking your soundcard for other alsa clients is to disable the soundcard in PA. In GUI tab Hardware -> selecting the given soundcard -> profile "Off" or "Disabled" or whatever appropriate in your locales/GUI version. Then audacity with alsa output can use the soundcard exclusively.