What is this mess on the PCB?

Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.

ShinOBIWAN

diyAudio Member
2004-02-25 9:13 pm
UK
Hi folks

I spotted some odd residue on my PCB recently. The component hadn't been used for about a year and was safely stored away in the house during that time. I pulled it out to use again and did a quick inspection only to find this. Can anyone tell me what it could be? I haven't powered it up for fear of damaging something, it was working fine the last time I used it before storing.

Any help or advice would be appreciated.
 

Attachments

  • 20160123_095540a.jpg
    20160123_095540a.jpg
    543.5 KB · Views: 333
  • 20160123_095558a.jpg
    20160123_095558a.jpg
    571.8 KB · Views: 315
  • 20160123_095610a.jpg
    20160123_095610a.jpg
    481.6 KB · Views: 303

ShinOBIWAN

diyAudio Member
2004-02-25 9:13 pm
UK
Clean it with distilled water several times with a soft brush, then leave to air dry.

Should be fine.........

Hugh

Thanks Hugh. I was worried it was something serious like a leaky capacitor or something! The component is only 3 years old so thought it unlikely glad its just rain water. Makes sense since I moved house awhile back and it was tipping it down when we emptied the moving van so could have easily picked up a drop through the vents on the case.
 
Clean it with distilled water several times with a soft brush, then leave to air dry.

Should be fine.........

Hugh

Dish washer, on its own. I kid you not! These things are designed to clean and leave no residue and air dry. I've done it with complete amps, scopes, things like that. All worked flawlessly afterwards.

Jan
 
Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.