Technics Su-V8 phono equalizer opamp upgrade

Technics SU-V8 bias and dc offset adjustments

I downloaded a manual, and my mulitmeter is only a 3 digit, and i set it at dc mode as per photo.

I find it was running very very warm while doing these adjustments?

This is my first time at doing my own bias, i fitted the V8 with MT200 Sanken transistors
bias 40mv in the manual?
[IMGDEAD]http://i67.tinypic.com/2luv3b4.jpg[/IMGDEAD]

[IMGDEAD]http://i67.tinypic.com/10qcprr.jpg[/IMGDEAD]

dc offset minimum reading ? shoulve ive gone into the negative readings?

[IMGDEAD]http://i66.tinypic.com/2ntwgzk.jpg[/IMGDEAD]
 
Last edited:
Hello,

I would like to upgrade the phono equalizer in my Technics SU-V8 amplifer. The photo shows the pin voltages, and the current old NJM4559DS. Which TI op-amp would best suit. I am after clarity etc, improvement over the old JRC. I have used LM4562 in CD players with great results, though it may be not be suited to this situation.

[IMGDEAD]http://i64.tinypic.com/5wec5l.jpg[/IMGDEAD]
 
from the net:
I didn't post the OPA2134 versus NJM2068 results because they are essentially identical.
The OPA1612 is definitely noisier most likely due to its bias-current cancellation and higher resulting
input current noise.
I put the OPA2134s back into the preamp and will be using them.
The OPA1612 is going into the RIAA EQ stage.

Yes, they are very, very close.
You can compare the green traces in the post to compare the OPA2134 to the NJM2068.
Side by side the '2134 and '2068 virtually overlaid so I didn't capture the plots.
In fact the NJM2114, the NJM5532, OPA2134 and NJM2068 are all very, very close with a cartridge as a source.

With a 2K Rsource the OPA1612 and NJM2068 have similar noise signatures.
With a cart it is an entirely different story with the NJM2068/OPA2134 being much quieter than the OPA1612.

The NJM2068 is slightly better in the midrange at 1/10th the cost of the OPA2134.
The OPA2134, considering that its a FET input with higher voltage noise nevertheless has outstanding performance.
30dkqjs.jpg
 
Give the OPA1642 a try. It's a JFET-input amplifier like the OPA2134 but with 5.1nV/rtHz input voltage noise, and very low flicker noise which is important in RIAA pre-amplifiers.

It's what is in my MM phono pre-amp at home :) (schematic in the back of the updated OPA1642 datasheet).

A cheaper option is the OPA1652, which also has fantastic input current noise and a broadband noise voltage of 4.5nV/rtHz at 1k (actually falls to 3.8nV/rtHz at 10k). However, the flicker noise in the OPA1652 is not as good as the OPA1642.
 
Last edited:
Hi,

it's always nice to see the classics getting some love ;)

Opamp swapping for these does not come without issues, though. Looking at the board drawing, I don't see any decoupling cap on pins 4 and 8 (supply pins). This might be ok for the old and slow opamps, but not for the new ones.

All modern opamps strictly require decoupling very close to the opamp as they oscillate wildly otherwise. You can add that by soldering in 100nF caps (film or ceramic) each from the supply pins to ground. Usually one can do this most easily on the underside of the board.

This cannot do any harm, but only improve things in any case.
 

aspi

Member
2013-05-17 10:43 pm
Hi MaccAu,

I second h_a, local supply decoupling is very desirable. But this is more easily put between the rails, that is, a cap on the trace side to pins 4 and 8 directly. Even better: a socket with a pre-fit cap, such as MPE-Garry 001-3-008-3-B1STF-XT0.

Pay attention to the JFET arrays in your signal path. They limit any difference a new op amp can make. They give some physical length to the NFB path, so too fast an op amp may oscillate. (The 4559 is very slow.) If I'm not mistaken, their feeding resistors set an intermediate source resistance thus making ultra-low-noise op amps and those with a FET input pointless. Try a 4580 then?

Maybe there is some potential in looking at the caps in the signal path. The RIAA values (C107... 112) seem to be carefully chosen, but ideally they should be 1% C0Gs. C105/106 might be very old. C113/114 may be replaced with 4.7 µF PE caps.

Happy (de)soldering!
 
Hi MaccAu,

I second h_a, local supply decoupling is very desirable. But this is more easily put between the rails, that is, a cap on the trace side to pins 4 and 8 directly. Even better: a socket with a pre-fit cap, such as MPE-Garry 001-3-008-3-B1STF-XT0.

Pay attention to the JFET arrays in your signal path. They limit any difference a new op amp can make. They give some physical length to the NFB path, so too fast an op amp may oscillate. (The 4559 is very slow.) If I'm not mistaken, their feeding resistors set an intermediate source resistance thus making ultra-low-noise op amps and those with a FET input pointless. Try a 4580 then?

Maybe there is some potential in looking at the caps in the signal path. The RIAA values (C107... 112) seem to be carefully chosen, but ideally they should be 1% C0Gs. C105/106 might be very old. C113/114 may be replaced with 4.7 µF PE caps.

Happy (de)soldering!

Thank you Aspi for the help, and input on the 4559. On my V9, i replaced the ceramics with film caps wimas, including the bipolars. I will look at those caps on the V8.

So a cap on pins 4 and 8 underneath the pcb? like a wima?

Thanks Sam :) yes i use japanese goot desolder, very effective and good:D
 

aspi

Member
2013-05-17 10:43 pm
Thank you Aspi for the help, and input on the 4559. On my V9, i replaced the ceramics with film caps wimas, including the bipolars. I will look at those caps on the V8.

So a cap on pins 4 and 8 underneath the pcb? like a wima?

Thanks Sam :) yes i use japanese goot desolder, very effective and good:D
Hi MaccAu,

yes, it will be a lonely part on the solder side and the connection should look like a 'Z' or 'N'. In this place a WIMA seems bulky to me while the cheapest ceramic 0.1µF will do perfectly well. Most conveniently, pick an axial X7R and bend the leads to an 'S'.

This cap provided, I'd give the 5532A a try.

Cheers!
 
Technics SU-V8X bias adjustment

Hi All,
It appears my Technics SU-V8X has a bias issue, left side was so hot it would burn your hand if left there. I checked under the pcb and toched up solder that looked a bit iffy, the thermal compound is pretty old about 2008 or so, and of a cheap brand unick, but the other channel is fine, so must be the bias!

Should I follow just the steps 1,4 and 5? I only need to fix the bias
Thanks
Sam

[IMGDEAD]http://i67.tinypic.com/iftr9f.jpg[/IMGDEAD]