TDA7498 Class D Sure Amplifier modified

:confused:I recently modified the low pass filter section of a sure TDA7498 amplifier board. I am running a pair of 10" Crown woofers with vintage Philips AD 0161 tweets with a passive air inductor crossovers from Philips. The power handling is 65 watts into 8ohms. With a dc resistance check I get a reading of 6.1 ohms. This is normal for a 8 ohm speaker.
I have obtained pleasing results using the filter configuration found on the chip manufactures data sheet The modification was challenging for me as it took me a while to come to a decision on the values to use. Using the manufactures values made sense, as I was not designing the output filter to a particular set of speakers.
The board is small, so fitting the full size components on it was difficult. Two of the caps and the resistors on both channels had to be mounted underneath as to keep the leads short. I used the values in the manufactures applications circuit diagram for 8 ohm speakers. Before doing these modifications, the amp would go into a protective state way before the maximum output could be achieved. The sound now, is clear and the high end isn't overpowering with noticeably less distortion.
I am curious to know if anyone has had experience with snubber circuits and the effect of not having them included. Sure has left them off, but the places are included on the board. The proximity to the chip being in question as to the benefit of adding these components. Research into the topic has revealed that placing the RC circuit farther than 3 mm from the IC pins can cause arcing. Of course this concerns me as I often enjoy driving my system hard at times. The area where the snubber should be is about 2 cm from the IC. That is perhaps why sure chose to omit the snubber components from the board.
Your feedback and opinions would be greatly appreciated before I move on with these additional modifications or not.
I should mention, that I also replaced the two SM coupling capacitors with metalized poly caps as to reduce input distortion All the SM components on the output filter rebuilt with metalized capacitors, 5 in all and two metal 8.2 ohm 1 watt resistors for each channel.
My questions now, should I go further or leave well enough alone? Would you chance arcing by installing the missing components left off board
by surehifi, and the high pass and clock resistor? I haven't noticed any switching noise from the chip whatsoever, so not sure what to do at this point.
In summary, the modifications so far have yielded excellent sound from the board with the chip not shutting down or going into protective state. I have added a rotary encoder board for a volume control. The amp is powered at 34V. This is the suggested voltage for 8 ohm speakers. I noticed some EMI from the fan motor. This is eliminated by switching the encoder to volume mode. Upon initial power up, the rotary encoder defaults to off mode and the two led lights go out.. By pushing the knob, the encoder enters the volume mode and can be adjusted. Other than an addition of a ferrite ring inductor on the the fan cable which I have installed, there probably isn't much more I can do about it, unless I can find a fan that doesn't give of so much EMI. Any ideas for that would be helpful. It would be nice not to have to switch the encoder to volume to avoid this low level switching noise from the amps cooling fan. A minor flaw probably not worth any more time trying to solve.
Perhaps at this point, enough has been done as the output seems to remain stable at higher volumes now. Perhaps the changes I have not attempted, will have little noticeable effect on sound quality. Still the temptation to do these changes is there for me. Any ideas?
Audiophiles, always tweaking and pushing the limits.
Many thanks
 
Last edited: