• Disclaimer: This Vendor's Forum is a paid-for commercial area. Unlike the rest of diyAudio, the Vendor has complete control of what may or may not be posted in this forum. If you wish to discuss technical matters outside the bounds of what is permitted by the Vendor, please use the non-commercial areas of diyAudio to do so.

Support for Botic Linux driver

I tried to make this firmware as simple as possible for the user. Plug and play. "http://botic7.local"
Linux is built on the basis of builbroot. And it has a minimum set of required components. The kernel is tuned for maximum stability with the DSD512.
(ssh root/root)

If you need advanced tuning for your requirements, then this firmware is not for you.


I tried your Pure firmware, it looks simple and well done to me.

But i have a problem powering off the BBB after use. Usually, using other firmwares with botic driver, i simply switch off the PSU, then it takes power from the battery connected to hermes-BBB while botic shuts down the BBB in a secure manner.
But using your Pure firmware, when i switch off the PSU the BBB takes power from the battery but botic doesn't shut down the BBB. So it remains on until battery drains... I'd have to use shutdown harware button on BBB, but to do that i should open my dac every time.

There is a way to activate this power off botic functionality in Pure firmware?
 
Hi drone, you do not need to use the clock dividers. Simply use the original pure parameters and set the jumper to 1:1.


Hi,
just wanted it to be the way as before (as I have tested several clock speeds) so I can use the divider.

Just not sure about the further Opargs-settings? Tried to set them to "default" AS per Miero's page.

also not sure what to do with these:

snd_soc_davinci_mcasp.mute_pins=8 snd_soc_davinci_mcasp.amanero_mute_delay=500 snd_soc_davinci_mcasp.amanero_mute_pins=8

This is preconfigured in Pure firmware. In original Miero Botic these are missing.

BR

Branko
 
Last edited:
Don't think you need these parameters but I would simply not touch them as they should not do harm and it is possible that they need to be set to something...


Not sure I understand the clock speed setting. Does it mean for you using the divider improves the sound quality? In every other case I would use the higher clock speed and not use the divider since that provides a wider range of sample rates that you can playback...
 
Hi people! I have a strange problem that I hope is really easy to solve; but what I found after some quick googling did not help, so I ask here ... I have BBB-hermes-cronus connected to DDDAC ... It has been working well for a very long time, only slightly annoyed after power downs and such. Now I get this: "ERROR: All audio outputs are disabled" when I try to play with mpc. Is there a simple solution to just enable the outputs again? I have no clue as to why they have stopped working, as I have not touched any settings or conf-files or anything like that. I would very much appreciate any help or hints of what to do. :-]
Forgot to mention I play from NAS, but that seems to be all ok ... It is mounted, and the files are there ...

---- edit: OK, so now I got it to play with 'play' ... Maybe it is fixing it self??? I let it play out, and see if anything is different with mpd/mpc ...
 
Last edited:
I see your edit - perhaps your MPD configuration file has been corrupted and should be replaced.

Yeah, but when I look at it, it looks fine. Maybe I can do a 'filecheck' or what it is called on the whole linux system?

edit: I actually think my card is totally full. Not sure how to fix that, really ... Remove something that is not needed I guess, but what can that be? I'll start there, and see if that helps. Not sure how it got full, though. Some 'auto update' or something that I am not aware of, maybe? :-/
 
Last edited:

bern

Member
2010-07-19 10:26 am
Try to find out how much free disk space you have:
Code:
df -h
Check in your mpd.conf (eg: /etc/mpd.conf) location/directory of your log file mpd.log.
Check the size/how big it is your mpd.log. Maybe it has grown too much and overfilled? If so, remove unnecessary content.
 
Thanks, Bern!
Yes, no space at all. I see I have quite a few directories with Beaglebone-stuff that can be deleted. Like './lib/cloud9_backup_examples/examples_old/.git/objects/92'

Do you happen to know the exact frase to use in this case?

Like ...

Code:
sudo rm -r ./lib/cloud9_backup_examples/examples_old/.git/objects/92

?

Or could I go with even broader strokes and remove the whole 'cloud9_backup_examples'-directory?
 
It works again! And, the solution was as easy as it could be; it is a 'toggle' in mpc to turn outputs on and off. I have never seen this before, and have no clue how it was turned on in the first place. One possibility is the fact that I just had to replace my cellphone, and in regard to that I accidentally used a different app to control my music (M.A.L.P), and this app have done something like that? Sounds strange, but I have no other explanation. Unless the fact that I also really had filled up the memory card of my BBB to the rim made something go a bit off the rails ... Anyways, super happy it started working again, and thanks very much for the help given here!
 

francolargo

Member
Paid Member
2007-03-12 8:07 am
Twin Cities, MN
Are you connected to any devices that are capable of recording? Try ‘arecord -l’. My experience with older Botic versions is that there is no way to capture PCM without some kind of recognized input device. However, I have no experience with Jack. I have had some success programming the user area of ALSA. It is more work than Jack, but just as powerful and probably more flexible to write custom ALSA plugs.

If you let us know your objective, perhaps we can get you running with ALSA.

Best,

Frank
 
I couldn't get a solution with ALSA so I decided to try it through JACK.
Has designed a very simple yet well-sounding balanced dual mono DAC-cape on UDA1334.

LittleRedRidingHood.jpg


ALSA splits channels into left-right and changes the phase.
Code:
pcm.!default {
	type plug
	slave {
	pcm botic-split
	channels 2
	}
 }
pcm.botic-split {
	type route;
	slave {
	pcm "hw:0,0"
	channels 4
	}
	ttable.0.0 -1;
	ttable.1.1 -1;
	ttable.0.2 1;
	ttable.1.3 1;
 }

This DAC works great with all Pure Firmware players except TidalConnect.
This player can only play on hardware alsa device or JACK.
I wanted to build the following chain: TidalConnect->JACK->Alsa(default output)->Botic

I think can try to solve the problem through a virtual alsa loopdevice. But so far, I also do not understand how to do this.
 
Last edited:

francolargo

Member
Paid Member
2007-03-12 8:07 am
Twin Cities, MN
That looks like an intertersting project, but it is not clear to me what is the role of Botic. A loopback gives you the ability to process a PCM stream using separate memory that you assign to a different (virtual) device like hw:1,0, but the final destination of the processed signal remains hw:0,0.

I am away from my home system until next week. When I return, I will send you example plugs to create a loopback. Until then you may possibly find examples on the web as used to run BruteFIR, which is the application that I ran using input via hw:1,0.
 
Last edited: