Rotel rsp 976 memory capacitor problem

srinath

Member
2010-02-12 4:09 pm
I just got an RSP976 preamp/processor.
It has very low memory holding time frame, like 2-3 hours.
Also its not sensing the remote most of the time.
Could these 2 be related, or could someone point me in some general direction, like the memory cap would be on the PS board or something like that.

Thanks.
Srinath.
 

srinath

Member
2010-02-12 4:09 pm
@Percival007: I will look @ 5v standby trafo. I do have manual, but see I am clueless, unless there is a part labeled Memory cap, or memory transformer I wont be finding anything. I have it plugged into a power conditioner type supply, I usually turn it off, but I think I forgot yesterday. But I also didn't put any settings in it either. I'll try putting some settings in it and see.

@Rayma: I don't get what you said. Turn it on for a day - as in leave it powered up (not in standby) Then turn it off - meaning - unplug ? or was that first one on and second one standby ?

I guess you mean leave it powered on a day with some settings, then put it in standby a few mins. Then power it back on and see if it remembers what you put in earlier ?

Also the remote has a few buttons that are very hard touch. Possibly the well used buttons - volume up and down especially. I think its got worn out pins under it. I'll open that to check.

Thanks.
Srinath.
 

srinath

Member
2010-02-12 4:09 pm
I didn't check this yesterday, but I have an issue in it I think.
It works ocassionally, especially volume up/down. But I have to press the remote buttons hard, and the remote makes a beep sound and the preamp accept it and starts to increase/decrease. However all other buttons in the remote beep rather easily, with a normal touch, but the amp does not sense it at all.

Maybe the remote has learnt controls of a different amp ?

I will have to try to get it to learn this one ? maybe I'll see how to do that.
Thanks.
Srinath.