Revox B126 CD Player Malfunction- Help Needed (TDA1541A-CDM4/27)

This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.
I have a Revox B216 CD Player that started distorting and then suddenly stopped recognizing discs ie No TOC and no playback.

The motor would spin the CD and the radial control for the laser would move it towards the middle of CD to read TOC, but the Focus mechanism (vertical control) would not function.

What I have done so far:

Replaced the laser assembly/ribbon connector from a CDM4/19 -no change
Replaced the imfamous 33uF 16V axial Philips cap as well as the other caps on the Servo board - no change
I changed out all the electrolytic caps on the Servo Board as well (except the small Bipolar cap - 1.5uF)

Months ago I replaced all the electrolytic caps on the Decoder Board (DAC/FIlter/7210 Decoder/Analog output stage) as it worked fine for the past 2 months.
Checked all the voltages on main Decoder board - measure as per service manual.

Checked voltages on Servo board and discovered a 1 ohm safety resistor had opened up and so the -10VDC to TCA0372 dual power opamp (focus & radial control of laser assembly) ended up being +5VDC to the -V(ee) power pin (-V pin 4, 9-16).

Replaced 1 ohm with new resistor and all power supply voltages to the TDA 5708 & TDA5709 as well as the TCA0372 are now correct.

The focus control does not move vertically once the disc spins and searches for the TOC.

Could the TCA0372 Power Opamp be damaged as a result of the V- (or ground pin for single supply) pins received a positive voltage in this case +5 Volts?

The Radial control (other half of the TCA0372 Power Opamp) seems to function correctly as it moves when it suppose to. Install disc & laser seeks the TOC at the inner edge of CD.

The laser light is functional as it seems to have the typically brightness of other CDM4's that I have used.

SO any ideas for the repair?

I am measuring I believe -9VDC to the focus motor of the laser assembly when powered up (Measured at the ribbon cable on the laser). I could not measure this same voltage when I press play because of the logisitics of the transport but I believe it stays constant since it isn't moving in the vertical direction.

Is the TCA0372 damaged? The radial control laser seems to work but.....
Could the TDA5708 decoder damaged.... but it really didn't see the wrong voltage like the TCA0372 as the 1 ohm resistor only feeds -V to the TCA0372.

Any help would be appreciated.

Thanks in advance,
It looks like you've done some decent troubleshooting. I think replacing the TCA0372 is worth a try. I have repaired a player which had a dead one of these before (I can't remember whether the radial drive on that one worked or not, but the focus sure didn't). I can send you a used TCA0372 for the cost of postage if you want, just PM me.

I changed out all the electrolytic caps on the Servo Board as well (except the small Bipolar cap - 1.5uF)

I'd change this capacitor as well, it can cause problems with tracking (it won't be causing your focus problems though). Replace it with a 1 - 2uF MKT, it'll never be a problem again.
Joined 2007
Paid Member
Think that IC is similar to the L272

It's just a power opamp, so careful voltage measurements should reveal if there is an issue. If the 1 ohm safety res has gone up then that's quite likely... or else there is a short on one of the outputs somewhere. Have you scoped the focus search ramp waveform.

Check the voltage on the inputs and outputs... it behaves as an opamp.
I have power corrected as result of replacing a couple of transistors in Main Power Supply.

I replaced TCA0372 with a unit from a Philips player temporarily Anton (AMC) is sending me a few items in the meantime.

So I replaced TCA0372 and I have all the correct power supply voltages to the servo board & elsewhere.

I resoldered every solder joint (on the Servo Board) just in case there is a bad/cold solder joint.

I put the Revox in service mode and initially the laser would move back & forth (radially - horizontally) going thru Steps 1 -11. Steps 12 -14 the cd spindle motor spins.

The laser is visible, but the focus (vertical movement) is non-existant diring ANY of these 14 steps.

The I turned it off and went back in the Service Mode and the radial movement of the laser stops working as well.???? It moves to the inner disc when I initially go into Service mode then within 3 seconds goes back to neutral position.

I put it back together and add a CD and turn it on & press play for the 1st time. The Laser moves to the TOC ( before I press play) for a few seconds and then move back past the neutral section closer to the outer edge. The disc spins for 3 seconds and stop. The laser assembly does not move vertically (focus) or horizontally (radial) but I think (?) the laser is visible (Red LED) when I press play and the the disc spins for a few seconds. SO I have a laser that does not move in vertically or horizontally directions and the laser will light up in Service Mode but I am not sure it emits when I press play.

Anton (DIYAudio AMC) is sending me a TDA5708 & TDA5709 IC to replace the existing units as I am running out of ideas.

Initially when I sensed a malfunction, the first symptom was distorted sound and then really got bad and then the disc could not be read. So it sounds like something failed (other than the TCA0372 as I really don't know when this got damaged.... I know when it totally failed and took out my power +/- 10V & (+/-5V Regulated) as it shorted across the + & -10V as there is a dead short across Pin 2 (+PS ) & Pin 4 (-PS), but this was hours into my troubleshooting adventure.

Any ideas?

TDA5708 & TDA5709..... but some of the function work (laser for TDA5708 & CD spindle motor for 5709)

Any help would be appreciated!

Thanks in advance.
I sent the ICs off today, they should be with you soon.

I think you should have a closer look at the passives on the outputs of the TCA0372 (between it and the outputs to the focus and radial motors). In particular, take a look at the two zener diodes on the radial drive output. It also might be worthwhile to check that the neither the focus or radial coils on the laser mechanism are shorted.

If worst comes to worst, I do have a complete one of this servo board.
Thanks Anton..... I will check out those items you identified tonight...... stuck going to work on my day off today...... This is my second laser assembly I added..... I could check for shorted coils and/or add the original one back in as well.

I remember reading somewhere on DIYAudio that a bad memory IC (adjacent to SAA7210) gives a similar outcome where the player will not function.

I will check this if it has any potential............

After burning out a 2nd TCA0372 & taking out the +5V & -6V PS once again... I discovered the 2nd laser focus motor was shorted.

I received some parts from Anton (AMC184) and replaced the laser with the original laser, fixed power supplies and added another TCA0372.

The music will play perfectly for a 1-2 minutes before the sounds becomes broken up & distorted and then finally the transport will stop spinning the disc.

So I am back to where I was for the original problem.

Any ideas why it will play perfectly for 1-2 minutes and then starts distorting and then stops playing.

I have changed the laser output transistor, checked all the diodes/resistors & capacitors on the servo board & resoldered all connections as well. All the electrolytic capacitors have been changed out on the Servo board & the PS board.

Anton has sent me a TDA5708 & TDA5709 as well so I was going to change these out as well if I have no other options.

Any help would be appreciated.

Thanks in advance.
Looking at the symptoms you describe, I think the problem is still likely to be the servo. Within those first couple of minutes, can the player skip to the last tracks of a CD?

Based on the timing of the fault, it certainly does sound like a heat related problem. Do you have any freezer spray? If so, you could try spraying the different ICs on the servo board. If not, you could try operating it 'till it fails, then seeing if any of the ICs seem unusually hot.

Failing that, try replacing both the TDA5708 and 5709.

You have been recalibrating the Laser Power and Focus Offset adjustments after making each major change, right?
Update: Continued problems with Revox Player

Here are the sysmptoms:

It will play perfectly for 1 minute to 10 minutes depending on the temperature of the unit (Ambient). It will begin to mistracked and music becomes garbled and eventually it will stop spinning the disc. Turn it off for a couple minutes and it will start-up and play for 1 minute since it is warmed up at this point.

For example it was sitting in my unheated work shed overnight and it got down to say 4 Celcius (40 F) and I turned it on and it worked for 10 minutes perfectly.

If its a 10-15 C mid-day and I will turn it on and it will work for 2 minutes or so.

If its 20 C or 68 F, the unit will play for only 1 minute.

So I believe it is temperature related.

I have replaced the following with no change:

I changed the following on the Servo board:

All transistors, TDA5708/5709 Decoder chips, 4560 & TCA372 Opamps; the 4.7K & 22K pots; the 2 7.5V Zeners and all electro. caps have been changed and all resistors have been checked.

On the Main Board (I had some spares):

The SAA7010/SAA7020 & Memory chip associated with the SAA7010, the 11.28XX Mhz crystal, all transistors associated with the PS and IC chips.

Next up is the CD turntable Drive output transistors & the laser assembly.

Any ideas would be helpful?

Let me know.

Thanks in advance.

The laser assembly seemed to do the trick...... :)

Only thing is that it plays all commercial CD's and plays some CD-R's.

It seems to play the most scratched CD-R but will not play almost perfect condition CD-R's.:confused:

It must be the way I recorded or the brand as the scratched CD-R is different brand from the other perfect condition CD-R's that won't play.

Any idea or experience with this situation???
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.