Moving the goal posts.

Just had the pleasure of an update to Visual Studio Community.
My programs stopped working.
Narrowed it down to a bad registry read.
I was getting back a null string instead of "c:\" which points to drive software was installed on.

After a lot of internet trawling I found that 32 bit and 64 bit programs read the registry differently.
So I adjusted my code accordingly and it started to work.

I then had problems publishing my code to an output directory.
On some of the modules I was getting publish errors.
Everything looked fine and had previously worked.
I had installed some new anti virus software since I last worked on these programs so out of desperation I turned it off and the programs now publish correctly.

Taken me a good few hours work to do what should have taken half an hour.
The last time I downloaded visual studio it said it needed 36GB of disc space !
It does allow selective downloading but I have many different types of projects from many years of work so I need most of the options.

I couldnt get visual studio to accept .net core 7 option after the latest download.
I installed x64 .net6 core 7 sdk but it didnt work.
Eventually I found out I needed x86 version as I had selected "any cpu" in my project.