Marantz CD75ii laser not moving and CD just spins

Hi guys, got this as faulty from online. Buyer stated disk just spins and does not read CDs I was hoping its just the blue cap under the laser but no joy!

When I put a cd in it just spins and laser does not go up or down and I cannot see a bean either.

I've checked most of the rails and on the chips and they all seem ok as far as I can see.

Any experts on these old players? Its 100% not the cd mechanish as I tried that in a working unit and it was fine.

Ive been using CD65DX service manual but the device is CD75 II

Any help appreciated.
 

Attachments

  • marantz_cd-65dx_service_en.pdf
    9.7 MB · Views: 118
OK heres exactly what happens and thanks for helping me!

When power is pressed,

cd spins and spins and spins
laser does not move and no red light
the front panel does not respond to eject.

On power off

the laser head moves sligtly
cd stop spinning.

I put the laser into different unit and it works perfectly and I tried front panel on philips machine and to my surprise it works and comes on perfectly!
 
with your vague description and my vague memory (last time i repaired a CD ... 15Y ago ? ) many problems are possible.
so first check/info:
  • power on - display normal ?
  • eject : tray open/close ok ? moves head to start (at innermost )position ?
  • if not ->
  • check power supply: 5V , +/- 10...or12 v ok ?
  • (power off) move head somewhat (maybe turning gears by hand); power on: moves head to start (at innermost )position ?
 
Last edited:
Apologies not being lazy just not sure what to check. OK what I've done.

Power on,

display all working buttons respond to display. It does nothing to the actual cd player. :(
when I press eject nothing. The cd just spins and spins. Even if power it on open draw it doesn't pull try in or when I press open/close.

Voltage seems ok. I only replaced 2 capacitors. The blue one that known to fail and another bipolar cap with a big film cap as I read online that could be the problem. But now from my test clearly something between the front panel and what ever controls the laser?
 

Attachments

  • ggh.jpg
    ggh.jpg
    1.1 MB · Views: 65
Lack of clock signal on this chipset causes the disc spinning uncontrollably issue - check you have 5v at saa7220 chip power pin (24). Best is use a scope to check you’ve got clock at the 7220, and that the signal is making it to the decoder chip (saa7210), and then also power supply (s? Cant remember) to 7210 decoder.

good luck!
 
Hi,
I am in holiday, in France, Provence now.
But to check your player, follow some standard procedures.
I would start this way:
No CD in tray. Then open tray, mechanical, by turning the motor/gear to move it.
Then power on.
Now tray should close, maybe need close button, laser going to start position, lens moving Up down 3 times, to find focus.
Check what your player doing and where problem begins.
Then find reason.
Maybe a switch not working, so player waiting for its closing. CLK already checked, ok.
If master controller not working, forget it.
Need replacing board. But this is very seldom, most times switch, cable contact, bad supply or defective drive transistors are the problems.
Check...
 
Maybe... but if the next switch it expecting not coming, it will wait forever...
So find out, what it's waiting for.
And.. first check is to move the tray by hand, without power, then power on, it must do something. To move it out or in until end switch tell him position, full in or out.
If it does nothing, drivers have no power or controller is not working.
Check.
 
If not the clock itself, then I’d start checking the motor control circuitry. Is the motor spinning stupidly fast or slow? And clockwise or anti-clockwise? In later models Ive had a faulty saa7310 cause a slow anti-clockwise spin (in yours it’s the saa7210), but very rare I’d say. What is the history of the player?
 
Hi there, The film cap you replaced looks like a very high voltage x2 type, it could be overkill in that location, in all the years I've been repairing Philips based cd players, I've yet to see a bad 1.5uf cap!
If it were mine, I would replace all the blue Philips axial capacitors, (some on the display pcb also) they will be toast!

flip the main pcb over and check everywhere for dry/cracked solder joints especially round the 3 pin voltage regs and IC's, I once had a cd65ii that was behaving exactly like yours, 10 pins on the mab ic were wide open the solder had cracked so bad!

Hope this helps, Ben

P.S. if your fitting radial type caps to the display, becareful they dont foul on the buttons when you reassemble.
 
Hi, Yes indeed you are correct! A few days/weeks ago I manged to get it working. Turns out the master chip/processor is the one in the middle MAB in my picture. Bad solder joint, only one! But was enough to make it not work. The blue Philips capacitors were also shot but that was not the issue!

Thanks for the help. When you get stuck like I do you just want to throw the damn thing out the window LOL

Took me weeks actually to fix it with luck, so I really hope someone else checks this post and fixes theres.