loading library file in protel 99

SSJB

Member
2016-12-16 4:04 pm
Protel 99 SE "File Not Recognized" Library Error Solution "Windows 7"

Dear Friends,

I want to share the link of the video file which demonstrates how you can resolve the problem of "File not recognized" in Protel while adding libraries.

I have tested it myself & got 100% result. Give it a try.

Description of Video File on Youtube:
Protel 99 SE "File Not Recognized" Library Error Solution "Windows 7"- Video Tutorial

Link of Youtube:
https://youtu.be/8xzlTb629JU

Regards
SSJB
 
So as a long time user and original owner of Protel99SE (service pack 6) and am now able to run it under Windows 10.

I patched the Client99SE.exe file as noted in this thread. I used a trial version of a Hex editor called "Hex Editor Neo" from HHD Software as it simply allowed me to search for the offset with Ctrl-G.

First put 0x2690E into the search box and click OK. Type 90 into the location you reach and the 9 following... that's 10 in total. Save the file.

Next open the search again and put 0x25f78 into the search box and click OK. Type 90 into the location you reach and the 9 following... that's 10 in total. Save the file.

Job done. Make a copy of the patch Client99SE.exe file for safe keeping.
 
Worked for me too

The patches worked for me too under W7 (ultimate 32)
There is one other thing not mentioned in this tread howerver: The help function doesnot work.
One must install KB917607 since HELP it isnot a part of the operatng system anymore.
But besides that macros must be enabled in the registry editor.
Create a new key in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft
named "WinHelp"
and under that create a new attribute DWORD named "AllowProgrammaticMacros" and assign the value of "1" to that.

I really needed the help function after many years of working with othe CAD software
 

joe6

Member
2019-07-17 6:48 am
Well, having now decoded bonybrown's program of post #23, I see that the data in the two edit locations for my Client99SE.exe file are the same as bonybrown's, and by inference, GuntherVB's.


So in all likelihood, theirs is the same (794,624 byte) file as mine, whereas AdmiralDecker's file is clearly different.


But alas, the two patches do not work for me. If I try to open or create any schematic documents, 99SE locks up while displaying the status message : "Starting Server - Schematic Sheet and Library Editor..."

Joe.