Leach Amp

Herman

Member
2001-05-25 6:10 pm
Europe
Hi all,
I build 2 Leach Amp boards (ver. 4.5). Both of them show HIGH offset voltages at the output (power transistors not attached). After several days of test and measurement, I eventually ran out of ideas. Any suggestions or hints for further checking are greatly appreciated.....

Herman
 
Hi all,
thanks for the replies so far.
According to the "manual", I connected a 100-ohm-resistor from each end of R36 to the output to close the feedback loop. Additionally, I shorted C12 (acc. to manual).
I'm using a lab bench supply with the current limit set to 200mA, and the current actually drawn is around 130mA. Funny enough, I removed Q12, but the 30VDC on the output terminal remained!!!
In my opinion, I have an idea about the end of the story but not how it starts: For some reason :-( , I have a high DC voltage on the output which turns on Q10. Now there is a DC path via Q12-Q10 (measured current through R23 around 22mA) to the output/feedback, opening Q2. This in turn drops the voltage across D13/D14 to some 24V...and thats the final stage.
BTW: I tried to deactivate Q16 temporarily (lifted the base pin), but that did not make any difference.

Repeated checking of all components, placements and orientations has not shown any errors yet, sigh.

Hope anyone out there already had the same effects and knows why it happened.....
Herman
 

grataku

Member
2000-12-31 9:31 am
-
Herman,
I took a look at the schematic to try to understand what the heck you are doing but there is just no way.
Depending upon how obsessed you are about getting the thing to work I can tell you that you'll probably figure it out within the next day or so.
I am stating the obvious here but there must be some kind of BIG SCREW UP or maybe some bad component to generate the kind of phenomenon you are describing. The fact that it happens on both boards makes me think you are making some kind of systematic mistake, something obvious that you think you are doing right but that instead is completely wrong.
Sorry I couldn't be of much help (I think no one could). At this stage of the game I would remove all power and start with a fresh frame of mind.

[Edited by grataku on 05-26-2001 at 10:13 AM]
 
Herman

It's difficult to fault find at a distance, but I've done it before successfully so let's give it a try. I'm not completely familiar with the Leach amp but it is basically similar to a number of others I have worked on.

You don't mention your supply rail voltage, but I assume it is a little higher than the dc offset you are measuring when you have the 100ohm test resistors in place of the output transistors.

The most likely cause of dc at the output is the failure to a short of Q16 (+ve offset) or Q17 (-ve offset). This would explain why lifting the base pin of Q16 made no difference. Check the voltage at the emitter of Q16 and if it equals the supply rail voltage the transistor has failed to a short. The dc offset at the output will be less than the supply rail due to the volt drop across the 100ohm test resistor.

If Q16 proves to be OK, there are some other checks that can be made to determine the cause of the problem, but I suggest you email me to discuss this further rather than taking up space on the forum.

Geoff
 
ATTENTION

To all who exchange the original transistors with the common equivalents (like BC550 / BC560):

The original transistors (MPS8099 or so) and the european equivalents (like BC5xx) have their collector and emitter pins interchanged !!!

So sticking to the component placement sketch put me right into a lot of trouble :(. I publish this here to keep others away from this "trap"

Herman
 

Herman

Member
2001-05-25 6:10 pm
Europe
New Trouble

I recently blew my Leach amp due to a silly mistake: I used too weak transistors for the safety circuit (Q10, Q11 were BC550 and BC560 resp.). They must have been blown early, but nobody realized that. When I accidently applied DC to the input, the whole power stage went up :-(
I replaced those transistors now with 2N5551(npn, Q7 and Q10) and 2N5401(Q11). But now other trouble arrived:

I can't set the bias current!

All the checks proposed by Leach went ok until I tried to set the bias current. With the pot at max resistance, I find approx. 10mA. When I turn the pot, NOTHING changes.
I measured approx. 0V at Q7(C) and -2.2V at Q7(E). The biasing diodes are ok -at least, when I trust my multimeter which shows a voltage drop of approx. 500mV per diode.

I have no more idea what to check. Any help is gretly appreciated. Thanks in advance!
Greetings
Herman