Infinity HTS20 subwoofer humming noise with RCA inputs connected

Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.
Hi guys,

I am new to this forum. I searched the forum but did not find an exact answer to this problem hence any help would be appreciated.

I have an Infinity HTS-20 powered subwoofer and I hear loud humming sound when I connect the RCA inputs to the subwoofer The humming sound continues to increase as I turn the volume up on the subwoofer. If I disconnect the input RCA cables at the subwoofer end then there is no hum even if I increase the subwoofer volume control to the maximum.

I took it to a repair shop and he indicated that it is an open circuit/ground issues and asked for $100 to fix it but I didn't want to spend that much. Any help would be apppreciated.
 
GM, thanks but I checked the link you sent and found only amplifier related problems listed there. I am certain that the problem is with my subwoofer and the authorized service center also confirmed that the problem is with the subwoofer electronics. I should have stated ealier but forgot to mention that even when I disconnect the cable from my receiver but have the other end connected to the subwoofer the hum continues. The hum starts the moment I connect the input cables to the subwoofer (irrespective of whether the other end is connected to my receiver or not) and the humming stops when I remove the input jacks from the subwoofer. After removing the RCA input cables from the subwoofer there is no hum even if I increase the subwoofer volume contol to maximum.

It could be some faulty electrolytic condenser or some diode or something I am not aware of but just wanted the expert opinion of some of the gurus on this forum before I start doing anything. Any suggestions would be appreciated.
 
There is a service bulletin on this fault;
NUMBER ............. PRODUCT(S) ............. SUBJECT .................... DATE
INFTT2003-01 .......... HTS-20...........NO OUTPUT OR HUM ....... 03/03/03
Don't know if this is related to your fault
INF2000-01 Rev2 .... HTS-10, 20.........FAILURE OF C6 .................. 02/01

Can't find a copy of either on-line, maybe you can get the bulletins from Harmon/Infinity?

Hope this helps
Regards
James
 
Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.