Help troubleshooting AMP (DC protection)

Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.
Hi,

I have a Marantz 8 channel amp and it works fine for a few minutes (up to 15), then shuts down. Once it starts to shut down, it rarely stays up, just goes into an error state.
I bought the service manual and have narrowed down to the DC protection circuit.

I think the KRA107M transistor is bad. With the DC_AMP connections removed, the base voltage seems to drop over time. When it reaches 12.x volts, the voltage driving the NPN KRC102M goes above 1.5 and it turns on, shutting down the amp.

Can someone help me bias a BC557 ? The KRA107M has internal 47K / 10K bias


kra107m by AustinIsWeird, on Flickr

http://www.datasheetcatalog.org/datasheet/kec/KRA107_9M.pdf

An externally hosted image should be here but it was not working when we last tested it.



dc-2 by AustinIsWeird, on Flickr

An externally hosted image should be here but it was not working when we last tested it.



prot1 by AustinIsWeird, on Flickr




When working, the voltage at DC AMP1/2 is around 12.7V, when it fails, this value drops to 11.7V to 12.2V

I am not sure the amp is really failing due to DC offset. Perhaps, the circuit is temperature dependent and not biased correctly.

Can anyone help me understand how it works and why it may be shutting down...

Thanks in advance
 
Last edited:
Just ended up buying a replacement for the KRA107M from a distributor in the UK.

In the meantime, by removing the transistor, I do not get shutdowns. Still have current and over temperature protection, just no DC protection. Measured no DC offset at all during any levels of playback on all channels. Taking the chance that the amp will not destroy itself while I'm waiting for the new part....
 
Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.