Amplifier Does Not power up

I have a Sony STR DH-500 Receiver, it is +/- 4 to 5 years old. I have a problem with the power button. When I switch it on it does not power up, unless I firstly unplug the power cable from the multi plug adapter then re-plug it back. Then only does the receiver power up.

Also another issue which started a few months ago is that a few buttons on the remote control seem to be unresponsive (which I have tested).

Please help me out guys, I do not want to purchase another receiver, if this can be resolved myself then I would greatly appreciate that.
 

Sorento

Member
2008-03-12 9:59 pm
if you power it up with the cable trick, does it work normally ?
can you turn it off with the power button or does it stay on ?

remote controls are often clogged by dirt which gets trapped between button made of conductive rubber and circuit board; the only way I know to fix that is to open the case - usually two shells snapped together - and clean button rubber and contact metal with piece of cloth and a drop of alcohol ...
 
Hi payloadde, please forgive me but I am assuming that cable trick is the power button on the receiver? I haven't actually opened up the receiver itself. When I do power up the receiver via the power button on the receiver itself, it does power up and when I turn it off then same way, it does go off. But if I have to power it up again right afterwards or even later in the day it does not power up at all. I have to go through the entire routine of unplugging the power cable from the socket - replugging it back in - then only will it power up. It is a frustrating because the power sockets are tucked away in the back and very hard to reach.

As for the remote, I did open it up a few weeks ago and I did wipe clean the circuit board and conductive rubber contacts with a cloth and metholate spirit. Thought that would work but the few buttons still do not work as previously.

Any other suggestions please.
 
if you power it up with the cable trick, does it work normally ?
can you turn it off with the power button or does it stay on ?

remote controls are often clogged by dirt which gets trapped between button made of conductive rubber and circuit board; the only way I know to fix that is to open the case - usually two shells snapped together - and clean button rubber and contact metal with piece of cloth and a drop of alcohol ...

Hi payloadde, please forgive me but I am assuming that cable trick is the power button on the receiver? I haven't actually opened up the receiver itself. When I do power up the receiver via the power button on the receiver itself, it does power up and when I turn it off then same way, it does go off. But if I have to power it up again right afterwards or even later in the day it does not power up at all. I have to go through the entire routine of unplugging the power cable from the socket - replugging it back in - then only will it power up. It is a frustrating because the power sockets are tucked away in the back and very hard to reach.

As for the remote, I did open it up a few weeks ago and I did wipe clean the circuit board and conductive rubber contacts with a cloth and metholate spirit. Thought that would work but the few buttons still do not work as previously.

Any other suggestions please.