Low-distortion Audio-range Oscillator - Page 206 - diyAudio
Go Back   Home > Forums > Design & Build > Equipment & Tools

Equipment & Tools From test equipment to hand tools

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd April 2013, 06:04 AM   #2051
AKN is offline AKN  Sweden
No snake oil
diyAudio Member
 
AKN's Avatar
 
Join Date: Aug 2005
Location: In the middle of Sweden
Send a message via MSN to AKN
Hi,

Chris719, thanks for linking to that latency tool.

My result from an old XP with Core2 Duo 3GHz while running ARTA and browsing diyA. Quite good I think.
Attached Images
File Type: jpg latency.JPG (41.5 KB, 195 views)
__________________
/ Anders
  Reply With Quote
Old 2nd April 2013, 06:09 AM   #2052
davada is offline davada  Canada
diyAudio Member
 
Join Date: Jul 2004
Location: Fort St John, BC Canada
Quote:
Originally Posted by chris719 View Post
Try that other utility I linked, it will let you know the service or driver causing the issue most likely.

If you have a Core i5/i7 machine you should be able to get below 100 uS consistently. Mine hovers around 33 uS but will go up to the 50 uS area if I move my mouse very fast, and that utility correctly identifies the usb driver as the source.
latency Monitor won't run in XP. It says "The process entry point GetProcessIdOfThread could not be located in the dynamic link library KERNAL32.dll"
__________________
David.
  Reply With Quote
Old 2nd April 2013, 06:34 AM   #2053
1audio is offline 1audio  United States
diyAudio Member
 
Join Date: Mar 2004
Location: SF Bay Area
Blog Entries: 3
On my i5 laptop using the neat utility I discovered that I need to do two things. First disable Microsoft Security Essentials real time protection, second switch the CPU to max performance. I created a power profile specifically for that. Now, when I'm making a test I will switch off the security and switch the power to max on this system. I'll test this for a while.
__________________
Demian Martin
Product Design Services
  Reply With Quote
Old 2nd April 2013, 07:05 AM   #2054
davada is offline davada  Canada
diyAudio Member
 
Join Date: Jul 2004
Location: Fort St John, BC Canada
Now I'm getting a continuous 146xx latency.

DPC says some device driver is acting very badly. No kidding! That's putting mildly.
__________________
David.
  Reply With Quote
Old 2nd April 2013, 07:08 AM   #2055
diyAudio Member
 
Join Date: Jun 2004
Location: Connecticut
I know people like XP and all that, but I would definitely get rid of it if you can. I can get <= 1 ms audio latency from Windows 8 even.
  Reply With Quote
Old 2nd April 2013, 07:32 AM   #2056
AKN is offline AKN  Sweden
No snake oil
diyAudio Member
 
AKN's Avatar
 
Join Date: Aug 2005
Location: In the middle of Sweden
Send a message via MSN to AKN
Quote:
Originally Posted by chris719 View Post
I know people like XP and all that, but I would definitely get rid of it if you can. I can get <= 1 ms audio latency from Windows 8 even.
1ms, typo?
__________________
/ Anders
  Reply With Quote
Old 2nd April 2013, 09:37 AM   #2057
AKN is offline AKN  Sweden
No snake oil
diyAudio Member
 
AKN's Avatar
 
Join Date: Aug 2005
Location: In the middle of Sweden
Send a message via MSN to AKN
(out of edit time)

chris719, I get the <1ms time now after testing on a W8 PC. The application seem to have a detection problem on W8.
I also tested on my fully loaded W7 office PC (>10 IE sessions, ongoing Virus Scan and >10 remote desktop sessions) and never passed 45uS.
__________________
/ Anders
  Reply With Quote
Old 2nd April 2013, 03:47 PM   #2058
diyAudio Member
 
Join Date: Jun 2004
Location: Connecticut
Oh, I meant monitoring through mu EMU 1820m ASIO, not DPC latency. The Thesycon utility is broken and will not show less than 1 ms on Windows 8. The other utility works, I see between 12-38 us with that tool.
  Reply With Quote
Old 2nd April 2013, 04:00 PM   #2059
RNMarsh is offline RNMarsh  United States
diyAudio Member
 
RNMarsh's Avatar
 
Join Date: May 2012
Location: 2457 Cascade Trail; Cool, CA. 95614
And, if we cant get something that works on everyones ADC/PC/Win versions? Then what? Plan B?
  Reply With Quote
Old 2nd April 2013, 06:06 PM   #2060
davada is offline davada  Canada
diyAudio Member
 
Join Date: Jul 2004
Location: Fort St John, BC Canada
Quote:
Originally Posted by RNMarsh View Post
And, if we cant get something that works on everyones ADC/PC/Win versions? Then what? Plan B?
Mess with it until it does.

Switch to Linux.
__________________
David.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radford Low Distortion Oscillator Series 2 audiomik Equipment & Tools 21 19th February 2014 10:46 AM
ultra-low distortion audio oscillator geekysuavo Analog Line Level 16 26th March 2013 03:04 PM
Low distortion oscillator? rjm Equipment & Tools 30 4th May 2011 10:45 PM
Can we improve this low distortion sine oscillator ? gaetan8888 Solid State 22 29th March 2009 12:30 PM
Simple, low distortion 1kHz oscillator jackinnj Solid State 4 6th October 2003 03:58 AM


New To Site? Need Help?

All times are GMT. The time now is 05:10 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2