XMOS-based Asynchronous USB to I2S interface - Page 144 - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th November 2012, 05:24 PM   #1431
diyAudio Member
 
Join Date: Nov 2007
Hello CKL,
please be more specific about garbage sound: is some sort of white noise that has nothing to do with music played or the quality of sound is dropping?
FYI, WaveIO share common ground with PC/MAC source and this could lead to issues if you have ground loops in your audio setup or there's no connection to earth. It would be nice to know who things will change if your UBS host is powered from batteries (is isolated from mains) - if possible.
As for "waiting for a while" expression: could this be directly related to time needed for some caps to be discharged? How long do you have to wait?
I'll wait for your answer,
L
__________________
Contact link for WaveIO USB-to-I2S/SPDIF board.
Daughter card GB list for WaveIO can be found here
  Reply With Quote
Old 10th November 2012, 07:15 PM   #1432
Magsy is offline Magsy  United Kingdom
diyAudio Member
 
Join Date: Jan 2005
Location: Wales
Mine arrived yesterday, it is a very nice high quality bit of kit and a clean well soldered board which you don't always get! Thanks

Works great but sure uses a lot of current, my target reg's fail to supply enough so I'm using a fiddled with LM317 for now.

Installed fine on Windows 8, drivers are good, there have been no bad noises and it seamlessly changes sample rate via ASIO. I set to 'minimal latency' with no dropouts.

Hooked up via SPDIF and I2S without issue, I don't much like Buffalo 2 but it is sounding pretty nice via I2S now..

I can't make it work with iPad 2/IOS 6 though, it reports "device requested too much power". I thought the descriptor had been updated for it to request less power? Am I doing something wrong?
  Reply With Quote
Old 11th November 2012, 07:08 AM   #1433
diyAudio Member
 
carsten.witt's Avatar
 
Join Date: Jan 2006
Location: Berlin
@Lorien,

some news about the "daughter"?


Carsten
  Reply With Quote
Old 11th November 2012, 09:01 AM   #1434
diyAudio Member
 
triode_al's Avatar
 
Join Date: May 2004
Location: Westland
Blog Entries: 1
Quote:
Originally Posted by Lorien View Post
[]
3. If you don't have any WaveIO main board around but you want one then there are two choices for you, as far as I can see now:
a) Sign in into this GB and wait for the WaveIO + daughter bundle to be available and buy all of them at once (you have to wait for some time though!) or

I don't want to send my WaveIO in for service later :
Daughter board will be integrated into WaveIO boards already sold by sending WaveIO cards back to me, I'll make the necessary hardware + software changes and I'll ship it back to destination.
-- it helps,
L
I signed in the list and opted for the bundle. Hope I don't confuse everybody with this addition!
albert
__________________
DAC TDA1541 S1; Kondo post-I/V filter; MC30-Super --> two stage RIAA; Pre: Kaneda ; F5 ; 300B PP ; ESL 57
  Reply With Quote
Old 13th November 2012, 08:14 AM   #1435
CKL is offline CKL  Hong Kong
diyAudio Member
 
Join Date: Nov 2006
Hi Lorien,

The clicking noise starts to happen after 2-3 minutes. Firstly, there is some clicking noise at the background and later on 100% sound is clicking noise. I tried to replace the 9V regulated power supply with 9V battery but no cure. To recover, I have to unplug the power for a while.
  Reply With Quote
Old 13th November 2012, 08:43 AM   #1436
diyAudio Member
 
Join Date: Nov 2007
Hello CKL,
where do you use your 9V from batteries as WaveIO does accept only 5Vdc on external or USB power rails .. I'm just curious! BTW, there's a lot of dissipated heat on your WaveIO card? In addition, few pictures of your setup could help. For that please use ekits at luckit . biz email to keep this thread clean.

@albert: there's no problem about your demand as there are others that want that bundle too.

@ carsten: still working on it.
@ Magsy: You're not doing anything wrong, the fault is entirely mine! FYI, actual PCB does not have any HW parts to safely detect when the WaveIO is externally powered thus, for compatibility reasons, I preserved the "default" descriptors in WaveIO's stock firmware. But you can change this by using the DFU feature. I'll come back and let you know how to do this. The downside is that once the firmware is changed with new descriptors your WaveIO will always report as self-powered device unless you will revert it back to "factory defaults".
Thank you,
L
__________________
Contact link for WaveIO USB-to-I2S/SPDIF board.
Daughter card GB list for WaveIO can be found here
  Reply With Quote
Old 13th November 2012, 09:06 AM   #1437
Magsy is offline Magsy  United Kingdom
diyAudio Member
 
Join Date: Jan 2005
Location: Wales
I did wonder how I would switch between the two modes but I will probably always have external power so I'm happy to flash it when you have firmware ready

Thanks
  Reply With Quote
Old 14th November 2012, 09:48 AM   #1438
diyAudio Member
 
Join Date: Nov 2007
For some technical reason I'm forced to post the DFU infos here instead of WaveIO's web page but I guess it's not a problem.
To Magsy and anyone else willing to make WaveIO to report on USB enumeration as Self-Powered Device, avoiding the "device requested too much power" from iPad (or any other portable device) below are some simple tricks to make this work (Windows users):
1. Make sure that your WaveIO firmware has the DFU feature implemented (RevisionID 0x0331 or higher). There are several ways to do this and I'll list them below. First thing to do is to download latest drivers from WaveIO | Luckit @ Support tab (v1.56.0) and install the drivers (if are not installed already).
a)
* Check in the installation directory (:C/Program Files/Luckit/USBAudio_Driver/) if "dfucons.exe" file is there (it should be).
* plug-in your WaveIO card into one of USB ports available and make sure it's detected.
* Open the console (Start => Run => cmd) and navigate to "USBAudio_Driver" directory (see the path above).
* Run the following command in the DFU console: dfucons info
@ REV field you should see 0x0331 (or higher).
b)
* A more simpler way to see your device's revision ID is to run "TUSBAudio Control Panel" located in the driver's directory or in Start => Luckit => USB 2.0 High Definition Audio Driver => TUSBAudio Control Panel. If your WaveIO is detected, click on "Device 0" option on the left window and you should see on the right the RevisionID value.
2. There are also two ways to make the upload but I recommend only one: using the DFU console (dfucons.exe).
* Download the .bin file from WaveIO | Luckit @ Support section (named "WaveIO_v2.31.bin") in the WaveIO driver's installation directory (:C/Program Files/Luckit/USBAudio_Driver/).
* Open the console (Start => Run => cmd) and navigate to "USBAudio_Driver" directory - if you're not there yet (see the path above).
* Run the following command: dfucons download WaveIO_v2.31.bin
* Wait for firmware to upload and when finish run again: dfucons info
* You should see now @ REV field the RevisionID 0x0332 (the one with Self powered decriptors)
* Done!
3. For reverting your WaveIO firmware to "early stages" you should plug in the card, open the console and navigate to dfucons.exe file and run the following command: dfucons revertfactory
A simple check with dfucons info command will show you 0x0331 or the one you had before.
4. That's it!

Note:
* for MAC OS users, there's an XMOS doc attached to this message. There was a link somewhere to it, not long ago, but they have changed their site and now looks different. The instructions are quite similar, read them well and change the values appropriately (please see chapter 4 "Using the DFU loader–OSX" at page 4)!
* Once uploaded, the new firmware will always declare your WaveIO card as "self powered one" unless you will revert it to defaults.

Happy uploading,
L
Attached Files
File Type: pdf DFU-loader-for-XMOS-USB-Audio-devices(1.1).pdf (331.3 KB, 198 views)
__________________
Contact link for WaveIO USB-to-I2S/SPDIF board.
Daughter card GB list for WaveIO can be found here

Last edited by Lorien; 14th November 2012 at 09:50 AM.
  Reply With Quote
Old 14th November 2012, 08:15 PM   #1439
Magsy is offline Magsy  United Kingdom
diyAudio Member
 
Join Date: Jan 2005
Location: Wales
Yeeeha!

Working on iPad 2,4 and Mini without any issue, plug it in and it sounds beautiful. Still works on the PC fine too

Only one thing, I don't have dfucons and it is not in either driver on the website, so currently I cannot factory default. Can you please zip that and put it on the website?

Thank you very much!
  Reply With Quote
Old 14th November 2012, 10:17 PM   #1440
wlowes is offline wlowes  Canada
diyAudio Member
 
wlowes's Avatar
 
Join Date: Mar 2007
Location: Toronto
Blog Entries: 9
Default Is there any sonic benefit to upgrading firmware?

Basically if it is working reliably as shipped, is there any reason to bother with the new firmware?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
exaU2I - Multi-Channel Asynchronous USB to I2S Interface exa065 exaDevices 1357 3rd March 2014 09:51 PM
Introducing miniStreamer: Native 24/96 USB to I2S / SPDIF interface minidsp miniDSP 39 6th January 2014 12:00 AM
Ultimate USB to I2S interface sampler Digital Source 206 30th January 2012 04:45 PM
Is it possible to develop a ASIO driver for PCM2900 based USB Audio interface? cxhawk Digital Source 7 3rd December 2010 03:30 PM
interface I2S with USB mermoz Digital Source 0 21st February 2003 11:34 AM


New To Site? Need Help?

All times are GMT. The time now is 09:26 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2