Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

Low volume on all outputs/inputs (NuForce MCP-18)
Low volume on all outputs/inputs (NuForce MCP-18)
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th October 2018, 04:05 PM   #1
studio19atx is offline studio19atx
diyAudio Member
 
Join Date: Nov 2016
Default Low volume on all outputs/inputs (NuForce MCP-18)

Hello,
I have a NuForce MCP-18. I noticed that the volume on all inputs and outputs have gone low. Almost feel like there is no gain whatsoever. At the highest volume, I can barely hear some sound. Could the problem be with the power supply? Can someone shed some light?
Thanks
  Reply With Quote
Old 23rd October 2018, 12:57 PM   #2
studio19atx is offline studio19atx
diyAudio Member
 
Join Date: Nov 2016
Any insights? Anyone?
  Reply With Quote
Old 27th October 2018, 08:50 AM   #3
mbz is offline mbz  Australia
diyAudio Member
 
Join Date: Jul 2013
Since all inputs and both channels affected, yes, it could be a power supply issue, one or
both rails down. Outside chance it's a failed component (opamp). Difficult to troubleshoot
without a service manual, depends also on your skills and tools available.
  Reply With Quote
Old 30th October 2018, 02:15 PM   #4
studio19atx is offline studio19atx
diyAudio Member
 
Join Date: Nov 2016
Quote:
Originally Posted by mbz View Post
Since all inputs and both channels affected, yes, it could be a power supply issue, one or
both rails down. Outside chance it's a failed component (opamp). Difficult to troubleshoot
without a service manual, depends also on your skills and tools available.
Thank you for the reply. I have another unit and swapped out the power supply board. The unit worked perfectly. You are right, the power supply has issues. I will try and troubleshoot. The part of EOL, so replacements are not available.
  Reply to this post

Reply


Low volume on all outputs/inputs (NuForce MCP-18)Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ESD protection on audio inputs and outputs, yes or no? JayShoe Digital Line Level 5 14th July 2018 10:35 PM
Switching SE and balanced inputs/outputs andyjevans Tubes / Valves 0 4th September 2012 09:50 PM
Help with Clarion deck inputs/outputs cm961 Car Audio 3 13th August 2010 08:28 PM
Changing inputs and outputs on DH-200 jakelm3075 Solid State 4 30th March 2006 10:28 PM
Why are XLR outputs male, and inputs female? Bricolo Parts 5 30th August 2004 01:43 AM


New To Site? Need Help?

All times are GMT. The time now is 08:29 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio
Wiki