diyAudio

diyAudio (https://www.diyaudio.com/forums/index.php)
-   Digital Source (https://www.diyaudio.com/forums/digital-source/)
-   -   Marantz CD63 KI SIG, Error 12, Sled Error problem (https://www.diyaudio.com/forums/digital-source/132833-marantz-cd63-ki-sig-error-12-sled-error.html)

sisik 9th November 2008 02:43 PM

Marantz CD63 KI SIG, Error 12, Sled Error problem
 
Hello everyone, I am new to this site and wonder if anyone can help with my Marantz CD problem? My CD player went wrong initially about 2 years ago when it started skipping every now and again, cleaning did not help. Since then I have installed 2 new optical drives a Philips VAM 1202/12. They both worked for about 6 months each before the problem started again, and then would not register CD's at all!. So again I installed another new Philips optical drive to no avail! Following the diagnostic instructions it comes up with Error 12 sled error. I tried putting the whole transport unit into my other basic CD 63 and it works perfectly! What could be wrong with the KI player? is it something on the PCB? How can I check? I have thought about replacing the PCB on the KI player with the basic CD 63 players PCB? Any thoughts, they both look the same essentially. I find the KI player a much more enjoyable listen.

poynton 9th November 2008 03:12 PM

Where are you getting the replacement mechanisms from?

Many (most) of the "chinese" ones on the market either are faulty out of the box or fail like you describe !

Andy


All times are GMT. The time now is 01:25 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 17.65%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio

Wiki