Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

NAD C542 continuous issues
NAD C542 continuous issues
NAD C542 continuous issues Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th February 2020, 08:42 PM   #1
czolgista778 is offline czolgista778  Netherlands
diyAudio Member
 
Join Date: Nov 2010
Default NAD C542 continuous issues

Hi Guys,
My 2 NAD C542's are driving me nuts, they both have 'similar' problem but I've no clue how to tackle it...recapped, whole drive mechanisms replaced, voltages measured - nothing helps. I'm wondering if they're suffering from a known failure?

Unit 1:
- Complete laser assembly replaced
- Power supply fully recapped except for the 12V one as this one has decent (Fine Gold) caps, measured the voltages - good
- Voltages measured - all OK
- Relays bypassed (just for testing purposes)

Problem:
- Sometimes it doesn't fully turn on, the green LED turns on and that's it. The other time it turns on, reads the TOC, then the 1st track but it's skipping through tracks, trying to change track or go from the first to last track sometimes it goes nuts and eventually shows -- ---- on the display.
- If it reads the TOC and you let it play untouched from 1st to last track, it will play the whole CD with no issues



Unit 2:
- Complete laser assembly replaced, still the same issue
- Power supply fully recapped except for the 12V one as this one has decent (Fine Gold) caps, measured the voltages - good
- Voltages measured - all OK
- Relays bypassed (just for testing purposes)

Problem:
- Turns on fine, CD spins but no sound from the laser and no TOC readout
- Every few seconds there is a short click from the relay, the voltage drops and comes back again, this can also be seen looking at the CD speed, it goes up and down every few seconds
- Very rarely it reads the TOC after a minute and plays but touching any button makes it lose it's mind

Last edited by czolgista778; 6th February 2020 at 08:47 PM.
  Reply With Quote

Reply


NAD C542 continuous issuesHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: NAD C542 Very Good Condition maartentje Swap Meet 0 7th March 2012 04:44 PM
NAD C542 Repair -- Help! robber222 Digital Source 0 24th October 2010 10:14 PM
Transport for NAD C542 Hifisound Digital Source 2 27th September 2010 05:03 PM
Nad C542 Upgrade/mod FSHZ42 Digital Source 0 11th March 2008 10:23 AM
Nad C521 & C542 arupg Digital Source 0 22nd December 2005 06:24 AM


New To Site? Need Help?

All times are GMT. The time now is 12:02 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio
Wiki