Go Back   Home > Forums > >

Digital Line Level DACs, Digital Crossovers, Equalizers, etc.

DIY DAC made with dam1021 making noise when rpi4 is turned on
DIY DAC made with dam1021 making noise when rpi4 is turned on
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools
Old 18th November 2020, 05:05 PM   #1
daniel4381 is offline daniel4381
diyAudio Member
 
Join Date: Jul 2014
Default DIY DAC made with dam1021 making noise when rpi4 is turned on

I have made a DAC with Soekris dam 1021 which is also connected with rpi4 via i2s interface. I am using a digital switch to switch between rpi and amanero combo384. All the connecting cables with rpi4, switch, amanero combo384 and dam 1021 are shielded signal cables. The rpi4 is powered by ups and ups is powered by smps 3 amp mobile charger. Previously I used rpi 3b + and that time there was no noise even at the full volume. But recently I changed to rpi4 and I am getting noise even at low volume. The noise goes off when rpi4 is powered off. My amp and preamp is parasound halo 21 and p6 and it is perfectly alright as it playes other sources quietly. Need yor kind help and suggestion.
Attached Images
File Type: jpg 20201118_222322.jpg (1.04 MB, 71 views)
File Type: jpg 20201118_222327.jpg (1.03 MB, 71 views)
File Type: jpg 20201118_222342.jpg (1.01 MB, 64 views)
  Reply With Quote
Old 18th November 2020, 06:16 PM   #2
Markw4 is online now Markw4  United States
diyAudio Member
 
Join Date: Jul 2016
Location: California
RPi4 produces more RF noise than RPi3 did. That the price you pay for more speed. It means you may need to take more steps to control conducted and or radiated EMI/RFI between RPi4 and the DAC. Some experimentation might be helpful. For example, increasing physical separation between the boards may give a clue.
  Reply With Quote
Old 21st November 2020, 10:26 AM   #3
daniel4381 is offline daniel4381
diyAudio Member
 
Join Date: Jul 2014
Thanks for your suggestion, separated the RPi and shielded it, the noise has gone.
  Reply to this post

Reply


DIY DAC made with dam1021 making noise when rpi4 is turned onHide this!Advertise here!
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux USB-Audio Gadget (RPi4 OTG) phofman PC Based 21 13th November 2020 07:34 AM
RPi4 and Khadas Toneboard soundcheck Digital Line Level 7 11th May 2020 08:13 PM
PAM8403 Buzzing/Whine noise Rpi4 + USB Sound Card bangity Class D 0 16th February 2020 06:24 PM
JL Slash Amp 500/1 makes Popping Sound when Turned on and low rumble when turned Off richyim Car Audio 20 10th January 2020 05:09 PM
RPi4 + IANCANADA ES9038Q2M double-mono DAC + IANCANADA FiFoPi Ultimate questions Vortex Digital Line Level 49 19th November 2019 02:17 AM


New To Site? Need Help?

All times are GMT. The time now is 02:59 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright ©1999-2021 diyAudio
Wiki