Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Fire Audio 2200D
Fire Audio 2200D
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th February 2019, 05:27 AM   #1
chrisg4 is offline chrisg4  South Africa
diyAudio Member
 
Join Date: May 2016
Location: South Africa, KZN
Default Fire Audio 2200D

Hi Perry,

I got this amp with a very blown power supply and one side on outputs (IRF1310N) shorted.
I removed all the fets, checked the psu drives/gate resistors, then installed new irf3205's. I installed a new HIP4080, I'm only getting drive waves on Q5,6,7 and Q20,21,22. there are no output fets in the board

Pics:

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.

Last edited by chrisg4; 11th February 2019 at 05:34 AM.
  Reply With Quote
Old 11th February 2019, 05:58 AM   #2
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Find the outputs that have their source leg connected to ground (probably the ones with signal). There will be 3 on each side. For one of those on each side, bridge the drains and source legs. Does that allow you to see the signal on the high side?
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote
Old 11th February 2019, 07:45 AM   #3
chrisg4 is offline chrisg4  South Africa
diyAudio Member
 
Join Date: May 2016
Location: South Africa, KZN
i dont have any outputs in the board, can i test without
  Reply With Quote
Old 11th February 2019, 07:47 AM   #4
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Yes
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote
Old 11th February 2019, 08:31 AM   #5
chrisg4 is offline chrisg4  South Africa
diyAudio Member
 
Join Date: May 2016
Location: South Africa, KZN
no signal on any bank, the resistor close to the HIP4080 smokes up
  Reply With Quote
Old 11th February 2019, 08:34 AM   #6
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post a close-up photo and indicate which resistor.

Are there any solder bridges other than the ones you made to test the drive?
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote
Old 11th February 2019, 08:40 AM   #7
chrisg4 is offline chrisg4  South Africa
diyAudio Member
 
Join Date: May 2016
Location: South Africa, KZN
none that i can see

Click the image to open in full size.
  Reply With Quote
Old 11th February 2019, 08:52 AM   #8
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Are you sure that the solder bridges are on the right transistors?
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote
Old 11th February 2019, 09:53 AM   #9
chrisg4 is offline chrisg4  South Africa
diyAudio Member
 
Join Date: May 2016
Location: South Africa, KZN
on these marked in red, signal was here before creating the solder bridge

Click the image to open in full size.
  Reply With Quote
Old 11th February 2019, 02:04 PM   #10
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
1. Did those have leg 3 grounded?

2. Did you bridge legs 2 and 3 on one in each of those groups?

3. Are both of the large 1 ohm resistors heating the same?

4. Was this 4080 ever in the circuit with a damaged output?
__________________
Anyone who purchased the repair tutorial, email me (babin_perry@yahoo.com) if you want to download the latest version.
  Reply With Quote

Reply


Fire Audio 2200DHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundstream DTR1.2200D Formas Car Audio 7 27th May 2018 07:08 PM
Help Fire - Need New Sub Amp ODougbo Solid State 6 23rd December 2012 08:36 PM
FS: Audio Transformer Fire Sale dsavitsk Swap Meet 3 10th June 2010 06:17 PM
Which way to fire my sub? Gorbee Subwoofers 24 12th September 2006 12:59 AM
Amp on Fire! peter5 Solid State 6 7th January 2002 11:35 AM


New To Site? Need Help?

All times are GMT. The time now is 04:57 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki