• WARNING: Tube/Valve amplifiers use potentially LETHAL HIGH VOLTAGES.
    Building, troubleshooting and testing of these amplifiers should only be
    performed by someone who is thoroughly familiar with
    the safety precautions around high voltages.

Troubleshooting magnavox 9302-00

poolorpond

Member
2005-08-01 7:12 pm
Eight years ago, I shelved this amp (new wife, kid, house, etc). I had switched the power on and off a number of times for some reason and the rectifier tube went. One of the output transformers heated up to the point where the sound was distorting and it was dripping wax.

Jump to today- With a NOS sylvania 5u4gb rectifier, and the output transformers disconnected, no tubes in the sockets, the B+ is putting out 428 volts dc @ a stable .37 amps with 120vac feeding the primaries (brought up to power with a variac). There are 623vac across the secondaries before the regulator. The power supply caps tested accurate capacitance and no short on my DMM. There is a choke, too. Stock configuration- just like the schematic.

Even with no load, 428 vac seems high to me. I would only expect about 50v sag with that rectifier. Any thoughts on that .37 amps? Anyone have any experience with this amp/tranny?

Need some suggestions about what to test next. Should I reconnect the tubes and bring up the voltage, with the output transformers still disconnected (ready to hit the kill switch)?
 

Attachments

  • Magnavox_93xx console amp series.jpg
    Magnavox_93xx console amp series.jpg
    646.8 KB · Views: 99

poolorpond

Member
2005-08-01 7:12 pm
I never tested the power supply voltage. I have no idea what it might have been before my little accident. I have seen schematics of amps using el84 PP output stages with a B of 350v, which is well above the recommended plate voltage. I'm really not into over-driving a tube like that.
 

azazello

Member
2008-08-23 7:28 pm
USA
Disconnect all secondaries and measure with DMM primary. Then connect heater coils and measure primary. Then connect rect. tube without wire to first el. cap. Note, if You connect only PS elements, +U can be more 400 V /without load/, that is dangerous and death U. If You never measure high voltages, better don't do that! When output stages are connected +U can be about 350 V. Then connect middle points of OTs. Every time switch off if You something connect and then switch on and measure!