Reference DAC Module - Discrete R-2R Sign Magnitude 24 bit 384 Khz - Page 330 - diyAudio
Go Back   Home > Forums > Commercial Sector > Vendor Forums > Vendor's Bazaar
Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Vendor's Bazaar Commercial Vendors large & small hawking their wares

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th August 2015, 10:23 AM   #3291
soekris is offline soekris  Denmark
diyAudio Member
 
Join Date: Jun 2009
Quote:
Originally Posted by ylingf View Post
Thank you Soren! I am having problem downloading mkrom.exe though.
Unix is need correct upper/lower case, the link is:

http://www.soekris.dk/MKROM.EXE

Should be Version 0.93, 20150815.
__________________
Søren
  Reply With Quote
Old 16th August 2015, 10:24 AM   #3292
diyAudio Member
 
Join Date: Feb 2003
Location: West Coast of Norway
Small "clicks" between every track. Not very annoying. Using raspberry pi2 i2s direct into the dam1021.
This is with archphile distro.

Earlier with rpi2 - usb-i2s interface - dam1021 I got only pops/clicks between sample change.

I dont get clicks with picoreplayer distro.
  Reply With Quote
Old 16th August 2015, 10:30 AM   #3293
Dimdim is online now Dimdim  Greece
diyAudio Member
 
Join Date: Sep 2008
Location: Athens
Quote:
Originally Posted by soekris View Post
No. But you can always assign old filters to one of the type 4..7, assuming you have the source.
This is excellent news!

What are the commands for selecting different filters?
Do we still need to make a source change to apply the new filter?
__________________
http://www.dimdim.gr
  Reply With Quote
Old 16th August 2015, 10:36 AM   #3294
diyAudio Member
 
Join Date: Feb 2012
Location: Riga
Clicks still persist for me as well.

However they only happen when input sample rate is different, changing tracks with the same sample rate doesn't trigger re-locking. The length of the click hasn't changed and I believe that the amplitude changes depending on what signal is being played.

Clicks were detected using Foobar when switching between 16/44 and 24/96 content.

Using Amanero interface, last revision.

Last edited by RudeWolf; 16th August 2015 at 10:44 AM.
  Reply With Quote
Old 16th August 2015, 10:46 AM   #3295
soekris is offline soekris  Denmark
diyAudio Member
 
Join Date: Jun 2009
Forgot to mention:

FIR2 filter can also be selected, types are 8..11 and as possible will track FIR1 selection.

There is new uManager command "filters [all]", will show either current selected filters or all possible.

The uC operates in two modes:

Management mode, entered though +++, for download and setting parameters, this mode is not really supposed to be used while paying audio, it can not change things and pll will not track. Exit command will return to playing mode.

Playing mode, normal mode while playing audio, short commands and status over the serial port work, command have to be upper case:

Ix, x = 0..3, select input
Vx, x = -80 to +10, set current volume
Fx, x = 4..7, select FIR1/FIR2 filter, with immediate effect

In playing mode it will also output the short status to the serial port:

Rx.xx, Current uC Firmware Revision, at power up only
Lxxx, PLL lock at speed xxx

Will update website and release full manual with all info shortly.
__________________
Søren

Last edited by soekris; 16th August 2015 at 10:51 AM.
  Reply With Quote
Old 16th August 2015, 11:10 AM   #3296
leehan is offline leehan  United Kingdom
diyAudio Member
 
Join Date: Jun 2010
Location: Kent, UK
Thank you for the update Soren. I still have the clicks. Hope the following helps.

Is it just between tracks with different sample rates or between all tracks ?

Between tracks with different sample rates.

What USB interface are you using ? Or what interface if not USB ?

Amanero

What Player software are you using ?

Vox for Mac (VOX Player for Mac - play FLAC, MP3, APE, 24/192 on your Mac OS X)

How powerful / long is the click ?

Quite powerful, not very long, shorter than pronouncing "click". Testing with "Mixed" filter.

Improved from previous version ?

No.

Is there anybody with Amanero who doesn't get clicks?
  Reply With Quote
Old 16th August 2015, 11:52 AM   #3297
diyAudio Member
 
Join Date: Nov 2009
Location: Riga
Quote:
Originally Posted by soekris View Post
Playing mode, normal mode while playing audio, short commands and status over the serial port work, command have to be upper case:

Ix, x = 0..3, select input
Vx, x = -80 to +10, set current volume
Fx, x = 4..7, select FIR1/FIR2 filter, with immediate effect

In playing mode it will also output the short status to the serial port:

Rx.xx, Current uC Firmware Revision, at power up only
Lxxx, PLL lock at speed xxx

Will update website and release full manual with all info shortly.
It would be extremely useful to have query commands that a controller can use to obtain the current DAM status on demand. For example:
V? - output current volume
I? - output current input
An so on for the other commands.

Regarding the clicking problem.
It is better, but not completely solved. I will post my findings when I have time to do proper testing.
Would it be possible to implement a MUTE control output that DAM activates when there is no signal lock? It would allow muting the outputs externally to solve the problem once and for all.
If possible, perhaps the PWRLED pin could be reassigned to MUTE control? For dac builders it would also work quite well as a visual LED indicator for signal lock.
  Reply With Quote
Old 16th August 2015, 11:57 AM   #3298
diyAudio Member
 
Join Date: Apr 2015
Hi to this Thread,

I am tempted to Order a 0.01% DAM Module.
When I checked soekris.eu, I saw that this one
is out of stock. Can someone tell me when this will
be available?

Regards,
Michael
  Reply With Quote
Old 16th August 2015, 12:54 PM   #3299
diyAudio Member
 
Join Date: Feb 2003
Location: West Coast of Norway
Been playing some. Yes still clicks when changing songs. Even doing "fast forward" in songs. I am not sure if it is mpd (music player deamon" that looses track or something.
I can see from the umanager in "play" mode that it loads a filter during evry song change (regardless of sample rate, even if it is the same) and loads filter when doing "fast forward" for instance. It is this filter loading that causes the "click".
Sometimes the click is low in volume. Sometimes quite loud.

But maybe its just me. I think the dac has good sound with the latest fw? (and filters)
Quote:
dam1021 uManager Rev 0.99 20150814 FPGA Rev 0.99 Press ? for help.

# exit

L044
L044
L044
L044
L044
L044
This is when changing songs and doing "rewind or fast forward" in songs.

Last edited by bambadoo; 16th August 2015 at 01:06 PM.
  Reply With Quote
Old 16th August 2015, 01:02 PM   #3300
diyAudio Member
 
Join Date: Feb 2015
Quote:
Originally Posted by normundss View Post
It would be extremely useful to have query commands that a controller can use to obtain the current DAM status on demand. For example:
V? - output current volume
I? - output current input
An so on for the other commands.

Regarding the clicking problem.
It is better, but not completely solved. I will post my findings when I have time to do proper testing.
Would it be possible to implement a MUTE control output that DAM activates when there is no signal lock? It would allow muting the outputs externally to solve the problem once and for all.
If possible, perhaps the PWRLED pin could be reassigned to MUTE control? For dac builders it would also work quite well as a visual LED indicator for signal lock.
One observation with the new firmware is that the PWRLED pin is no longer inverted to what the onboard LED state is. This completely breaks my output muting/shunter due to it expecting the original inverted signal. Not a big deal as it actually simplifies the circuit quite a lot, just have to redo it. Now that I have to rip it apart I should be able to post a schematic if anyone wants to implement their own hardware mute.

EDIT: Yes the pops are bad now that I have to hear them again, yes its wife-waking material, suddenly remember why I went through the trouble to do hardware muting.
__________________
Soekris dam1021-12v2 dual-mono balanced: https://imgur.com/a/fD68M
Hypex nc400: https://imgur.com/iORCyna | Overkill TT2USB: https://imgur.com/a/p6OiS

Last edited by spikestabber; 16th August 2015 at 01:04 PM.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
e18 DAC - 8 channels at 32bit /384 kHz exa065 exaDevices 30 29th June 2012 05:11 PM
384 Khz DAC? SunRa Digital Source 8 1st October 2009 11:14 PM
24 bit/192 kHz via USB? gentlevoice Everything Else 3 22nd December 2008 06:24 AM
sign magnitude DAC Bernhard Digital Source 0 30th January 2007 01:40 PM
24 bit / 192 kHz Tube DAC questions Overlord Digital Source 4 29th April 2003 05:14 PM


New To Site? Need Help?

All times are GMT. The time now is 04:28 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio

Content Relevant URLs by vBSEO 3.3.2
Wiki