Evens C-500 amplifier ....opinions? - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd March 2010, 11:20 PM   #1
diyAudio Member
 
Join Date: Feb 2008
Default Evens C-500 amplifier ....opinions?

I want to build this amplifier as a diy project

Google Şu mesajı

Today I tried to make the pcb using press&peel method with little success...need photo paper.
The amplifier looks reliable and simple...using common componets...I have most of the transistors required, PSU and trafo.
I would like some expert opinions about this schematic.....the author may slip some ERRORS on the published article so that diyers have a hard time making the amplifier work properly.
Any advice on what components can be chaged for better results are welcomed. I want this to be a good sounding (Hi-Fi if possible), powerful and robust amplifier.
Please comment on the stability of this amplifier for +/-70 CC rails and 4 pairs of outputs and other related issues.

Any feedback greatly appreciated !!!
  Reply With Quote
Old 4th March 2010, 12:07 AM   #2
diyAudio Member
 
Join Date: Feb 2008
I was analyzing the schematic and I don't like Q11 used for bias adjustment...
2sc2058 is a ghost transistor..hard to find....can it be replaced with something else?...It doesn't even look like the one used for the prototypes.
Any thoughts?
  Reply With Quote
Old 4th March 2010, 01:10 AM   #3
diyAudio Member
 
Join Date: Feb 2008
Also the trim for bias is 500 on the schematic but 100 on the components layout...
I think the bias transistor is 2sd2058.....looks similar with the one in the pictures also.
  Reply With Quote
Old 4th March 2010, 05:51 PM   #4
diyAudio Member
 
Join Date: Feb 2008
No reply? .....
  Reply With Quote
Old 5th March 2010, 03:47 PM   #5
diyAudio Member
 
Join Date: Feb 2008
Cmon....no one has any opinion about this amplifier?
  Reply With Quote
Old 5th March 2010, 07:55 PM   #6
Account disabled at member's request
 
Join Date: May 2006
A quick look and I dont see much wrong with it, interesting how its compensated, might sound petty good indeed, for bias transistor you could just use standard bd139, for higher performance use something with very high gain even possibly a darlington. It uses good components, no need to change except for the Q11, I use 2sd1508 or 2sc3964 depending on what I have at hand.
  Reply With Quote
Old 5th March 2010, 08:18 PM   #7
diyAudio Member
 
Join Date: Feb 2008
The bd139 is rated for 80 v....does it matter what voltage is the bias transistor?
I was thinking about using mje340 or 350...the npn one because of the isolated type construction.
I hope I'll have some PCB's by the end of next week.
  Reply With Quote
Old 5th March 2010, 08:35 PM   #8
Account disabled at member's request
 
Join Date: May 2006
Not that much, bias transistor only has a couple of volts across it anyway but low Vce component is more temperature sensitive, the mjes dont work as well, these are high voltage types, youll be mounting that transistor on one of the output ones although I havent seen how its done with that amp, but its better to mount it on top of one of the output transistors, so I dont see a problem with the bd but for high performance try get hold of some darlington type. Another very good type is 2sc4495, you should be able to get them in the UK, try profusion, you could also get your output transistors from there although I wouldnt recommend the second source 2sc5200 2sa1943 output transistors, they have better sanken ones.
  Reply With Quote
Old 5th March 2010, 08:52 PM   #9
diyAudio Member
 
Join Date: Feb 2008
I used 2sc5200 and 2sa1943 in a lot of my amplifiers and I am very satisfied with them....reliable and cheap + they sound good. I know there are better transistors but they cost a lot more and hard to find...with these ones you wont cry if u burn a few pairs.
When I build the amplifier I will use several transistors for bias to see which one works better.
I was wondering why this schematic doesn't have a resistor in parallel with the output coil....any ideas?



Just checked the transistor recommended by you 2SC4495 Silicon NPN Triple Diffused Planar Transistor(Audio Temperature Compensation and General Purpose), sounds good

Last edited by butch_vlad; 5th March 2010 at 08:55 PM.
  Reply With Quote
Old 5th March 2010, 08:57 PM   #10
diyAudio Member
 
Join Date: Feb 2008
I forgot to mention I already have the outputs and the preouts....a few original pairs each.
The only thing I really miss is a good quality case...this one looks nice
modushop.biz
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
threshold s/500 power amplifier swmpd Pass Labs 15 24th May 2012 12:32 AM
JL Audio 500/1 Amplifier Repair Help Audioguy564 Car Audio 10 27th August 2009 03:24 AM
Newish JL 500/1 amplifier FOR SALE Dominick22 Swap Meet 1 13th December 2007 03:38 PM
Hafler DH-500 Amplifier for sale joe carrow Swap Meet 5 13th August 2006 06:22 PM


New To Site? Need Help?

All times are GMT. The time now is 10:45 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2