Transmission Line Modelling Software - Page 44 - diyAudio
Go Back   Home > Forums > Design & Build > Software Tools

Software Tools SPICE, PCB CAD, speaker design and measurement software, calculators

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th March 2013, 04:34 AM   #431
diyAudio Member
 
Join Date: May 2006
I finally got some time to compare tl.app to Hornresp for front loaded horn design. It's a fairly complex 4 segment horn with an offset driver, and obviously a sealed rear chamber but I didn't bother with a front chamber on this - that would just amount to a 5 segment horn anyway. I tried to make sure every single input was exactly the same in both programs, including making sure the rear chamber was the correct geometry and not masking rear chamber resonances in the hornresp sim.

This isn't a good horn design, so don't get hung up on that, the sole purpose of this excercise was to compare the output of both programs. They are pretty close, almost dead on in the 80 - 200 hz range, with tl.app response drooping a bit below 80 hz and a bit stronger above 200 hz as compared to hornresp.

I'm going to review my inputs again with a fine tooth comb to make sure the differences are not due to an error on my part, but even if not, I'd say these results are very acceptable. I can provide the hornresp export data and the tl.app project file upon request if anyone wants to check my work.
Attached Images
File Type: png tl.app vs hornresp.png (141.8 KB, 283 views)
  Reply With Quote
Old 6th March 2013, 05:57 AM   #432
diyAudio Member
 
Join Date: Jun 2007
Quote:
Originally Posted by just a guy View Post
They are pretty close, almost dead on in the 80 - 200 hz range, with tl.app response drooping a bit below 80 hz and a bit stronger above 200 hz as compared to hornresp.
Hi just a guy,

Possible reasons for the differences:

1. The TL program appears to be using a simple "straight line" approximation for the horn mouth acoustical impedance at high frequencies.

2. Perhaps the TL program is making assumptions on directivity and is showing the on-axis pressure response, rather than the power response?

Kind regards,

David
Attached Images
File Type: png TL_Za.png (21.8 KB, 272 views)
File Type: png HR_Za.png (58.9 KB, 273 views)
__________________
www.hornresp.net
  Reply With Quote
Old 6th March 2013, 02:15 PM   #433
diyAudio Member
 
Join Date: Nov 2006
Send a message via ICQ to elvischan917 Send a message via MSN to elvischan917
Quote:
Originally Posted by schmeet View Post
p = f(ct - x) + g(ct + x)

I think you are an expert in wave equation. Do you assume it is a plane wave inside the tube? How did you derive it?

Thanks.
Alvis
__________________
^_^
Alvis
  Reply With Quote
Old 6th March 2013, 06:15 PM   #434
diyAudio Member
 
upking's Avatar
 
Join Date: Apr 2011
Maybe someone could make a tutorial about how to use this program.
I honestly tried to figure out how to model the enclosure but I just can't!
The program seems to be amazing and very powerful, but only to the ones that already know how to use it.
  Reply With Quote
Old 6th March 2013, 06:33 PM   #435
diyAudio Member
 
Join Date: May 2006
Quote:
Originally Posted by upking View Post
Maybe someone could make a tutorial about how to use this program.
I honestly tried to figure out how to model the enclosure but I just can't!
The program seems to be amazing and very powerful, but only to the ones that already know how to use it.
Transmission Line Modelling Software

That's most of it. If you want every single little detail you have to read this whole thread.

Last edited by just a guy; 6th March 2013 at 06:37 PM.
  Reply With Quote
Old 6th March 2013, 06:36 PM   #436
diyAudio Member
 
Join Date: May 2006
Quote:
Originally Posted by David McBean View Post
Hi just a guy,

Possible reasons for the differences:

1. The TL program appears to be using a simple "straight line" approximation for the horn mouth acoustical impedance at high frequencies.

2. Perhaps the TL program is making assumptions on directivity and is showing the on-axis pressure response, rather than the power response?

Kind regards,

David
#1 Is this something we can manually account for by adding for subtracting a small segment at the end of the line?

#2 If it is showing on axis response, that would explain it. I'm not too interested in what's going on above 200 hz anyway so I don't care much about that. I'm very interested in getting the best results possible on the low end though.

Thanks David.
  Reply With Quote
Old 7th March 2013, 05:15 AM   #437
diyAudio Member
 
Join Date: Jun 2007
Quote:
Originally Posted by just a guy View Post
Is this something we can manually account for by adding or subtracting a small segment at the end of the line?
Hi just a guy,

The simplifying approximation made in the TL program when calculating horn mouth acoustical impedance at high frequencies cannot be manually accounted for. I haven't checked to see how much of an affect it has on the accuracy of the overall results, though - perhaps the difference is not worth worrying about anyway :-).

Kind regards,

David
__________________
www.hornresp.net
  Reply With Quote
Old 5th April 2013, 03:37 AM   #438
diyAudio Member
 
Greebster's Avatar
 
Join Date: Aug 2010
Location: South of the Skyway
Pete, you've gone and done a great job! Thank you

Found a little bugger with the series/parallel driver configuration always defaulting to series. As others have mentioned, also have the minimize error. I just ignore and all is fine. i7 Win7x64

and a big please on multi driver config implementation
  Reply With Quote
Old 18th April 2013, 09:31 PM   #439
diyAudio Member
 
LineSource's Avatar
 
Join Date: Sep 2003
Location: SiliconValley
Are there any hidden files which must be removed before a re-install of the latest version 3.6.1.11 can be accomplished?


I was using and enjoying version 3.6.1.11 on my computer for days until an error message came up, after which the "enclosure" window never showed any design data. I could still run simulations, just not see any physical box design images, not even the speaker circle. I downloaded a new "setup" file from Leonard Audio website into a clean directory, but it does not install ... only generates an error message.

1) Computer running Windows Vista64 Ultimate with all updates.
2) No problems with initial install of 3.6.1.11
3) ReStarted computer before re-install. .. Error Message Below
4) Attempted install into new directory, and as Administrator

------------- Great Tool ---- Appreciate your work ----
PLATFORM VERSION INFO
Windows : 6.0.6002.131072 (Win32NT)
Common Language Runtime : 4.0.30319.296
System.Deployment.dll : 4.0.30319.1 (RTMRel.030319-0100)
clr.dll : 4.0.30319.296 (RTMGDR.030319-2900)
dfdll.dll : 4.0.30319.1 (RTMRel.030319-0100)
dfshim.dll : 4.0.31106.0 (Main.031106-0000)

SOURCES
Deployment url : http://www.leonardaudio.co.uk/softwa...ne.application
Server : nginx

IDENTITIES
Deployment Identity : TransmissionLine.application, Version=3.6.1.11, Culture=en-GB, PublicKeyToken=f7a0f47851736b6e, processorArchitecture=x86

APPLICATION SUMMARY
* Installable application.

ERROR SUMMARY
Below is a summary of the errors, details of these errors are listed later in the log.
* Activation of http://www.leonardaudio.co.uk/softwa...ne.application resulted in exception. Following failure messages were detected:
+ Activation failed.
+ The system cannot find the file specified. (Exception from HRESULT: 0x80070002)

COMPONENT STORE TRANSACTION FAILURE SUMMARY
No transaction error was detected.

WARNINGS
There were no warnings during this operation.

OPERATION PROGRESS STATUS
* [4/18/2013 1:07:47 PM] : Activation of http://www.leonardaudio.co.uk/softwa...ne.application has started.
* [4/18/2013 1:07:52 PM] : Processing of deployment manifest has successfully completed.

ERROR DETAILS
Following errors were detected during this operation.
* [4/18/2013 1:07:52 PM] System.Deployment.Application.DeploymentException (Activation)
- Activation failed.
- Source: System.Deployment
- Stack trace:
at System.Deployment.Application.ComponentStore.Activ ateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)
at System.Deployment.Application.SubscriptionStore.Ac tivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)
at System.Deployment.Application.ApplicationActivator .Activate(DefinitionAppId appId, AssemblyManifest appManifest, String activationParameter, Boolean useActivationParameter)
at System.Deployment.Application.ApplicationActivator .PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
at System.Deployment.Application.ApplicationActivator .ActivateDeploymentWorker(Object state)
--- Inner Exception ---
System.IO.FileNotFoundException
- The system cannot find the file specified. (Exception from HRESULT: 0x80070002)
- Source: System.Deployment
- Stack trace:
at System.Deployment.Application.NativeMethods.CorLau nchApplication(UInt32 hostType, String applicationFullName, Int32 manifestPathsCount, String[] manifestPaths, Int32 activationDataCount, String[] activationData, PROCESS_INFORMATION processInformation)
at System.Deployment.Application.ComponentStore.Activ ateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)

COMPONENT STORE TRANSACTION DETAILS
* Transaction at [4/18/2013 1:07:52 PM]
+ System.Deployment.Internal.Isolation.StoreOperatio nSetDeploymentMetadata
- Status: Set
- HRESULT: 0x0
+ System.Deployment.Internal.Isolation.StoreTransact ionOperationType (27)
- HRESULT
  Reply With Quote
Old 22nd April 2013, 07:04 AM   #440
diyAudio Member
 
blakkshepeaudio's Avatar
 
Join Date: Sep 2010
Location: Country Victoria Australia
Is there any chance of further development on this very promising tool ?

Pleeeeeease.........


blakkground
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TLwrx v 3.0 Transmission Line Software CarlosT Subwoofers 16 27th March 2008 05:25 PM
3 Way Crossover modelling Software? Grahame Multi-Way 3 13th May 2007 05:50 AM
Matlab-based triode modelling software Radames Tubes / Valves 1 16th September 2005 08:36 PM
3d modelling software greg_mcquaid Multi-Way 17 22nd May 2004 08:03 AM


New To Site? Need Help?

All times are GMT. The time now is 08:42 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2