Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Pass Labs This forum is dedicated to Pass Labs discussion.

Mezmerize DCB1 Building Thread
Mezmerize DCB1 Building Thread
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd April 2012, 01:27 PM   #501
KatieandDad is offline KatieandDad  United Kingdom
diyAudio Member
 
KatieandDad's Avatar
 
Join Date: Nov 2011
Location: UK
Your heatsinks are all wrong.

At low current ie 10R (60mA) nothing will cook, but if you are HOTRODDING you will need to reorientate your heatsinks.
Attached Images
File Type: jpg DSIR9371.JPG (197.9 KB, 707 views)

Last edited by KatieandDad; 22nd April 2012 at 01:29 PM.
  Reply With Quote
Old 22nd April 2012, 01:41 PM   #502
KatieandDad is offline KatieandDad  United Kingdom
diyAudio Member
 
KatieandDad's Avatar
 
Join Date: Nov 2011
Location: UK
One other thing to check is that you haven't got any hairline shorts around the B1 buffer section.

OK my PCB was homebrew but I had minute shorts around the relay. That is why I decided to use the Salas Shunt Reg on its own with a regular B1 PCB.
  Reply With Quote
Old 22nd April 2012, 02:17 PM   #503
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Mezmerize DCB1 Building Thread
The Mosfets don't make full contact on the sinks in the picture! Dangerous.
  Reply With Quote
Old 22nd April 2012, 02:22 PM   #504
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Mezmerize DCB1 Building Thread
For the (L) offset the problem can be a dead JFET or wrongly matched by much in the right hand horizontal pair on the pic.
  Reply With Quote
Old 22nd April 2012, 03:01 PM   #505
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
The output offset depends on what you feed into the DCB1 and on what the operating Id is, in comparison to the measured Idss of the amplifying jFET. It does not depend on the PSU voltages. It does not depend on the LED voltages. It does not depend on the CCS current.

Why have you braided your cable pairs/triplets for high inductance?
Twisting for low inductance, is much preferred for attenuating interference.
__________________
regards Andrew T.

Last edited by AndrewT; 22nd April 2012 at 03:04 PM.
  Reply With Quote
Old 22nd April 2012, 06:18 PM   #506
andreasw is offline andreasw  Germany
diyAudio Member
 
Join Date: May 2008
Location: NRW
Thank you for your answers and for your recommendations.

At first I will remove it out of the case (I didnīt expect problems ...) and will check and measure all the things you mentioned.

@Salas
I disconnected the heatsinks cause I thought it effects something.
I know they are oversized and will remove them.


Andreas
  Reply With Quote
Old 22nd April 2012, 08:55 PM   #507
johnwmclean is offline johnwmclean  Australia
diyAudio Member
 
Join Date: Oct 2009
andreas, I don’t see any thermal grease applied, I would recommend to apply some.
  Reply With Quote
Old 24th April 2012, 11:19 AM   #508
andreasw is offline andreasw  Germany
diyAudio Member
 
Join Date: May 2008
Location: NRW
Quote:
Originally Posted by Salas View Post
For the (L) offset the problem can be a dead JFET or wrongly matched by much in the right hand horizontal pair on the pic.
I changed the JFET you mentioned.
Now I measure R -0,8 mV and L -1,7 mV DC offset.

It's better but good enough?

Andreas
  Reply With Quote
Old 24th April 2012, 11:42 AM   #509
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Mezmerize DCB1 Building Thread
Its very good. Are the supply voltages still alright? Check that you got 1.5-2VDC drop on the current set resistors too. Then you are good to play.
  Reply With Quote
Old 25th April 2012, 07:40 PM   #510
andreasw is offline andreasw  Germany
diyAudio Member
 
Join Date: May 2008
Location: NRW
I measured 1.6VDC and itīs connected to Symasyms and sounds good at "Plastic Speakers" in the celler.
I have to finish the front plate and than it moves to my second setup which is DCB1, Symasym, Pearl (my first is ONO, Aleph P1.7, Aleph J :-).
I will post some pictures later.

Thank you very much for your help!

Andreas
  Reply With Quote

Reply


Mezmerize DCB1 Building ThreadHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS : F3 PCB + PSU - Hypnotize - Mezmerize - LightSpeed korben69 Swap Meet 16 21st June 2013 07:52 AM
WTB Mezmerize PCB 3GGG Swap Meet 3 16th January 2011 10:15 AM
My XXLS Subwoofer building thread... harrisni Subwoofers 9 28th October 2007 09:21 PM
Fave song from SOAD 'Mezmerize'? PeteMcK Music 6 8th March 2006 04:12 AM
Gainclone building thread based on BrianGT's boards meat Chip Amps 752 8th August 2004 07:25 AM


New To Site? Need Help?

All times are GMT. The time now is 04:51 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki