ucd 25 watts to 1200 watts using 2 mosfets - Page 366 - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th August 2013, 06:37 AM   #3651
diyAudio Member
 
andrewlebon's Avatar
 
Join Date: Feb 2008
Hello
greetings why do CROWN XTI9000 have 4 T157-2 cores as output filters PER CHANNEL
warm regards
andrew lebon
__________________
[image][/image]"It's Better to try and fail than to never know and always wonder"
  Reply With Quote
Old 28th August 2013, 07:18 AM   #3652
PetruV is offline PetruV  Romania
diyAudio Member
 
Join Date: Dec 2012
Location: Bucuresti
What is the link to irs900 and irs3000 pcbs?
__________________
I know everything but do nothing
  Reply With Quote
Old 28th August 2013, 01:27 PM   #3653
diyAudio Member
 
Join Date: Sep 2010
Location: Quezon City
Quote:
Originally Posted by stewin View Post
thanks for the reply . i am facing serious issues with irs900 both thienchay and detex they work for a short time or a few days and fail i have had three different experiences .in all the above the voltage was
>>> +/- 70vlts about 6amps and filtering caps were 6800uf per rail.
>>>the load was 3ohms to 8 ohms
>>>all the output fets were one pair irfp250n
>>>all the inductor i used was etd 33 or ee 33 , 15turns and 1mm gap on both legs using a piece of CD or DVD disc
>>>switching frequency was 250khz normal on the thienchay and detex layout
two projects had two channels one project had four channels.

i am thinking maybe busspumping, slow fets ("but dismissing it because big proffesional companies powersoft use irfp250n") , non ucd topology or core saturation . please help i am really confused .

i have another irs900 three channels which has survived for one year plus without any issues except bowing fuse when one output of either channel ,a speaker or load is disconnected when the amp is on. all the specs are like the above except the voltage is +/-39vlts.
i will post photos later.
Did your IRS900 fail at startup? If yes it's possible that you have a startup problem described here. Check the time constant of your bootstrap supply...

Since IRS900 doesn't have overcurrent protect, high side latching at startup will cause both mosfets to blow.
  Reply With Quote
Old 28th August 2013, 07:12 PM   #3654
stewin is offline stewin  Kenya
diyAudio Member
 
Join Date: Jul 2007
thanks lester. i think that is the best explanation. because i had build manojs great amp aud600 three channels with protection board , it worked well and very fine even when using a generator instead of ac from mains. voltage was +/- 60vlts output fets were irfp250n .

but when i did not use the protection board . it failed even at startup even without a load same case as irs900d. and the case was not one board but different experiences.
  Reply With Quote
Old 31st August 2013, 04:58 AM   #3655
diyAudio Member
 
andrewlebon's Avatar
 
Join Date: Feb 2008
Default IRS1500 STEREO PCB

Sameerx1 new IRS1500 stereo pcbs double side
warm regards
andrew lebon
Attached Images
File Type: jpg 1148845_202438549917588_1666567237_n.jpg (126.9 KB, 794 views)
File Type: jpg 1229811_202438573250919_50477389_n.jpg (115.2 KB, 765 views)
__________________
[image][/image]"It's Better to try and fail than to never know and always wonder"
  Reply With Quote
Old 1st September 2013, 01:21 AM   #3656
diyAudio Member
 
andrewlebon's Avatar
 
Join Date: Feb 2008
Default spw52n50c3

Manufacturer: Infineon
Product Category: MOSFET
RoHS: RoHS Compliant Details
Transistor Polarity: N-Channel
Drain-Source Breakdown Voltage: 560 V
Gate-Source Breakdown Voltage: +/- 20 V
Continuous Drain Current: 52 A
Resistance Drain-Source RDS (on): 70 mOhms
Configuration: Single
Maximum Operating Temperature: + 150 C
Mounting Style: Through Hole
Package / Case: TO-247
Packaging: Tube
Fall Time: 10 ns
Minimum Operating Temperature: - 55 C
Power Dissipation: 417 W
Rise Time: 30 ns
Series: xPW52N50
Factory Pack Quantity: 240
Tradename: CoolMOS
Typical Turn-Off Delay Time: 120 ns
Hello
greetings is this mosfet suitable for class d amps as its easily available
made by IFINIEON
warm regards
andrew lebon
__________________
[image][/image]"It's Better to try and fail than to never know and always wonder"
  Reply With Quote
Old 1st September 2013, 09:02 AM   #3657
diyAudio Member
 
Join Date: Oct 2009
some class d amps in working progress,
triell 3200, detex audio irs3000d, srimodify 3200i.
Attached Images
File Type: jpg DSC03375 copy.jpg (362.7 KB, 693 views)
File Type: jpg DSC03376 copy.jpg (347.2 KB, 620 views)
File Type: jpg DSC03377 copy.jpg (393.6 KB, 556 views)
File Type: jpg DSC03379 copy.jpg (391.2 KB, 165 views)
File Type: jpg DSC03381 copy.jpg (427.9 KB, 194 views)
File Type: jpg DSC03386 copy.jpg (356.6 KB, 213 views)
  Reply With Quote
Old 1st September 2013, 09:05 AM   #3658
diyAudio Member
 
andrewlebon's Avatar
 
Join Date: Feb 2008
core is not suitable for class d
warm regards
andrew
__________________
[image][/image]"It's Better to try and fail than to never know and always wonder"
  Reply With Quote
Old 1st September 2013, 09:17 AM   #3659
diyAudio Member
 
Join Date: Oct 2009
yes, but its working fine,
next week i am going to thailand, and i will buy that core, because in my country not available.
  Reply With Quote
Old 3rd September 2013, 01:42 AM   #3660
diyAudio Member
 
andrewlebon's Avatar
 
Join Date: Feb 2008
Default limiter

Hello Sameerx1
greetings heres the limiter
Attached Files
File Type: pdf Limiter.pdf (81.2 KB, 338 views)
__________________
[image][/image]"It's Better to try and fail than to never know and always wonder"
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Philips 40/25/15 watts amplifier with Universal preamplifier circuit. renjiish Solid State 62 28th June 2014 05:02 PM
Decibel Watts VS Watts ? fivestring Solid State 11 1st April 2009 01:08 PM
AMP1-B: why only 25 watts @8ohms? theAnonymous1 Class D 10 15th August 2005 06:55 PM
Sound quality of amps at 0.3 watts vs @ typical 5 watts rick57 Solid State 2 26th March 2005 06:25 AM
Need 2 watts Vivek Everything Else 4 17th July 2003 08:29 AM


New To Site? Need Help?

All times are GMT. The time now is 02:05 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2