ucd 25 watts to 1200 watts using 2 mosfets - Page 218 - diyAudio
Go Back   Home > Forums > Amplifiers > Class D

Class D Switching Power Amplifiers and Power D/A conversion

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th August 2012, 05:35 AM   #2171
manojtm is offline manojtm  India
diyAudio Member
 
manojtm's Avatar
 
Join Date: Aug 2008
Quote:
i managed to make this thing work but dint get any much success......on low volume it works as clean as a headphone does but when increase volume there is a distortion in the speakers...like someone is tearing papers......help me out with this issue??????
I think your output filter not good or not matched (saturated) with current freq.. pls provide your schematic

RGDS
MANOJ
  Reply With Quote
Old 6th August 2012, 09:01 AM   #2172
paskal9 is offline paskal9  Malaysia
diyAudio Member
 
paskal9's Avatar
 
Join Date: Apr 2010
Location: the tropics with 97% humidity
Quote:
Originally Posted by irvynejay View Post
can you post some photo so we can see what, where is the problem

top and bottom
haven't built the pcb yet. i was contemplating to either redraw the schematic and include the 12v aux supply and a dc protection or just etch the pcb provided by thienchay at post #2101 & #2102.

seeing how simple it is i redraw the schematics when i see the pinout of the cd4049 is different compared to the pinout used in cheshta's and thienchay's pcb. so i was wondering if anyone have etched and built the irs900 using cheshta or thienchay's pcb.

here's the original schematic of the irs-900d posted by cheshta:
Click the image to open in full size.
together with the cd4049 pinout from his post:
Click the image to open in full size.

a remake of the pcb from thienchay:
Click the image to open in full size.

and he's the pinout from cd4049 datasheet:
Click the image to open in full size.

pin 7 and 8 shouldn't be shorted together and some other error. or am i reading it wrong somewhere?
would really love to hear any feedback from people who have built the irs900.
  Reply With Quote
Old 6th August 2012, 09:44 AM   #2173
exflaco is offline exflaco  Armenia
diyAudio Member
 
Join Date: Mar 2005
Location: Santa Fe
Too muchs mistakes may by Irvynejay or other people could help us
  Reply With Quote
Old 6th August 2012, 10:55 AM   #2174
diyAudio Member
 
irvynejay's Avatar
 
Join Date: Nov 2010
Location: Philippines;Mindanao,Butuan
Send a message via Yahoo to irvynejay Send a message via Skype™ to irvynejay
i don't have schematic i only made the amp without it and its working great
i only use detex file to make the pcb
Attached Images
File Type: jpg ab722e449ca921e4.jpg (263.3 KB, 1688 views)
File Type: jpg DSC_0167.jpg (349.7 KB, 892 views)
File Type: jpg DSC_0170.JPG (331.9 KB, 774 views)
File Type: jpg DSC_0168.jpg (220.5 KB, 670 views)
File Type: jpg 78d4afface1eb8fa.jpg (314.1 KB, 739 views)
File Type: jpg 31a42ae5c53391db.jpg (195.3 KB, 661 views)
File Type: jpg irs500 component.jpg (132.5 KB, 832 views)
__________________
Knowing GOD is not being good,Knowing GOD is just knowing him as my friend

Last edited by irvynejay; 6th August 2012 at 11:03 AM.
  Reply With Quote
Old 6th August 2012, 12:11 PM   #2175
diyAudio Member
 
thienchay's Avatar
 
Join Date: Oct 2010
I apologize because i'm did not checking carefully schematic of Detex .
I think they deliberately show ​​the wrong schematic , but given right PCB .
And i recheck it , they just used 2 NOT gate of CD4049 on their PCB , and it is right , orther NOT Gate is not used .

This is the schematic i redraw .
Attached Images
File Type: jpg CHE-900D checking.jpg (143.9 KB, 1108 views)
  Reply With Quote
Old 6th August 2012, 12:32 PM   #2176
paskal9 is offline paskal9  Malaysia
diyAudio Member
 
paskal9's Avatar
 
Join Date: Apr 2010
Location: the tropics with 97% humidity
Quote:
Originally Posted by irvynejay View Post
i don't have schematic i only made the amp without it and its working great
i only use detex file to make the pcb
Quote:
Originally Posted by thienchay View Post
I apologize because i'm did not checking carefully schematic of Detex .
I think they deliberately show ​​the wrong schematic , but given right PCB .
And i recheck it , they just used 2 NOT gate of CD4049 on their PCB , and it is right , orther NOT Gate is not used .

This is the schematic i redraw .
thanks guys!
that's all that i needed to hear. the schematic is indeed with error. now that i have you guys that have built a working pcb i know not to follow the schematic and build the amp according to the posted pcb.

thanks again guys
  Reply With Quote
Old 6th August 2012, 12:36 PM   #2177
diyAudio Member
 
irvynejay's Avatar
 
Join Date: Nov 2010
Location: Philippines;Mindanao,Butuan
Send a message via Yahoo to irvynejay Send a message via Skype™ to irvynejay
take note input ground connection to main ground psu,,have fun making it its good amp,
__________________
Knowing GOD is not being good,Knowing GOD is just knowing him as my friend
  Reply With Quote
Old 6th August 2012, 03:13 PM   #2178
stewin is offline stewin  Kenya
diyAudio Member
 
Join Date: Jul 2007
can irfp260N work at +/- 85vlts with this pcb? and has any one tried this amp with +/-90vlts & what output fets did you use?

Last edited by stewin; 6th August 2012 at 03:28 PM.
  Reply With Quote
Old 7th August 2012, 03:43 AM   #2179
chago25 is offline chago25  Philippines
diyAudio Member
 
Join Date: Feb 2011
Quote:
Originally Posted by irvynejay View Post
i don't have schematic i only made the amp without it and its working great
i only use detex file to make the pcb
its not only working great its powerful also!
  Reply With Quote
Old 7th August 2012, 08:26 AM   #2180
stewin is offline stewin  Kenya
diyAudio Member
 
Join Date: Jul 2007
Quote:
Originally Posted by chago25 View Post
its not only working great its powerful also!
what voltage did you use and was the outputs heating ?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Philips 40/25/15 watts amplifier with Universal preamplifier circuit. renjiish Solid State 64 28th July 2014 11:33 AM
Decibel Watts VS Watts ? fivestring Solid State 11 1st April 2009 01:08 PM
AMP1-B: why only 25 watts @8ohms? theAnonymous1 Class D 10 15th August 2005 06:55 PM
Sound quality of amps at 0.3 watts vs @ typical 5 watts rick57 Solid State 2 26th March 2005 06:25 AM
Need 2 watts Vivek Everything Else 4 17th July 2003 08:29 AM


New To Site? Need Help?

All times are GMT. The time now is 06:04 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2