diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Class D (http://www.diyaudio.com/forums/class-d/)
-   -   IR2010 amplifier-New Project (http://www.diyaudio.com/forums/class-d/112696-ir2010-amplifier-new-project.html)

zox2003 28th November 2007 02:43 AM

IR2010 amplifier-New Project
 
2 Attachment(s)
After I played with IR2104(IR2104 and IRF540) and got him up and running I decided to do some corrections in circuit and build new amp using IR2010 as MOSFET driver.Currently I am working on modulator schematic (attached).

Any comments or suggestions are very welcome.

Thanks

lindomar 28th November 2007 09:47 AM

Hi... and power estage, not included in circuit?

-_nando-_ 28th November 2007 01:20 PM

Quote:

Originally posted by lindomar
Hi... and power estage, not included in circuit?
Do you see any power stage in the circuit? So, OF COURSE that there's NO power stage included. :gnasher:

zox2003 28th November 2007 01:25 PM

Like I said this is just modulator.Power stage is made with IR2010 and pair of IRF540's.

I have second version of modulator using LM311M and CD4069 invertor.

What is your suggestion? This schematic or combination of LM311 and CD4069?

Some people reported "ringing" effect from LT1016 because of his speed...


Thanks

Bender.ru 28th November 2007 01:31 PM

Imho LM311 would-be quite enough for selfoscillating topology :)

zox2003 28th November 2007 01:38 PM

Also today I am getting samples from TI of TL3016 which is drop in replacement for LT1016 but some people reported better results with TL then with LT1016...

Thanks

zox2003 28th November 2007 08:51 PM

Any comments or suggestions?

maverick_123 29th November 2007 02:08 PM

can you post your power stage schematic. I'am currently working with the IR2110 and it's not power up the mosfets. The are not even warm with no load connected to them

zox2003 29th November 2007 02:41 PM

I am using IR2010 not IR2110.

zox2003 3rd December 2007 04:26 AM

OK,

i have first results which are not very good.
Let me explain my chain (it got changed from original schematic):
My modulator is LM311 and CD4069 (inverter).Feedback goes form output (speaker) terminal to non-inverting input of LM311.Audio input is on Inverting input of LM311.Output is IR2010+pair of IRF540's.

Sound I got from this amp sounds kind of distorted.I can not really say at this point how much but maybe a little bit.My output fets are getting really hot (even on low audio input) and my 12V regulator (78m12-SMD version 0.5A) is getting hot too-regulator is used for IR2010 and CD4069 inverter.

Any help?

Regards


All times are GMT. The time now is 06:52 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2