Go Back   Home > Forums > > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Twisted Pear Superior quality electronic kits

Reply
 
Thread Tools Search this Thread
Old 19th February 2018, 02:10 AM   #1
MWL168 is offline MWL168  United States
diyAudio Member
 
Join Date: Oct 2005
Default Issue using Cronus/Hermes/Amanero with Soekris DAM1021 DAC

Hi All:

I need help with an issue using the Cronus/Hermes/Amanero with a Soekris DAM1021 DAC when playing music from YouTube.

The source is a MacBook Pro. I either play music through Audirvana or use a Chrome browser to play videos from YouTube on this Mac .

The DAM1021 runs on a +/- 9.3VDC PSU and the Cronus/Hermes runs on its own 6.5VDC PS.

When I play music with Audirvana, the whole setup runs perfectly fine. Solid lock to the i2s signal on all resolutions and beautiful music.

The problem comes when I play music from YouTube. The i2s lock is not stable with many irregular drop-outs lasting fraction of a second. Interestingly, the drop-out frequency varies from video to video, some videos consistently do worse than the others.

The odd thing is that if I play those same videos on YouTube using the same USB output on the Mac and through a USB-SPDIF converter and feed the SPDIF into the DAM1021, I have solid lock and no drop-out at all.

I can also play videos on YouTube through my dual-mono Buffalo II via another Cronus/Hermes/Amanero (a newer version than the one I am using with the DAM1021) with solid lock and no drop-out.

I have been able to consistently recreate all the above scenarios. There must be a logical explanation to this seemingly mystery. Can someone shed lights on what's going on and how to resolve this issue?

Thanks!


EDIT: forgot to mention that the same setup plays YouTube videos fine with solid lock using Amanero (same one I am using with Cronus/Hermes now) alone.

Last edited by MWL168; 19th February 2018 at 03:11 AM.
  Reply With Quote
Old 19th February 2018, 08:56 AM   #2
miero is offline miero  Czech Republic
diyAudio Member
 
Join Date: Jun 2011
Location: Prague
what clock is DAM1021 using if it is connected to Cronus? I guess there were some specific requirement (differential signal?) that might not be compatible with Cronus...
__________________
BeagleBone Black with I2S, DSD and SPDIF interface (Linux driver)
http://bbb.ieero.com/
  Reply With Quote
Old 19th February 2018, 01:20 PM   #3
MWL168 is offline MWL168  United States
diyAudio Member
 
Join Date: Oct 2005
Hi Miero:

The DAM1021 uses a Si514 for the clock and a FIFO reclocker. The i2s is also isolated.

I know the Cronus/Hermes is probably an overkill in this case but I have an extra one from my Buffalo DAC project two years ago anyway.

What puzzles me is that it works fine with Audirvana and iTune, the drop-out only occures when playing YouTube. I tried Amazon streaming and experience similar drop-out but to a much lesser degree.
  Reply With Quote
Old 19th February 2018, 01:45 PM   #4
miero is offline miero  Czech Republic
diyAudio Member
 
Join Date: Jun 2011
Location: Prague
Does it happen for both 44.1fs and 48fs?
__________________
BeagleBone Black with I2S, DSD and SPDIF interface (Linux driver)
http://bbb.ieero.com/
  Reply With Quote
Old 19th February 2018, 02:40 PM   #5
MWL168 is offline MWL168  United States
diyAudio Member
 
Join Date: Oct 2005
Sorry I am not able to ascertain.

I believe YouTube re-encode uploads to 44.1KHz. I was not able to find information about Amazon.

I have music with 96KHz, 192KHz and DSD128 on my Mac and they play fine through iTune and Audirvana fine with the Cronus.
  Reply With Quote
Old 19th February 2018, 06:01 PM   #6
miero is offline miero  Czech Republic
diyAudio Member
 
Join Date: Jun 2011
Location: Prague
OK. Try to remove 48fs clock from Cronus if the sound will be playing from Youtube. It is possible that incorrect clock is being used for 44.1fs. If Youtube will not play then this might be the case.

Notice: I'm not sure if this would work, if it does not then try to swap clocks on Cronus with each other.
__________________
BeagleBone Black with I2S, DSD and SPDIF interface (Linux driver)
http://bbb.ieero.com/

Last edited by miero; 19th February 2018 at 06:03 PM.
  Reply With Quote
Old 19th February 2018, 07:26 PM   #7
MWL168 is offline MWL168  United States
diyAudio Member
 
Join Date: Oct 2005
Thanks Miero.

Unfortunately it’s not easy for me to remove or swap the clocks on my Cronus because I mistakenly soldered them directly on the Cronus board.

I plan to swap the Cronus/Hermes in my Buffalo DAC to use with the DAM1021 to see if that works and report back. This Cronus is the newer version with the buffered clock output.

I should mention I have many content in iTune that’s 44.1KHz frequency family and the Cronus has no issue choosing the correct clock.

Anything else do you recommend me trying?

Last edited by MWL168; 19th February 2018 at 07:29 PM.
  Reply With Quote
Old 19th February 2018, 09:01 PM   #8
Russ White is offline Russ White  United States
diyAudio Member
 
Russ White's Avatar
 
Join Date: Jan 2005
Location: Nashville, TN, USA
If it's selecting the right clock - I would start maybe trying alternate amanero firmware? It sounds possibly a driver/firmware issue with that particular type of source.
__________________
Less pulp more juice Twisted Pear
Audio
/Twisted Pear Audio Blog
  Reply With Quote
Old 19th February 2018, 09:44 PM   #9
MWL168 is offline MWL168  United States
diyAudio Member
 
Join Date: Oct 2005
Thanks Russ.

The Amanero in question is currently running “Slave_For_1080” CPLD and “firmware_1096c” CPU firmware as instructed on the Hermes-Amanero thread. Which firmwares do you suggest I try?
  Reply With Quote
Old 19th February 2018, 10:05 PM   #10
Russ White is offline Russ White  United States
diyAudio Member
 
Russ White's Avatar
 
Join Date: Jan 2005
Location: Nashville, TN, USA
I am not sure since I don't have your DAC to try - I would experiment.
__________________
Less pulp more juice Twisted Pear
Audio
/Twisted Pear Audio Blog
  Reply With Quote

Reply


Issue using Cronus/Hermes/Amanero with Soekris DAM1021 DACHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: BeagleBone Black, Hermes, Cronus Thomas Giz Swap Meet 3 18th February 2018 02:32 PM
DSD256 not playing - BBB Hermes, Cronus, B3SE HeadSh0T Twisted Pear 0 8th February 2017 04:04 AM
Soekris DAM1021 and Amanero I2S - No Lock vdi_nenna Digital Line Level 3 24th March 2016 10:55 PM
WTB Soekris dam1021 + amanero alexanderfa Swap Meet 2 9th November 2015 11:55 PM
WTB - Soekris DAM1021 0.05% and Amanero rol Swap Meet 0 22nd February 2015 08:43 AM


New To Site? Need Help?

All times are GMT. The time now is 08:45 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki