Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

SCA 35 troubleshooting
SCA 35 troubleshooting
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th July 2019, 01:22 PM   #1
rkoonce is offline rkoonce  United States
diyAudio Member
 
Join Date: Aug 2006
Location: Texas
Default SCA 35 troubleshooting

I rescued a basket case Dynaco SCA 35 integrated amp with completely shot EL-84s. They had all four been very hot, one hot enough to crack the glass, and the other three with no getter left, only a rusty red residue in the top of the tube. I replaced the output tubes and capacitors, and the 12AX7s and 7199s were still good. The amp plays nicely after I cleaned all the pots and switches, but gain between channels varies with frequency. I can adjust the balance control at a single frequency to get equal output voltages, but that won't work with music. Any ideas what to check?

Thanks!
  Reply With Quote
Old 28th July 2019, 03:27 PM   #2
petertub is offline petertub  Sweden
diyAudio Member
 
Join Date: Jul 2015
Location: gothenburg,sweden
SCA 35 troubleshooting
It could be the PEC's ( the think units containing the tone-control components. It could also be something broken in one or both power stages.
To isolate disconnect the volume pot wiper and inject signal in the wire disconnected.

Connect a tone-generator and measure the output at the speaker connections ( must have a load, speaker or resistive 8ohm). Inject 40hz, 1000hz 5khz 10khz and note the values.
Repeat with other channel. If the channels are equal you might build a pair of PEC
equivalants and replace the existing ones.
If the channels are unequal you have a problem in one or both power stages, but you have at least isolated the problem by reducing the area.
Go work and report back!
__________________
My home is at www.tubular-well.se
  Reply With Quote

Reply


SCA 35 troubleshootingHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
troubleshooting amp kblee Chip Amps 0 18th July 2012 06:51 PM
need help troubleshooting an amp emremeydan Solid State 12 28th January 2008 10:16 PM
Zen V8 Troubleshooting moe29 Pass Labs 13 20th March 2006 03:44 PM
troubleshooting my new dac DaKi][er Digital Source 25 18th July 2005 09:00 AM
I would appreciate your help in troubleshooting my dac. protos Digital Source 17 29th December 2004 01:37 PM


New To Site? Need Help?

All times are GMT. The time now is 07:52 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki