Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

USSA-5 Build with Review
USSA-5 Build with Review
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old Today, 11:39 AM   #1031
nikosokey is offline nikosokey  Greece
diyAudio Member
 
nikosokey's Avatar
 
Join Date: Sep 2009
Location: Αrta-Greece
Quote:
Originally Posted by meanie View Post
Thanks, Fab!

Something happened when I was trying to increase bias, my meter show the reading jumping back and forth between 65mA and 58mA.

Then I realized I had a bad quality pot (P1,P2), so I had to strip the amp again and replace the pots.

Pls use quality brands like Bourne, you will get fewer issues in the long run.

Hi Meanie
i have the same issue.... cold welding bad join on trimmer Vishay ...solved..
T93YA102KT20 Vishay / Sfernice | Mouser Greece
my measurements were slowly coming to me...
__________________
Titan 2000 ,Cressendo Millenium 2000, P3A ,VSSA ΤΟ3 ,B1 Buffer ,Golmund Mimesis 9.2 Clone ,Preamplifier Dispre 2 - JFET, DCB1 SALAS, D-Reflector, BibFet, Buffalo II,ES9018K2M, Arduino LDR Volume, AK4490 Discrete Mirand Audio,SSHV2, 6V6 Salas Preamp.

Last edited by nikosokey; Today at 12:01 PM.
  Reply With Quote
Old Today, 11:48 AM   #1032
meanie is offline meanie  Singapore
diyAudio Member
 
Join Date: Jul 2018
Location: Singapore
Quote:
Originally Posted by nikosokey View Post
Hi Meanie
i have the same issue.... cold welding bad join ...solved..
my measurements were slowly coming to me...
I will recheck while changing the pots.

It was working fine @1.3A till this attempt to increase bias...
__________________
Marantz 7 clone - BA3FE - Yarra/Melbourne Preamp - USSPA - Korg Nutube - BabyHuey EL34s - 2ACAs - F6 - M2XSLB - 2Whammy -
USSA5SLB
  Reply With Quote

Reply


USSA-5 Build with ReviewHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd Watt Audio Alpha Build and initial review cgnman59 Tubes / Valves 6 26th April 2017 04:12 AM
SMPS vs LINEAR PS: Let's build up a serious technical review-list Centvrion Power Supplies 18 7th March 2011 05:09 AM
Honest opinion (peer review) about this 4Way before I build it Yoshy Multi-Way 54 16th December 2010 07:37 AM


New To Site? Need Help?

All times are GMT. The time now is 04:33 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki