Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

Amp on Fire!
Amp on Fire!
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th December 2001, 04:22 AM   #1
peter5 is offline peter5
diyAudio Member
 
Join Date: Jun 2001
Smile Amp on Fire!

I'm trying to figure out what I did wrong the FIRST time I built my Leach amp...

I have bare aluminum heatsinks for the TO-3 transistors. Right now I am using rubber insulators and aluminum screws to fasten the transistors to the heatsink. I know this is wrong because I am shorting the +Vcc and -Vcc to the grounded heatsink.

I know this is a newbie question, but how do I electrically and physically connect the transistor socket (on other side of heatsink) to the collector of the transistor without touching the heatsink?

Thanks.

Pete
  Reply With Quote
Old 28th December 2001, 05:31 AM   #2
GRollins is offline GRollins  United States
diyAudio Member
 
Join Date: Feb 2001
Location: Columbia, SC
Pete,
Assuming that I'm visualizing what you're describing correctly, the solution is easy and cheap. They make little plastic cylinders that slide over the base and emitter pins of the transistor and keep them from contacting the heasink. The transistor itself sits on a mica insulator that takes care of the collector. There are newer insulators that some folks here like. Go find one of the threads on them. Berylium oxide, I think, and silicone, and probably something new by tomorrow.

Grey
  Reply With Quote
Old 28th December 2001, 06:02 AM   #3
Damon Hill is offline Damon Hill  United States
diyAudio Member
 
Join Date: Mar 2001
Location: Auburn, WA (somewhere between Seattle and Tacoma)
Send a message via ICQ to Damon Hill
If you tighten the screws too much on silicon rubber
insulators, it's very possible that the sharp corners of the holes in the heatsink will bite through the insulators and short the supply rails to ground.

Mica insulators almost can't be damaged by this method; at any
rate, put on new insulators and test the supply rails with an
ohmmeter before you procede further.

Also, the sockets themselves should have shoulders that align
with the holes in the heatsink and precisely space the mounting
screws so they won't touch the heatsink.

Been there before, believe me.
  Reply With Quote
Old 5th January 2002, 02:11 PM   #4
Herman is offline Herman  Germany
diyAudio Member
 
Join Date: May 2001
Location: Europe
Talking Transistor insulators

For the base and emitter pins of the transistors, I prefer heat shrinking tube. For the collector, I use a soldering terminal tag (that washer with a solderable extension...). To make everything safe, you can even use plastic screws !!!

Good luck!
Herman
  Reply With Quote
Old 5th January 2002, 04:12 PM   #5
subwo1 is offline subwo1  United States
diyAudio Member
 
subwo1's Avatar
 
Join Date: Jan 2002
Location: North American Continent
Peter, you also need to slide shoulders over the screws to prevent the heads from shorting the TO-3 cases to the heatsinks. I prefer transistors in insulated cases because they are simple to mount.
  Reply With Quote
Old 5th January 2002, 04:42 PM   #6
PassFan is offline PassFan  United States
diyAudio Member
 
Join Date: Aug 2001
Location: Central FL
And always, always, always check your output drivers to ground before you power up. Use the highest resistance setting you have. I always check mine as I mount them. They cost too much to blow.
  Reply With Quote
Old 7th January 2002, 11:35 AM   #7
Musher is offline Musher
diyAudio Member
 
Join Date: Dec 2001
Location: Vantaa/Finland
For me mounting TO3 transistors has been simple. A parts dealer here sells kind of "TO3 kits" which contain two screws, two spring washers, two nuts, one washer with solderable extension, a mica insulator and two plastic washers.

Now, it's mounted like this. The diamond-shaped mica insulator has a 4mm hole in each end, and two 3mm holes for emitter and base pins. These are marked onto the heatsink, and drilled. I just use a 4mm bit for all 4 holes. And as Prof. Leach recommends, I spin a bigger drill bit by hand in every hole to remove any burrs and sharp edges.

I coat the transistor's "bottom" with silicone grease, put mica insulator in place and then spread some silicone grease to the insulator's yet uncoated side.

Then the transistor is put in place. The plastic washers go into the two holes where the screws will go (that is, on the opposite side of the HS from transistor's viewpoint). Before that, the washer-with-solderable-extension goes next to one screw's butt _on_ the plastic washer which 1. aligns the 3mm screw in the 4mm hole so that it, carrying collector current, will not touch the grounded heatsink and 2. prevents the extended washer from touching the heatsink, being between them.

Then the spring washers and nuts are put on the transistor's "top" side and fastened. Just for additional security, I put short, about 1/3" pieces of insulator from a wire to the emitter and base legs, so that they will not touch the heatsink 1. if the transistor happens to move/misalign itself before being fastened or 2. they get bent accidentally.

This will also gain some forgiveness if the holes in the heatsink were misplaced by just one mm in the first place.

I've started buying the mounting parts separatedly now, because that way it's much cheaper.

-Kimmo S.
  Reply With Quote

Reply


Amp on Fire!Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Which way to fire my sub? Gorbee Subwoofers 24 12th September 2006 12:59 AM
Why did my amp start on fire? soundNERD Chip Amps 39 30th October 2004 03:33 PM
fire up Aleph 30 wijgers Pass Labs 14 28th April 2004 03:42 PM
Amp on fire Ford_V6 Solid State 12 2nd April 2003 12:27 PM


New To Site? Need Help?

All times are GMT. The time now is 10:28 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio
Wiki