diyAudio

diyAudio (https://www.diyaudio.com/forums/index.php)
-   Analogue Source (https://www.diyaudio.com/forums/analogue-source/)
-   -   33 speed problem on a Technics SL-QL1 (https://www.diyaudio.com/forums/analogue-source/48796-33-speed-technics-sl-ql1.html)

mattjk 1st January 2005 07:52 PM

33 speed problem on a Technics SL-QL1
 
I have an old Technics SL-QL1 direct drive turntable. The 33 speed is a bit slow. The pitch light moves counter-clockwise at a steady pace... about 2 - 3 bars a second. In 45 speed, it is rock solid.

Is this something that I can repair myself without a frequency counter?

I have done some searching around the net, and found that the powersupply caps may be bad. I have checked and none of them or bulging or leaking.

Please let me know if you can help.

Thank you for your time,
Matt

mattjk 20th January 2005 01:02 AM

Bump!

I have tried replacing the power supply caps. No go.

Any other ideas???

dieselpower 21st January 2005 03:32 PM

Matt
Do you have a service manual? This might help, not sure. I just got one off of ebay yesterday for my Technics SL-220.

check out this link:
http://stores.ebay.com/Quag-West-Vin...Q3amesstQQtZkm

Netlist 21st January 2005 05:48 PM

Many Technics turntables have speed presets inside.
Don't know about this one though.

/Hugo :)


All times are GMT. The time now is 04:50 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 17.65%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©1999-2019 diyAudio

Wiki