diyAudio

diyAudio (https://www.diyaudio.com/forums/index.php)
-   Solid State (https://www.diyaudio.com/forums/solid-state/)
-   -   DC Offset with Cap Coupled Amp (https://www.diyaudio.com/forums/solid-state/377343-dc-offset-cap-coupled-amp.html)

dbxdx5 22nd September 2021 07:14 PM

DC Offset with Cap Coupled Amp
 
1 Attachment(s)
I'm working on an H.H. Scott 348 that initially had a problem with very unstable bias in one channel. (See this thread.) The bias issue turned out to be the due to someone before me inserting a cap backwards in the tone circuit. The bias in both channels now adjusts properly and is relatively stable.

Next I replaced the two 2,000uF output caps, as well as the 1000uF cap that handles the 70V B3+ for the amp boards. I hadn't checked the DC offset prior to doing this, so I have no point of comparison for what I found next. With an 8 ohm dummy load hooked up, I'm seeing DC spikes at the speaker terminals of more than 300mV in one channel and 200mv in the other. My understanding is that, with the circuit loaded, I shouldn't be seeing any DC through these output caps, let alone spikes that high. Thoughts?

rayma 22nd September 2021 07:21 PM

By spikes, do you mean while adjusting the balance pot, or otherwise?

Osvaldo de Banfield 22nd September 2021 07:32 PM

With some kind of amps you will allways have a steady dc offset because a part of driver's current flows though the voice coil. See R18 from the feedback network. But not spikes.

What kind of such spikes do you refer to? (Frequency, amplitude. Duration, etc.).

dbxdx5 22nd September 2021 08:45 PM

Quote:

Originally Posted by rayma (https://www.diyaudio.com/forums/solid-state/377343-dc-offset-cap-coupled-amp-post6793857.html#post6793857)
By spikes, do you mean while adjusting the balance pot, or otherwise?


I have two bench DMMs hooked up to the dummy load to observe the DC. One of the meters has a peak setting, and with that enabled I saw over 300mV on one channel. When I switched it to the other channel, the peak DC offset was over 200mV. I didn't touch any of the controls, volume at minimum.


Quote:

Originally Posted by Osvaldo de Banfield (https://www.diyaudio.com/forums/solid-state/377343-dc-offset-cap-coupled-amp-post6793870.html#post6793870)
With some kind of amps you will allways have a steady dc offset because a part of driver's current flows though the voice coil. See R18 from the feedback network. But not spikes.

What kind of such spikes do you refer to? (Frequency, amplitude. Duration, etc.).


The DC offset is fluctuating, which isn't unusual. What's odd is that I'm getting spikes/peaks of high DC several times a minute. I had test speakers hooked up briefly, and there was audible intermittent noise, which I assume is what I'm seeing on my meters. I'll hook up my scope to the dummy load and see if I can take a few photos of what it shows.

Osvaldo de Banfield 22nd September 2021 09:37 PM

Clearly the amp is oscillating at a low frequency rate, usually called motorboating. Check all bypass caps in the power buses. Eventually replace them one by one testing between.

dbxdx5 22nd September 2021 09:53 PM

1 Attachment(s)
Thanks, though I could use some help understanding which caps would be the bypass caps in the power supply.

Osvaldo de Banfield 22nd September 2021 10:37 PM

C404 seems to be small for such an ampifier. In any case try to disconnect the amp from the pre at C3 to see which of them are causing the trouble.

JMFahey 22nd September 2021 10:49 PM

Quote:

With an 8 ohm dummy load hooked up, I'm seeing DC spikes at the speaker terminals of more than 300mV in one channel and 200mv in the other. My understanding is that, with the circuit loaded, I shouldn't be seeing any DC through these output caps, let alone spikes that high. Thoughts?
Please SHOW them

Hook scope there and post screen image.

How else can we see waveform, amplitude, width, frequency, to answer you?

dbxdx5 23rd September 2021 12:58 AM

1 Attachment(s)
Quote:

Originally Posted by Osvaldo de Banfield (https://www.diyaudio.com/forums/solid-state/377343-dc-offset-cap-coupled-amp-post6794069.html#post6794069)
C404 seems to be small for such an ampifier. In any case try to disconnect the amp from the pre at C3 to see which of them are causing the trouble.

Ah well, I probably should have upped the capacitance of C404 when I replaced it, but I kept it at 1,000uF.

Looks like C1 is the input from the pre, so I'll try disconnecting there. Thanks Osvaldo.

Quote:

Originally Posted by JMFahey (https://www.diyaudio.com/forums/solid-state/377343-dc-offset-cap-coupled-amp-post6794075.html#post6794075)
Please SHOW them

Hook scope there and post screen image.

How else can we see waveform, amplitude, width, frequency, to answer you?


Thanks so much for weighing in Fahey.

The peaks that I've measured occur so quickly that I can't snap a photo of my old analog scope screen fast enough to capture them.

indianajo 23rd September 2021 03:01 AM

These sudden DC shifts can be caused by bad solder joints, bad resistors capacitors transistors or diodes, etc. Heard as pops.
If you have a scope, then you can trace by looking where the pops or DC shifts first occur. You'll need bigger gain towards the front than near the back.
Then at the stage where the pops start, look for bad connections around there. Push on solder joints with a stick.
If it is in a part ( and not unusual for parts in 1965) a heat gun or circuit cool spray may excite them to misbehave differently.
Certainly look at the power supply outputs with the scope. If the power supply voltages are not steady DC, then nothing else can amplify silently.
HHScott was reputed to use AB military grade carbon comp resistors, which I have found to be pretty reliable. Hammond organs are full of them. The one defect they have is that high value ones (over 100k) can experience moisture leak in and decrease the value.
The usual suspect on 50 year old amps is the electrolytic capacitor. Rubber sealed ones are particularly destined to a bad end. There were some sardine tin models that Hammond used that last nearly forever, but most other brands the seal that keeps the water in is some sort of elastomer. 1965 elastomers were nothing to respect greatly. Electrolytic caps are the ones with a plus & minus, a straight and curved plate. The actual part will have a plus on one end. If removing mark the board with plus so as to not put the replacement in backwards. Parts are available now with service lives up to 10000 hours, which should be fairly permanent. These high rated electrolytic capacitors have quite respectable elastomers as sealant.
But 1965 diodes & transistors were subject to dust & dirt floating around the fab areas, and much more likely to be popping than modern parts. Welds inside diodes & transistors were made by humans in 1965 too, with variable results.
Don't neglect the potentiometer, which can connect or lose connection wiper to track randomly in old age. This includes the volume pot, subject to high wear.
Thanks for posting schematics. I've never seen a used survivor HH Scott model <$150. I've never owned one.
Happy hunting.


All times are GMT. The time now is 11:11 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright ©1999-2021 diyAudio

Wiki