diyAudio

diyAudio (https://www.diyaudio.com/forums/index.php)
-   PA Systems (https://www.diyaudio.com/forums/pa-systems/)
-   -   Fixing a broken D&R700 mixer (https://www.diyaudio.com/forums/pa-systems/346117-fixing-broken-r700-mixer.html)

Arian 2nd December 2019 09:10 PM

Fixing a broken D&R700 mixer
 
Hello, this is my first post here and first of all i would like to express how glad i am to have found this forum.

A few months ago i purchased an old D&R700 mixer. It was dirt cheap and i figured that fixing it up would be a good learning experience.

Now iam at my wits end with it. I opened it up, checked the wires, measured the meters, checked the circuitbords and looked at every little part looking for signs of damage. I even tried connecting it ungrounded.

So what is the problem? Well the main left channel is constantly peaking even when no audio is plugged in. I tried individual channels and none of them seem to be responsible except the main left.
The left gives a combination of the typical electric buzzing sound, hissing and crackling.

Does anyone here have an idea what i should be looking for?

I am only a beginner and learning everything on the go so any input is helpful even if it doesnt pan out.

MAAC0 2nd December 2019 10:37 PM

You have to trace the signal and find were it gets bad. Feed signal in some channels and check signal were it enters the main audio pots. If You have a good signal there then the problem is on the output section. Have You cleaned pots / faders already ? Perhaps it's just a faulty output op-amp that was zapped probably by some phantom adapter. Trust me semiconductors look OK even when faulty, unless there is catastrophic failure and they burn / explode.

rayma 2nd December 2019 11:44 PM

Schematics here: https://www.d-r.nl/assets/700-seriesmanual_new.pdf

Clean all the pots/switches, measure the power supply voltages, and start signal tracing.
There are good block diagrams and schematics in the manual. It may need some of the
many electrolytic capacitors replaced. The LED driver chip could be bad. There will be
multiple problems, certainly.

Enzo 3rd December 2019 02:19 AM

SOunds like an op amp stuck on DC in the master section.

All those 8-leg ICs are likely dual op amps, so pins 1 and 7 are outputs. Go down them and check pins 1 and 7 for DC.

rayma 3rd December 2019 02:23 AM

Quote:

Originally Posted by Enzo (https://www.diyaudio.com/forums/pa-systems/346117-fixing-broken-r700-mixer-post5995359.html#post5995359)
SOunds like an op amp stuck on DC in the master section.

There's a coupling capacitor before the LED chip.

Arian 3rd December 2019 09:07 PM

Thanks, sounds like one hell of a job. Hopefully nothing too expensive needs replacing. I did check the direct outs and i measured the pots, found no issues there. As for the rest i will have to clear my schedule it seems.

indianajo 3rd December 2019 10:08 PM

I just repaired a $35 PV8 mixer off ebay. Master volume slide pot was worn out. Duh. $3 from newark. $2 in 2mm x10mm screws to screw pot to front panel. Bypassed Peavey's custom mount for pot from the board.
Left channel dead after input clip LED's on 8 inputs. No left volume indication, no left headphone out, no left master out, no left monitor out, no left tape out.
Culprit was a broken via through the board. $0. Good as new. Ran a 28 ga wire from one component pad to a capacitor lead.
New PV10 are $379.
Traced music from FM radio earphone through the circuit with a Simpson 266XLPM meter on 2.5 VAC scale. Used a component lead in an alligator clip lead as a probe. Used the ring of a RCA plug plugged in output as analog ground for meter. Use a .47 uf cap in series with negative clip lead else analog meters respond to DC on AC scales. AC is music.
Didn't have a schematic. Datasheet on op amp IC's showed where in, out, feedback(minus in) are. Place the music stopped was the problem. Used 3 strengths reading glasses & mechanic's light to get good look at it.
Didn't have to learn how to solder surface mount IC's resistors & capacitors to board. Very scary technique to a 69 year old. Wasn't the problem.

Arian 3rd December 2019 10:24 PM

I soldered some parts onto a circuit board once. Thats about it. Sounds like i may need to educate myself a bit more before i mess with this and break something.

MAAC0 3rd December 2019 11:04 PM

Simple design. It could be as simple as a dirty switch / jack. Take this approach first. Check the jack solder pads also. From many inserts they can be broken. If You can't find the fault take it to an electronic minded friend.


All times are GMT. The time now is 08:57 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 17.65%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright ©1999-2020 diyAudio

Wiki